Ask Your Question

slosh_liuxin's profile - activity

2017-12-05 21:13:36 -0600 received badge  Popular Question (source)
2017-12-04 19:59:46 -0600 asked a question modify default settings of lbaas haproxy

My openstack version is kilo,then i found that i can't modify the default settings of lbaas haproxy with "timeout" parameter.Such as like this:

    defaults
        log global
        retries 3
        option redispatch
        timeout connect 5000
        timeout client 50000
        timeout server 50000

    I want to raise 5000 --- 50000 and 50000--->500000,but when i change the conf with current lbaas conf and restart neutron-lbaas.service,there is not changed!
    I do not found a working way to slove this problems.
    Can anyone help me?Thanks very much!

List item

2017-03-23 13:41:32 -0600 received badge  Famous Question (source)
2017-03-23 13:41:32 -0600 received badge  Notable Question (source)
2016-12-02 07:48:41 -0600 received badge  Famous Question (source)
2016-09-14 07:38:50 -0600 received badge  Famous Question (source)
2016-08-03 17:23:23 -0600 received badge  Famous Question (source)
2016-06-10 02:07:08 -0600 received badge  Famous Question (source)
2016-06-10 02:07:08 -0600 received badge  Notable Question (source)
2016-05-19 04:34:41 -0600 received badge  Notable Question (source)
2016-05-11 23:06:07 -0600 received badge  Notable Question (source)
2016-03-18 14:29:39 -0600 received badge  Notable Question (source)
2016-03-18 12:00:42 -0600 received badge  Famous Question (source)
2016-03-16 03:09:28 -0600 received badge  Famous Question (source)
2016-03-08 15:38:54 -0600 received badge  Popular Question (source)
2016-02-29 15:00:38 -0600 received badge  Popular Question (source)
2016-02-25 17:57:42 -0600 asked a question instances cant not get private network ip address

Hi, In openstack kilo,all services were fine.But,when i lanuch an instance,i got errors like this in the openvswitch-agent.log:

2016-02-25 14:49:27.315 68239 ERROR neutron.agent.linux.utils [req-c60bce66-f76d-479a-9fae-1ebfab805f35 ]
Command: ['sudo', 'neutron-rootwrap', '/etc/neutron/rootwrap.conf', 'ovs-ofctl', 'dump-flows', 'br-int', 'table=23']
 Exit code: 1
Stdin:
Stdout:
Stderr: ovs-ofctl: br-int is not a bridge or a socket

 2016-02-25 14:49:27.317 68239 ERROR neutron.agent.common.ovs_lib [req-c60bce66-f76d-479a-9fae-1ebfab805f35 ]   Unable to execute ['ovs-ofctl', 'dump-flows', 'br-int', 'table=23']. Exception:
 Command: ['sudo', 'neutron-rootwrap', '/etc/neutron/rootwrap.conf', 'ovs-ofctl', 'dump-flows', 'br-int', 'table=23']
 Exit code: 1
 Stdin:
 Stdout:
 Stderr: ovs-ofctl: br-int is not a bridge or a socket
 2016-02-25 15:01:22.006 68239 ERROR neutron.agent.linux.ovsdb_monitor [-] Error received from ovsdb monitor: ovsdb-client: unix:/var/run/openvswitch/db.sock: receive failed (End of file)
 2016-02-25 15:01:23.005 68239 WARNING neutron.plugins.openvswitch.agent.ovs_neutron_agent [req-c60bce66-f76d-479a-9fae-1ebfab805f35 ] OVS is restarted. OVSNeutronAgent will reset bridges and recover ports.






  And also i fine some errors in the /var/log/messages like this:
  Feb 26 07:45:03 compute01 kernel: qbr64549e78-56: port 2(tap64549e78-56) entered disabled state
  Feb 26 07:45:03 compute01 kernel: device tap64549e78-56 left promiscuous mode
  Feb 26 07:45:03 compute01 kernel: qbr64549e78-56: port 2(tap64549e78-56) entered disabled state
  Feb 26 07:45:03 compute01 NetworkManager[74884]: <info>  (tap64549e78-56): device state change: activated -> unmanaged (reason 'removed') [100 10 36]
  Feb 26 07:45:03 compute01 NetworkManager[74884]: <info>  (tap64549e78-56): deactivating device (reason 'removed') [36]
  Feb 26 07:45:03 compute01 NetworkManager[74884]: <warn>  (qbr64549e78-56): failed to detach bridge port tap64549e78-56
  Feb 26 07:45:03 compute01 dbus[3025]: [system] Activating via systemd: service name='org.freedesktop.nm_dispatcher' unit='dbus-org.freedesktop.nm-dispatcher.service'


 I donn't find where is my mistake.So,i need help for solve the errors.....Thans for any help!
2016-02-24 16:10:01 -0600 received badge  Popular Question (source)
2016-02-24 01:29:35 -0600 received badge  Famous Question (source)
2016-02-23 17:47:45 -0600 commented answer cinder list ERROR: Unauthorized (HTTP 401)

Thank you very much!I solved this error,it is my fault!

2016-02-23 17:47:45 -0600 commented answer cinder list ERROR: Unauthorized (HTTP 401)

Thank you very much!I solved this error,it is my fault!

2016-02-23 17:45:16 -0600 received badge  Notable Question (source)
2016-02-23 02:46:48 -0600 commented question cinder list error

Hi,thanks teju!I fix the problem!It is my conf file was wrong....cinder-api service use two conf file..BTW,thank u very much for helping me to fix my problems!

2016-02-22 23:27:13 -0600 commented question cinder list error

Yes,i use admin user to login the dashboard.But i got the same error: WARNING keystonemiddleware.auth_token [-] Unable to find authentication token in headers

2016-02-22 18:50:26 -0600 asked a question cinder list error
  Hi,my openstack is kilo.I click any button in dashboard like volumes,access & security or the network tables,all the same error like this:

 [Tue Feb 23 08:44:00.383587 2016] [:error] [pid 45685] Traceback (most recent call last):
[Tue Feb 23 08:44:00.383595 2016] [:error] [pid 45685]   File "/usr/lib/python2.7/site-packages/horizon/tables/base.py", line 1260, in _filter_action
[Tue Feb 23 08:44:00.383600 2016] [:error] [pid 45685]     return action._allowed(request, datum) and row_matched
[Tue Feb 23 08:44:00.383605 2016] [:error] [pid 45685]   File "/usr/lib/python2.7/site-packages/horizon/tables/actions.py", line 136, in _allowed
[Tue Feb 23 08:44:00.383610 2016] [:error] [pid 45685]     self.allowed(request, datum))
[Tue Feb 23 08:44:00.383619 2016] [:error] [pid 45685]   File "/usr/share/openstack-dashboard/openstack_dashboard/wsgi/../../openstack_dashboard/dashboards/project/networks/tables.py", line 94, in allowed
[Tue Feb 23 08:44:00.383626 2016] [:error] [pid 45685]     usages = quotas.tenant_quota_usages(request)
[Tue Feb 23 08:44:00.383631 2016] [:error] [pid 45685]   File "/usr/lib/python2.7/site-packages/horizon/utils/memoized.py", line 90, in wrapped
[Tue Feb 23 08:44:00.383661 2016] [:error] [pid 45685]     value = cache[key] = func(*args, **kwargs)
[Tue Feb 23 08:44:00.383668 2016] [:error] [pid 45685]   File "/usr/share/openstack-dashboard/openstack_dashboard/wsgi/../../openstack_dashboard/usage/quotas.py", line 349, in tenant_quota_usages
[Tue Feb 23 08:44:00.383674 2016] [:error] [pid 45685]     tenant_id=tenant_id):
[Tue Feb 23 08:44:00.383681 2016] [:error] [pid 45685]   File "/usr/share/openstack-dashboard/openstack_dashboard/wsgi/../../openstack_dashboard/usage/quotas.py", line 165, in get_tenant_quota_data
[Tue Feb 23 08:44:00.383686 2016] [:error] [pid 45685]     tenant_id=tenant_id)
[Tue Feb 23 08:44:00.383699 2016] [:error] [pid 45685]   File "/usr/share/openstack-dashboard/openstack_dashboard/wsgi/../../openstack_dashboard/usage/quotas.py", line 147, in _get_quota_data
[Tue Feb 23 08:44:00.383744 2016] [:error] [pid 45685]     quotasets.append(getattr(cinder, method_name)(request, tenant_id))
[Tue Feb 23 08:44:00.383765 2016] [:error] [pid 45685]   File "/usr/share/openstack-dashboard/openstack_dashboard/wsgi/../../openstack_dashboard/api/cinder.py", line 409, in tenant_quota_get
[Tue Feb 23 08:44:00.383768 2016] [:error] [pid 45685]     return base.QuotaSet(c_client.quotas.get(tenant_id))
[Tue Feb 23 08:44:00.383771 2016] [:error] [pid 45685]   File "/usr/lib/python2.7/site-packages/cinderclient/v2/quotas.py", line 37, in get
[Tue Feb 23 08:44:00.383773 2016] [:error] [pid 45685]     "quota_set")
[Tue Feb 23 08:44:00.383776 2016] [:error] [pid 45685]   File "/usr/lib/python2.7/site-packages/cinderclient/base.py", line 173, in _get
[Tue Feb 23 08:44:00.383778 2016] [:error] [pid 45685]     resp, body = self.api.client.get(url)
[Tue Feb 23 08:44:00.383780 2016] [:error] [pid 45685]   File "/usr/lib/python2.7/site-packages/cinderclient/client.py", line 326, in get
[Tue Feb 23 08:44:00.383785 2016] [:error] [pid 45685]     return self._cs_request(url, 'GET', **kwargs)
[Tue Feb 23 08:44:00.383796 2016] [:error] [pid ...
(more)
2016-02-22 17:52:12 -0600 commented answer cinder list ERROR: Unauthorized (HTTP 401)

yes,i am very sure that!I can use the username/password login the dashboard.But can not see any messages with volumes on the dashboard.

2016-02-22 17:43:07 -0600 received badge  Popular Question (source)
2016-02-21 21:49:14 -0600 received badge  Associate Editor (source)
2016-02-21 21:48:14 -0600 asked a question cinder list ERROR: Unauthorized (HTTP 401)

Hi, i have problems on openstack kilo.When glance image-list is fine,but cinder list is no fine.This is info:

 - DEBUG:keystoneclient.session:REQ: curl -g -i -X GET http://controller:35357/v3 -H "Accept: application/json" -H    "User-Agent: python-keystoneclient"
  DEBUG:keystoneclient.session:RESP: [200] content-length: 250 vary: X-Auth-Token server: Apache/2.4.6 (CentOS)     mod_wsgi/3.4 Python/2.7.5 date: Mon, 22 Feb 2016 03:42:53 GMT content-type: application/json x-openstack-request-    id: req-13f9a1c1-fbbc-41a4-96cd-9dd6ab786954 
 RESP BODY: {"version": {"status": "stable", "updated": "2015-03-30T00:00:00Z", "media-types": [{"base":     "application/json", "type": "application/vnd.openstack.identity-v3+json"}], "id": "v3.4", "links": [{"href":      "http://controller:35357/v3/", "rel": "self"}]}}

   DEBUG:keystoneclient.auth.identity.v3.base:Making authentication request to http://controller:35357/v3/auth/tokens
   DEBUG:keystoneclient.session:REQ: curl -g -i -X GET http://controller:8776/ -H "Accept: application/json" -H "User-Agent: python-keystoneclient"
   DEBUG:keystoneclient.session:RESP: [200] date: Mon, 22 Feb 2016 03:42:53 GMT content-length: 292 content-type: application/json 
  RESP BODY: {"versions": [{"status": "SUPPORTED", "updated": "2014-06-28T12:20:21Z", "id": "v1.0", "links": [{"href": "http://controller:8776/v1/", "rel": "self"}]}, {"status": "CURRENT", "updated": "2012-11-21T11:33:21Z", "id": "v2.0", "links": [{"href": "http://controller:8776/v2/", "rel": "self"}]}]}

   DEBUG:keystoneclient.auth.identity.v3.base:Making authentication request to http://controller:35357/v3/auth/tokens
   DEBUG:keystoneclient.session:REQ: curl -g -i -X GET http://controller:8776/v2/de8fe81c89d44356846a7b8aec82eb56/os-services -H "User-Agent: python-cinderclient" -H "Accept: application/json" -H "X-Auth-Token:     {SHA1}8ad0a4fa35f238a746a8d0cdbc5a1ce3f8ea24b5"
   DEBUG:keystoneclient.session:RESP:
   DEBUG:keystoneclient.auth.identity.v3.base:Making authentication request to    http://controller:35357/v3/auth/tokens
  DEBUG:keystoneclient.session:RESP:
  ERROR: Unauthorized (HTTP 401)

  It is always called Unauthorized ,here is the error log:
   Feb 22 11:45:19 controller01 cinder-api: 2016-02-22 11:45:19.397 6683 ERROR keystonemiddleware.auth_token [-] Bad     response code while validating token: 400
   Feb 22 11:45:19 controller01 cinder-api: 2016-02-22 11:45:19.398 6683 WARNING keystonemiddleware.auth_token [-]    Identity response: {"error": {"message": "Expecting to find domain in project - the server could not comply with the    request since it is either malformed or otherwise incorrect. The client is assumed to be in error.", "code": 400, "title":    "Bad Request"}}
   Feb 22 11:45:19 controller01 cinder-api: 2016-02-22 11:45:19.398 6683 WARNING keystonemiddleware.auth_token [-] Authorization failed for token



 And this is the cinder.conf with keystone:
  [keystone_authtoken]
  auth_uri = http://controller:5000
  auth_url = http://controller:35357
  auth_plugin=password
  porject_domain_id = default
  user_domain_id = default
  project_name = service
  username = cinder
  password = xxxxxxxx

So,who can tell me where is the problems?Any help will be need!!!!!!

2016-01-19 01:02:56 -0600 received badge  Notable Question (source)
2016-01-15 03:23:13 -0600 received badge  Notable Question (source)
2016-01-02 19:26:57 -0600 received badge  Famous Question (source)
2016-01-01 09:06:11 -0600 received badge  Notable Question (source)
2015-12-28 01:19:59 -0600 received badge  Popular Question (source)
2015-12-24 19:54:34 -0600 asked a question when cinder node reboot,how to save or restone the target conf file?

Hi,

    I have a question,when i reboot the cinder node,the target conf is failure.I don't know why..My situation is openstack kilo,when power off or reboot the cinder nodes,the all instances can't boot.I use lvm for the cinder backend and compute nodes use the iscsi service.

    Can anyone tell me what is the problome?How can i fix the situation?When it happend i only can do rebuild all instances.It is very stupid.I need help!Any help is very helpful!Thanks a lot!!!!!
2015-12-22 05:01:06 -0600 received badge  Taxonomist
2015-12-22 03:02:10 -0600 received badge  Popular Question (source)
2015-12-21 23:06:16 -0600 commented answer How to choose the block node when use command create a volume

Thank you very much!But,I am a newer of openstack,i don't know how to create availability-zone and put the block node under it.....

2015-12-20 22:49:51 -0600 asked a question How to choose the block node when use command create a volume

Hi,
I have more than 3 block nodes in openstack kilo.I want to choose the block node when i create the volume. But,i don't know the right command...I finally to do th thing is :Lanuch a instance with a volume,the volume i can choose which is the block nodes....

Please help me!I realy need help,any helps is very useful,thanks a lot!!!

2015-12-17 05:00:50 -0600 received badge  Popular Question (source)
2015-12-15 15:32:32 -0600 received badge  Popular Question (source)
2015-12-04 01:02:47 -0600 commented answer Can not find the neutron-lbaas-agent packge on kilo

Thank you!!! It is my fault...I did not start(find) the service neutron-lbaas-agent on network node!Now,the LBAAS is fine! BYW,what is the diff with LBAAS V1 api and LBAAS V2 api?I use V1 to see them on dashboard..

2015-12-03 20:31:31 -0600 asked a question Can not find the neutron-lbaas-agent packge on kilo

Hi, I want to start the openstack-neutron(V1 OR V2),but i only can yum install openstack-neutron-lbaas-2015.1.0-3.el7.noarch,i can not install the neutron-lbaas-agent ont the network node.... I was flow the http://docs.openstack.org/admin-guide... when i create lbaas-loadbalancer ,the error like this:No eligible agent found for loadbalancer.... So,anyone can tell me how to install the neutron-lbaas-agent on centos7 with kilo?I really thanks for any help!!!

2015-12-03 01:43:23 -0600 commented answer Error in lbaas installation in kilo

Please tell me how to install neutron-lbaas-agent on centos7,I cann't find this packge...