Ask Your Question

openstack_single_node_saas's profile - activity

2018-03-04 01:07:41 -0600 received badge  Famous Question (source)
2018-02-23 07:01:04 -0600 received badge  Nice Question (source)
2017-04-12 04:59:16 -0600 received badge  Notable Question (source)
2017-03-24 13:11:06 -0600 received badge  Famous Question (source)
2017-03-01 01:29:24 -0600 received badge  Famous Question (source)
2017-02-16 05:50:50 -0600 received badge  Famous Question (source)
2016-06-23 10:03:47 -0600 received badge  Famous Question (source)
2016-04-04 11:08:50 -0600 received badge  Popular Question (source)
2016-04-04 11:08:50 -0600 received badge  Notable Question (source)
2016-01-24 05:53:43 -0600 received badge  Famous Question (source)
2016-01-18 08:26:53 -0600 received badge  Famous Question (source)
2015-12-30 11:07:28 -0600 received badge  Popular Question (source)
2015-12-28 15:55:13 -0600 received badge  Notable Question (source)
2015-12-27 02:29:51 -0600 received badge  Popular Question (source)
2015-12-26 03:36:34 -0600 asked a question Redirecting IP address

Hello Everyone,

I have installed Openstack on a single machine using Devstack. Since I am very new to Openstack, I am using Nova networking because I believe its somewhat simpler to use than Neutron networking. I have an Ubuntu instance running with a floating IP of 192.168.1.6 on top of Openstack. Now I have procured a static IP 40.201.179.137 from my ISP company. Kindly tell me if there is a way that without reinstalling Openstack, I can have static IP redirected to the floating IP so that my instance accessible from anywhere on the internet

Thanking you in anticipation.

Best regards,

Hamid Sultan

2015-12-05 08:03:46 -0600 commented answer Which security group instance attached to

Hi,

Thank you so much for your quick response.

Best regards,

Hamid Sultan

2015-12-04 07:05:47 -0600 asked a question Which security group instance attached to

Hi Everyone,

I have two simple question. I will greatly appreciate if someone can help me

1) How can we determine which Security Group an instance is attached to: 2) Can we change security rules of a Security Group while the attached instance is running.

Thanks a lot.

Hamid Sultan

2015-12-04 02:51:34 -0600 received badge  Notable Question (source)
2015-12-03 07:24:51 -0600 commented question ubuntu server port 9090

Hi Bipin,

Thank you so much for your message.

My security group rules allow incoming traffic.

I tried the above netstat command. But it does not give any output..

Please tell me how to make port 9090 listen.

I will greatly appreciate your help.

Thanks

Hamid Sultan

2015-12-03 07:07:25 -0600 received badge  Popular Question (source)
2015-12-02 20:22:19 -0600 received badge  Student (source)
2015-12-02 04:35:36 -0600 asked a question ubuntu server port 9090

Hi Everyone,

I have an Ubuntu Server 12.04.03 server on top of Openstack MY ssh server is running fine. X11 forwarding is enabled. firewall is disabled I am trying to connect to port 9090 of Ubuntu server instance through a java socket programming application. This application is running on a workstation in the same wireless network. However, this application gives the message "Connection refused: connect"

I did the following on the Ubuntu server instance: netstat -an | grep "LISTEN" but it does not show port 9090 in the output Someone link on the Internet suggested the following: iptables -A INPUT -p tcp --dport 9090 -j ACCEPT Since I am not very familiar with Linux networking commands, I am not sure if this will solve the problem or further complicate matters

Please help me resolve the problem.

Thanks in advance.

Hamid Sultan

2015-11-29 07:00:52 -0600 commented question On ubuntu instance firefox display problem

Hi Farzad,

I am also not familiar with VNCServer and its config. Kindly help me if that VNCServer needs adjustment and how to do it..

Thanks Hamid Sultan

2015-11-29 03:32:00 -0600 commented question On ubuntu instance firefox display problem

Hello Farzad,

Actually, after reaching the console through Openstack dashboard, and after installing and running eclipse. I can create a Java project on eclipse. But when I try to edit the Java source file, the keyboard does not responde. Mouse clicks are also not responding.

Thanks

2015-11-26 00:11:28 -0600 received badge  Popular Question (source)
2015-11-26 00:11:11 -0600 received badge  Commentator
2015-11-26 00:11:11 -0600 commented answer eclipse IDE on an instance

Hi Luigi, Thank you for your message. The way I am accessing Eclipse is this: First, I log onto the Openstack dashboard. Then I launch Ubuntu Instance. Then I invoke the Ubuntu instance's console. Then I log onto the instance. Ten I invoke Eclipse from the command line. Best regards, Hamid

2015-11-24 08:30:43 -0600 commented question eclipse IDE on an instance

Hi Luigi,

Thank you for your message.

The way I am accessing Eclipse is this: First, I log onto the Openstack dashboard. Then I launch Ubuntu Instance. Then I invoke the Ubuntu instance's console. Then I log onto the instance. Ten I invoke Eclipse from the command line.

Best regards, Hamid

2015-11-23 13:38:04 -0600 received badge  Notable Question (source)
2015-11-23 08:53:55 -0600 asked a question eclipse IDE on an instance

Hello Everyone,

I am installed eclipse IDE on an Ubuntu Server instance on top of Openstack.

On some windows within eclipse it is not responding to keyboard hits as well as mouse clicks.

For example, to exit the eclipse, I go to File and then to Exit. But it does not exit from the IDE.

Similarly, if I create a Java source file in the IDE, it does not respond to keyboard hits.

Please help me solve this problem. I will appreciate much.

Thanks and best regards,

Hamid Sultan

2015-11-23 03:18:05 -0600 received badge  Popular Question (source)
2015-11-22 05:10:13 -0600 received badge  Famous Question (source)
2015-11-22 03:26:41 -0600 asked a question Setting static IP through nova

Hi Everybody,

I am a beginner in Openstack. I have installed Openstack on a single machine using Devstack.

I was having problems installing Neutron.
So for networking, I chose nova. Things are running fine.

Now, I have taken a static IP from my Internet Service provider.

Can any help me how to how set my local.conf file or some other way so that I can assign that particular static IP address to the Ubuntu instance when I launch is as a VM on top of Openstack.

Thanking you in anticipation.

Best regards,

Hamid Sultan

2015-11-21 02:16:32 -0600 received badge  Popular Question (source)
2015-11-21 02:16:32 -0600 received badge  Notable Question (source)
2015-11-20 10:51:02 -0600 commented answer ssh not connecting to Ubuntu Server 14.04 instance

Hello Herman, Thank you for your message which I did not see earlier. Yes your suggestion is absolutely correct. I installed ssh server. Now it works. Warm regards, Hamid Sultan

2015-11-20 10:48:03 -0600 commented answer ssh not connecting to Ubuntu Server 14.04 instance

Hello Farzad, Thanks for your message. Sorry I did not see it earlier. Yes I am using key-pair and it is connecting. Best regards, Hamid Sultan

2015-11-19 11:55:58 -0600 asked a question On ubuntu instance firefox display problem

Hi Everyone,

I installed Firefox browser on Ubuntu instance. But when I start by typing "firefox" on the command line, it says: Error: Display not specified I also did: export DISPLAY=0:0 xhost + But it still gives error: Cant open display 0:0

I would appreciate if someone can help me how to solve this problem.

Thanks in advance.

Hamid Sultan

2015-11-19 11:48:11 -0600 received badge  Notable Question (source)
2015-11-19 11:46:49 -0600 commented question ssh not connecting to Ubuntu Server 14.04 instance

Hi Anand, Thank you for your message. It turned that by default ssh server is not installed on Ubuntu. So I installed ssh server and it worked. Thank you again for your input.

Best, Hamid Sultan

2015-11-19 11:44:05 -0600 received badge  Popular Question (source)
2015-11-14 10:23:56 -0600 asked a question ssh not connecting to Ubuntu Server 14.04 instance

Hi Everybody,

Through Devstack, I have installed Openstack on a single node running Ubuntu Server 14.04 I am able to launch an instance on Openstack through pre-loaded image of cirros from dashboard. I can log onto this instance on a wireles LAN from any Linux workstation using the following: ssh -i key-pair.pem cirros@192.168.1.5

I have launched another Ubuntu Server 14.04 instance on top of Openstack. I can ping this instance using its floating IP from any linux workstation.

However, when I do: ssh -i key-pair.pem ubuntu-user@192.168.1.6 It says "ssh ..... Connection refused: port 22"

I did 'apt-get update' and 'apt-get upgrade' on the top level Ubuntu Do I need to install ssh server on that Ubuntu Or do you think there might be another reason for connection refusal

I would appreciate much if somebody can help me resolve this.

Thanks & best regards,

Hamid Sultan

2015-11-04 04:11:11 -0600 asked a question Ubuntu instance not responding

Hello Everyone,

I have a single node installation of Openstack using Devstack

I launched an instance using cirros image through the dashboard and it works fine.

However, I created an Ubuntu 14.04-server image using the following link:

http://blog.aaronorosen.com/quick-guide-to-creating-a-openstack-bootable-image/ (http://blog.aaronorosen.com/quick-gui...)

Finally, I uploaded the image using the following command

glance image-create --name ubuntu-14.04-server --disk-format=qcow2 --container-format=bare --is-public=True < ubuntu-14.04-server.img

However, I did not use nova boot command as given in the blog. Instead I launched it as an instance through the dashboard, by assigning a Security Group, a keypair, and a floating IP address. The dashboard shows it as running. However, I cannot ping the instance from another linux workstation Also, I am also not able to logon onto this instance using the following command:

ssh -i key-pair.pem username@192.168.1.9

The error message says: ssh: connect to host 192.168.1.9 port 22: No route to host

All workstations are connected via a wireless LAN

I would greatly appreciate if anyone can help me resolve this problem

Thanks in anticipation.

Best regards,

Hamid Sultan

2015-11-02 08:46:13 -0600 received badge  Famous Question (source)
2015-11-02 08:45:55 -0600 commented answer service cinder-volume ubuntu@lmdriver-1 problem

Hi Boris,

Thank you so much for your help. I followed your suggestion and it works. Thanks again. Best regards,

Hamid Sultan

2015-10-27 01:42:41 -0600 commented answer service cinder-volume ubuntu@lmdriver-1 problem

Hi Boris,

Please let me know if I understand your suggestion clearly:

When I run the last two lines (from above commands) there is no mention of files existing. Then I run stack.sh again Then I copy the above four line script into /home/stack folder

Please correct me if I am wrong

Thanks Hamid

2015-10-27 01:29:26 -0600 received badge  Notable Question (source)
2015-10-26 03:02:36 -0600 received badge  Popular Question (source)
2015-10-25 10:18:25 -0600 asked a question service cinder-volume ubuntu@lmdriver-1 problem

Hi Everybody,

I installed Openstack using Devstack on a single machine running Ubuntu 14.04.2 Server. When I reboot the machine, I run rejoin-stack.sh. Apparently all services come back except that Storage information cannot be retrieved on dashboard. Also the following message is repeatedly displayed on the console:

Error: cinder.service (-) Manager for service cinder-volume ubuntu@lmdriver-1 is reporting problem, not sending heartbeat, service will appear down

I would greatly appreciate if someone could help me solve this problem.

Thanking you in anticipation.

Best regards,

Hamid Sultan

2015-10-23 02:46:08 -0600 received badge  Notable Question (source)