Ask Your Question

Tabi T's profile - activity

2015-12-06 04:13:26 -0500 received badge  Popular Question (source)
2015-12-06 04:13:26 -0500 received badge  Famous Question (source)
2015-12-06 04:13:26 -0500 received badge  Notable Question (source)
2015-11-17 12:00:05 -0500 received badge  Famous Question (source)
2015-08-20 02:07:54 -0500 received badge  Student (source)
2015-08-19 21:44:00 -0500 received badge  Notable Question (source)
2015-08-19 06:14:45 -0500 asked a question Running any Ceph command give a Pipe fault.

I am trouble the cause of all my compute state as down. On executing a ceph command, any command, I get this error:

pipe(0x7f1240000c00 sd=4 :0 s=1 pgs=0 cs=0 l=1 c=0x7f1240000e90).fault

The error is the same from either the controller nodes, the Ceph OSD nodes or Compute node. Reboot of the hosts did not resolve the problems.

Any idea what could be the cause of this error and how to fix it?

Much appreciated.

Tabi

2015-08-19 03:48:54 -0500 commented question All compute nodes state appear as down

Checked Nova log on Controller node and nothing serious/...

182>Aug 19 08:41:09 node-2 nova-api 10.12.1.2 "GET /v2/3809c40125364255be74aea103e3347e/servers/detail?all_tenants=True&host=node-7.tabi.co HTTP/1.1" status: 200 len: 206 time: 0.0$ <182>Aug 19 08:41:10 node-2 nova-api 0.152s 10.12.1.4 OP

2015-08-19 02:41:19 -0500 commented question All compute nodes state appear as down

Here is nova-all log excerpt from the compute node/..

182>Aug 18 22:30:04 node-10 nova-compute Skipping periodic task _periodic_update_dns because its interval is negative <182>Aug 18 22:30:04 node-10 nova-compute Loading compute driver 'libvirt.LibvirtDriver' <182>Aug 18 22:30:04 node-10 nova-comp

2015-08-19 01:44:05 -0500 commented question All compute nodes state appear as down

Hi, Nova-api.log or nova-all.log?

2015-08-19 01:39:27 -0500 received badge  Popular Question (source)
2015-08-18 18:44:29 -0500 asked a question All compute nodes state appear as down

I installed OpenStack Juno and spawn some instances successfully. After a failed attempt to delete a volume, I noticed one compute node state changed to down. Shortly after that all the other compute nodes states and change to down. I have reboot all controllers, compute and storage node and state of the compute nodes still appear as down.

I am running Ceph OSD for storage.

Any what could be the cause and how to resolve it?

Tabi

2015-07-23 10:10:24 -0500 commented question HA Storage Options for Private OpenStack Cloud

Hi Andrew,

I am new to the forum and noticed your question has been outstanding for a while. Do you still need input?

2015-07-13 10:04:20 -0500 commented answer nova-compute State down

Hi Ivan, can you provide more information about the failed communication with RabbitMQ service and why Ceph stopped working on the compute node? Also, is nova-conductor running on the same host as the compute node?