Ask Your Question

Vikram's profile - activity

2016-03-04 00:45:21 -0500 received badge  Teacher (source)
2016-03-04 00:45:21 -0500 received badge  Necromancer (source)
2015-08-27 13:06:00 -0500 received badge  Famous Question (source)
2015-06-15 02:33:58 -0500 received badge  Notable Question (source)
2015-06-14 10:33:54 -0500 commented answer Directory '/opt/stack/glance' is not installable. File 'setup.py' not found.

can you please specify the command to do this.

2015-06-12 02:58:15 -0500 commented answer The service rabbitmq-server fails to start if rabbitmq.config file exists in /etc/rabbitmq/ directory. If I have even a blank file as rabbitmq.config the service rabbitmq-server fails to start.

I was finally able to reset rabbitmqctl, but it didn't help. Again I'm facing the same issue. As soon as I edit rabbitmq.config file, I cannot restart the rabbitmq-server service. What should I do ...???

2015-06-12 01:23:13 -0500 received badge  Famous Question (source)
2015-06-11 07:51:51 -0500 received badge  Popular Question (source)
2015-06-11 00:34:43 -0500 asked a question The service rabbitmq-server fails to start if rabbitmq.config file exists in /etc/rabbitmq/ directory. If I have even a blank file as rabbitmq.config the service rabbitmq-server fails to start.

I'm in the final process of installing ICEHOUSE, and I'm now at a stage where I must edit the nano /etc/rabbitmq/rabbitmq.config and use the following: [{rabbit, [{loopback_users, []}]}]

The service rabbitmq-server fails to start if rabbitmq.config file exists in /etc/rabbitmq/ directory. If I have even a blank file as rabbitmq.config the service rabbitmq-server fails to start.

Strange ... Has this happened to anyone, or am I the CHOOSEN ONE :)

CURRENT SCENERIO

CURRENT SCENERIO
=================
root@controller:/home/XXXXXX# ls /etc/rabbitmq/
enabled_plugins  rabbitmq.config  rabbitmq_OLD.config
root@controller:/home/XXXXXX#
root@controller:/home/XXXXXX# rm /etc/rabbitmq/rabbitmq.config
root@controller:/home/XXXXXX#
root@controller:/home/XXXXXX# service rabbitmq-server restart
 * Restarting message broker rabbitmq-server                                                                                                                     [ OK ]
root@controller:/home/XXXXXX#
root@controller:/home/XXXXXX# nano /etc/rabbitmq/rabbitmq.config
root@controller:/home/XXXXXX#
root@controller:/home/XXXXXX# ls /etc/rabbitmq/rabbitmq.config
ls: cannot access /etc/rabbitmq/rabbitmq.config: No such file or directory
root@controller:/home/XXXXXX#
root@controller:/home/XXXXXX# nano /etc/rabbitmq/rabbitmq.config
root@controller:/home/XXXXXX#
root@controller:/home/XXXXXX# ls /etc/rabbitmq/rabbitmq.config
/etc/rabbitmq/rabbitmq.config
root@controller:/home/XXXXXX#
root@controller:/home/XXXXXX# service rabbitmq-server restart
 * Restarting message broker rabbitmq-server                                                                                                                     [fail]
root@controller:/home/XXXXXX#
root@controller:/home/XXXXXX# rm /etc/rabbitmq/rabbitmq.config
root@controller:/home/XXXXXX#
root@controller:/home/XXXXXX# service rabbitmq-server restart
 * Restarting message broker rabbitmq-server                                                                                                                     [ OK ]

LOGS
====
=INFO REPORT==== 11-Jun-2015::09:26:15 ===
Halting Erlang VM

=INFO REPORT==== 11-Jun-2015::09:26:30 ===
Starting RabbitMQ 3.2.4 on Erlang R16B03
Copyright (C) 2007-2013 GoPivotal, Inc.
Licensed under the MPL.  See http://www.rabbitmq.com/

=INFO REPORT==== 11-Jun-2015::09:26:30 ===
node           : rabbit@controller
home dir       : /var/lib/rabbitmq
config file(s) : (none)
cookie hash    : QVBdAzu+ABo1H5Wopt/OPw==
log            : /var/log/rabbitmq/rabbit@controller.log
sasl log       : /var/log/rabbitmq/rabbit@controller-sasl.log
database dir   : /var/lib/rabbitmq/mnesia/rabbit@controller

=INFO REPORT==== 11-Jun-2015::09:26:31 ===
Limiting to approx 924 file handles (829 sockets)

=INFO REPORT==== 11-Jun-2015::09:26:31 ===
Memory limit set to 397MB of 993MB total.

=INFO REPORT==== 11-Jun-2015::09:26:31 ===
Disk free limit set to 50MB

=INFO REPORT==== 11-Jun-2015::09:26:31 ===
msg_store_transient: using rabbit_msg_store_ets_index to provide index

=INFO REPORT==== 11-Jun-2015::09:26:31 ===
msg_store_persistent: using rabbit_msg_store_ets_index to provide index

=INFO REPORT==== 11-Jun-2015::09:26:31 ===
started TCP Listener on [::]:5672

=INFO REPORT==== 11-Jun-2015::09:26:31 ===
Management plugin started. Port: 15672

=INFO REPORT==== 11-Jun-2015::09:26:31 ===
Statistics database started.

=INFO REPORT==== 11-Jun-2015::09:26:31 ===
Server startup complete; 6 plugins started.
 * amqp_client
 * mochiweb
 * rabbitmq_management
 * rabbitmq_management_agent
 * rabbitmq_web_dispatch
 * webmachine

=INFO REPORT==== 11-Jun-2015::09:26:36 ===
accepting AMQP connection <0.283.0> (10.10.10.10:57299 -> 10.10.10.10:5672)

=INFO REPORT==== 11-Jun-2015::09:26:36 ===
accepting AMQP connection <0.294.0> (10.10.10.10:57300 -> 10.10.10.10:5672)

=INFO REPORT==== 11-Jun-2015::09:26:36 ===
accepting AMQP connection <0.307.0> (10.10.10.10:57301 -> 10.10.10.10:5672)

=INFO REPORT==== 11-Jun-2015::09 ...
(more)
2015-06-11 00:31:32 -0500 received badge  Enthusiast
2015-06-10 02:45:49 -0500 commented answer Installing neutron - No handlers could be found for logger "neutron.common.legacy"

enojando - I tried what you suggested, and it's still not working. I recreated the endpoints via 'keystone endpoint-create' command and still I'm getting 'Connection to neutron failed: Maximum attempts reached' error message. Any thoughts?

2015-06-09 22:34:11 -0500 commented answer neutron-plugin-openvswitch-agent cant be started on compute node

I'm facing the same issue, in the logs it says "ImportError: No module named rabbit". Any idea's?

LOGS ATTACHED

root@compute:/home/XXXXXXX# service neutron-plugin-openvswitch-agent status neutron-plugin-openvswitch-agent start/running, process 6464 root@compute:/home/XXXXXXX# service

2015-06-09 21:04:28 -0500 commented answer Connection to neutron failed: [Errno 111] Connection refused

actually .. the problem is with space before and after =. rather than XXX = XXX it should be XXX=XXX.

Hope it helps.

2015-06-09 04:53:05 -0500 received badge  Notable Question (source)
2015-06-09 04:53:05 -0500 received badge  Popular Question (source)
2015-06-08 23:14:13 -0500 answered a question Image Service: Invalid OpenStack Identity credentials

Previously I was getting the following error message:-

root@controller:/home/XXXXXX# glance image-create --name "cirros-0.3.3-x86_64" - -file /tmp/images/cirros-0.3.3-x86_64-disk.img --disk-format qcow2 --container-f ormat bare --is-public True --progress [=============================>] 100% Request returned failure status. Invalid OpenStack Identity credentials.

Issue solved by changing ththe following in glance-api.conf & glance-registry.conf:

[keystone_authtoken] auth_uri = http://controller:5000/v2.0 identity_uri = http://controller:35357 admin_tenant_name = service admin_user = XXXXXX admin_password = XXXXXX

To this:

auth_host = controller auth_port = 35357 auth_protocol = http admin_tenant_name = service admin_user = XXXXXX admin_password = XXXXXX auth_uri = http://controller:5000

============

=VALIDATION=

root@controller:/home/XXXXXX# nano /etc/glance/glance-api.conf root@controller:/home/XXXXXX# nano /etc/glance/glance-registry.conf root@controller:/home/XXXXXX# service glance-registry restart glance-registry stop/waiting glance-registry start/running, process 7550 root@controller:/home/XXXXXX# service glance-api restart glance-api stop/waiting glance-api start/running, process 7563 root@controller:/home/XXXXXX# root@controller:/home/XXXXXX# source admin-openrc.sh root@controller:/home/XXXXXX# glance image-create --name "cirros-0.3.3-x86_64" --file /tmp/images/cirros-0.3.3-x86_64-disk.img --disk-format qcow2 --container-format bare --is-public True --progress [=============================>] 100% +------------------+--------------------------------------+ | Property | Value | +------------------+--------------------------------------+ | checksum | 51b8afbd2b6d36d7012280e9ede51e7e | | container_format | bare | | created_at | 2015-06-08T18:14:12 | | deleted | False | | deleted_at | None | | disk_format | qcow2 | | id | 9a8b12c9-f0d6-43a4-a23a-f4cc67fe89f1 | | is_public | True | | min_disk | 0 | | min_ram | 0 | | name | cirros-0.3.3-x86_64 | | owner | c3eab5d97c514aa4aec53ba1dc5aae40 | | protected | False | | size | 955802 | | status | active | | updated_at | 2015-06-08T18:14:12 | | virtual_size | None | +------------------+--------------------------------------+ root@controller:/home/XXXXXX# glance image-list +--------------------------------------+---------------------+-------------+------------------+--------+--------+ | ID | Name | Disk Format | Container Format | Size | Status | +--------------------------------------+---------------------+-------------+------------------+--------+--------+ | 9a8b12c9-f0d6-43a4-a23a-f4cc67fe89f1 | cirros-0.3.3-x86_64 | qcow2 | bare | 955802 | active | +--------------------------------------+---------------------+-------------+------------------+--------+--------+ root@controller:/home/XXXXXX#

2015-06-07 23:30:22 -0500 commented question Keystone service status is always stopping or waiting

I've tried the solutions mentioned in :-

https://ask.openstack.org/en/question/42775/keystone-service-status-is-always-stoppingwaiting/ (https://ask.openstack.org/en/question...)

http://askubuntu.com/questions/412912/openstack-keystone-service-stops-immediately-after-starting (http://askubuntu.com/questions/412912...)

and a few others .. but still cant get the service to work

2015-06-07 23:24:46 -0500 asked a question Keystone service status is always stopping or waiting

Hi Experts,

I'm in the process of installing and configuring Openstack, and in this process I'm trying to install keystone. Following are the steps that I've taken:-

# apt-get install keystone

# nano /etc/keystone/keystone.conf

[DEFAULT]
...
admin_token = openstack

[database]
...
connection = mysql://keystone:openstack@controller/keystone
# either i put controller or my eth0 ip address the end result is the same.
[token]
...
provider = keystone.token.providers.uuid.Provider
driver = keystone.token.persistence.backends.sql.Token

[revoke]
...
driver = keystone.contrib.revoke.backends.sql.Revoke

[DEFAULT]
...
verbose = True

# keystone-manage db_sync

# service keystone restart

As soon as I do restart or stop start the keystone server always stops.

I'm using ubuntu 14.02 on a Virtual box running on 1 GB RAM with 1 Core

Please help..

Regards, V

2015-06-07 23:24:22 -0500 answered a question Keystone service status is always stopping/waiting

Even re-installing failed. I'm running Ubuntu 14.02 server on a virtual box. I'm attaching a screenshot for your consideration.

My keystone.conf file has following entries:

admin_token = openstack [database] ... connection = mysql://keystone:openstack@controller/keystone [token] ... provider = keystone.token.providers.uuid.Provider driver = keystone.token.persistence.backends.sql.Token [revoke] ... driver = keystone.contrib.revoke.backends.sql.Revoke [DEFAULT] ... verbose = True

The DNS is also not a problem, as it is resolving the 'controller' ip address.

Akshay/anybody .. Please help me. I'm stuck on this for over a month now.

Regards,

--V