Ask Your Question

Tael Lumenia's profile - activity

2017-11-06 06:40:58 -0600 received badge  Student (source)
2017-11-06 06:40:56 -0600 received badge  Self-Learner (source)
2017-11-06 06:40:56 -0600 received badge  Teacher (source)
2015-07-26 21:58:53 -0600 received badge  Famous Question (source)
2015-05-26 08:53:39 -0600 received badge  Notable Question (source)
2015-05-22 02:04:00 -0600 received badge  Enthusiast
2015-05-15 01:51:27 -0600 answered a question ERROR: openstack 'Namespace' object has no attribute 'os_url'

I don't really what happened but yesterday I deleted my VM and rebuilt a new one and I never felt again on this problem ! Other ones perhaps (...even sure) but not this one. So here is my aswer: rebuilt integrally.

Thanks ghebda for your help.

2015-05-14 13:10:31 -0600 received badge  Popular Question (source)
2015-05-13 02:07:10 -0600 commented question ERROR: openstack 'Namespace' object has no attribute 'os_url'

Thanks ghebda for your comment, it's really nice.

I had already try to check with those two commands if my OS_URL was set and if I could pass through via the flag --os-url. But the result is still the same: OS_URL is set (http://controller:35357/v2.0) and using the flag give me the same error

2015-05-12 09:29:56 -0600 received badge  Organizer (source)
2015-05-12 08:29:44 -0600 asked a question ERROR: openstack 'Namespace' object has no attribute 'os_url'

Hello there,

I am looking for some hints, some solutions on this problem. I try to install Keystone, following the http://docs.openstack.org/kilo/install-guide/yum/content/keystone-service.html (http://docs.openstack.org/ tutorial) but when I execute:

openstack service create --type identity --description "OpenStack Identity" keystone

it send me this error message:

ERROR: openstack 'Namespace' object has no attribute 'os_url'

I saw on this site problem around no attribute 'os_auth', check my version of python-openstackclient but didn't found answers.

Can you help me please ?

EDIT: after checking, it seems that this error appears on each openstack command, not only keystone


Config: RedHat 7.1 / OpenStack kilo / python-openstackclient version 1.0.3

2015-05-12 04:08:01 -0600 received badge  Autobiographer