Ask Your Question

nguy4444's profile - activity

2016-10-27 21:58:31 -0600 received badge  Student (source)
2016-10-27 21:58:28 -0600 received badge  Notable Question (source)
2016-06-14 04:20:33 -0600 received badge  Teacher (source)
2016-06-14 04:20:33 -0600 received badge  Self-Learner (source)
2015-12-07 03:29:23 -0600 received badge  Popular Question (source)
2015-08-18 15:53:58 -0600 asked a question Launching stack from Horizon - environment file ignored, why?

I am trying to launch a Heat template from Horizon, via Orchestration->Stacks->Launch Stacks. The problem I am having is that the environment file - whether I specify it as a file, URL, or directly type it in - is being ignored, and I am still prompted to fill out parameter values that I thought would be loaded from the environment file. I am not getting any syntax errors on the environment file. so I am puzzled.

My environment file only has the parameters section, such as:

parameters:
   parm1: value
   parm2: value

I have tried this on both the Icehouse and Juno levels and get the same result. Any information or pointers to information on launching stacks from Horizon (have googled but have not found anything specific to my situation) is appreciated. Thanks!

2015-08-18 15:29:21 -0600 received badge  Famous Question (source)
2015-08-18 15:29:21 -0600 received badge  Popular Question (source)
2015-08-18 15:29:21 -0600 received badge  Notable Question (source)
2015-05-09 19:58:13 -0600 received badge  Enthusiast
2015-04-27 17:08:24 -0600 answered a question Need clarification of heat template "get_file" with http resource

I found the problem, and it appears to be a bug.

The get_file works fine when run from the command line, when the heat stack-create command is used.

However, it does not work if the template is invoked from the Horizon UI (under Project->Orchestration->Stacks-Launch Stack). That is where the error above occurs... so Horizon has an issue running these types of templates.

2015-04-27 11:40:43 -0600 commented question Need clarification of heat template "get_file" with http resource

I wish I could be more specific, but that is the only error that appears. It is popup box on the Horizon UI. This is OpenStack Juno version. Again, my real question is, should get_file act like wget?

2015-04-25 22:11:47 -0600 asked a question Need clarification of heat template "get_file" with http resource

Hello,

I am a newbie with building heat templates. I am just trying to retrieve a file from an http server using the "get_file" function. The syntax I am using is just

get_file: "http://my_http_server/subdir/file.sh"

However, I get the error "No content found in the "files" section for get_file path http://my_http_server/subdir/file.sh%22 (http://my_http_server/subdir/file.sh")

If I issue the wget command for http://my_http_server/subdir/file.sh, I can retrieve the file fine. I thought that is how the get_file function worked, but I may be wrong. The OpenStack explanation is not clear to me where the file to be retrieved should specifically be located, I assumed if using http it is the same as a wget. But I must be wrong. What am I missing? Thanks!