Ask Your Question

fatk1d's profile - activity

2015-04-27 05:52:56 -0500 received badge  Famous Question (source)
2015-04-10 07:35:49 -0500 commented answer Need OpenStack VMs to Talk to Internet

You are a machine. :) Solved the problem! Thanks again for your help. I managed to remember to update the with the real IP of the DNS server so that much I had gotten right. :)

2015-04-10 07:26:43 -0500 commented question Need OpenStack VMs to Talk to Internet

Thanks for the suggestion but I had already come across that issue and was able to resolve it before I ran into this one. Great suggestion, though!

2015-04-10 03:24:19 -0500 received badge  Notable Question (source)
2015-04-09 23:15:34 -0500 received badge  Popular Question (source)
2015-04-09 21:05:57 -0500 commented answer Cloning from: openstack-dev/devstack yields c-api and other installation failures.

Sir, I finally got the installation to work like I wanted it to. It would have taken me much longer to resolve the issues without your help. Hats off to you for your assistance. If you lived in Missouri, I'd have to buy your lunch. Since you're quite far away, accept my sincere gratitude. :)

2015-04-09 21:04:27 -0500 received badge  Famous Question (source)
2015-04-09 20:45:03 -0500 asked a question Need OpenStack VMs to Talk to Internet

Thanks to the user known as "dbaxps", I was able to get the VMs that I created in OpenStack (through Devstack all-in-one installation) to talk to other computers on my private LAN.

The VMs that I spin up have their private IPs in the 10.10.10.X range and their floating IPs are in the 172.16.5.x range. The host OS has his private network on the 192.168.1.X range. So, none of the OpenStack networks overlap with the network that I have on my host computer. From what I've read, this is a configuration requirement.

The default gateway on my 192.168.1.X network is which goes out to the Internet through NAT taking place on an NVG589 residential gateway. The problem is that packets from the 172.16.5.X network reach the residential gateway without issue, they just aren't undergoing NAT at the NVG589 residential gateway. The NVG589 residential gateway is only set up to NAT IP's in the 192.168.1.X network.

I've looked for ways to tell the NVG589 to NAT an additional address space but there doesn't seem to be anyway of doing this. Anyone have any ideas as to how to make this work without putting the NVG589 in a bridge/pass-thru mode and getting a network appliance that CAN NAT more than one address space? I realize that I may be over looking something obvious here but I'm not a networking guru. Suggestions would be appreciated.

2015-04-07 15:39:20 -0500 received badge  Notable Question (source)
2015-04-07 15:38:40 -0500 received badge  Famous Question (source)
2015-04-05 13:53:28 -0500 received badge  Popular Question (source)
2015-04-05 03:43:08 -0500 received badge  Notable Question (source)
2015-04-04 22:32:31 -0500 received badge  Student (source)
2015-04-04 11:52:08 -0500 asked a question Cloning from: openstack-dev/devstack yields c-api and other installation failures.

In trying to get used to the various options of OpenStack, I've been installing Devstack over the last week at various times. The first time I cloned from Devstack, I setup an all-in-one installation on Dell R610 using minimal local.conf with nova based networking. It worked like a champ. I've since (approximately one week later) removed that installation after playing around with it and I'm now trying to get it back using the exact same local.conf file that produced my initial successful installation. Between each attempt at installing Devstack, I am of course doing an "./" followed by a "./" and then removal of devstack directory. I then

git clone

and proceed with the "./" after I copy in my simplistic local.conf file:



As you can see, there's not much to it and it produced a working devstack installation the first time I tried it a week ago. Now, using a more recent(?) Devstack clone, I'm getting a failure when c-api tries to start. Below is the failure:

2015-04-04 10:50:01.981 DEBUG cinder.openstack.common.service [-] Full set of CONF: from (pid=17714) wait /opt/stack/cinder/cinder/openstack/common/
2015-04-04 10:50:01.981 DEBUG cinder.openstack.common.service [-] ******************************************************************************** from (pid=17714) log_opt_values /usr/lib/python2.7/dist-packages/oslo/config/
2015-04-04 10:50:01.981 INFO eventlet.wsgi.server [-] (17751) wsgi starting up on
2015-04-04 10:50:01.982 DEBUG cinder.openstack.common.service [-] Configuration options gathered from: from (pid=17714) log_opt_values /usr/lib/python2.7/dist-packages/oslo/config/
2015-04-04 10:50:01.982 DEBUG cinder.openstack.common.service [-] command line args: None from (pid=17714) log_opt_values /usr/lib/python2.7/dist-packages/oslo/config/
2015-04-04 10:50:01.982 INFO eventlet.wsgi.server [-] (17752) wsgi starting up on
2015-04-04 10:50:01.982 CRITICAL cinder [-] NoSuchOptError: no such option: config_file

2015-04-04 10:50:01.982 TRACE cinder Traceback (most recent call last):
2015-04-04 10:50:01.982 TRACE cinder   File "/usr/local/bin/cinder-api", line 10, in <module>
2015-04-04 10:50:01.982 TRACE cinder     sys.exit(main())
2015-04-04 10:50:01.982 TRACE cinder   File "/opt/stack/cinder/cinder/cmd/", line 61, in main
2015-04-04 10:50:01.982 TRACE cinder     launcher.wait()
2015-04-04 10:50:01.982 TRACE cinder   File "/opt/stack/cinder/cinder/openstack/common/", line 379, in wait
2015-04-04 10:50:01.982 TRACE cinder     CONF.log_opt_values(LOG, logging.DEBUG)
2015-04-04 10:50:01.982 TRACE cinder   File "/usr/lib/python2.7/dist-packages/oslo/config/", line 1931, in log_opt_values
2015-04-04 10:50:01.982 TRACE cinder     logger.log ...
2015-04-04 10:35:40 -0500 commented answer Would like OpenStack VMs to be able to communicate with local network

Thanks again for the great information. I honestly appreciate the fact that you took the time to respond. I have been cloning from the master branch (I believe) and I plan to try a set up once more later today cloning devstack from the stable/juno branch.

2015-04-04 09:21:45 -0500 received badge  Famous Question (source)
2015-04-04 04:06:16 -0500 received badge  Popular Question (source)
2015-04-04 01:43:47 -0500 received badge  Notable Question (source)
2015-04-04 01:01:44 -0500 received badge  Popular Question (source)
2015-04-03 16:32:25 -0500 commented answer Is it possible to run neutron from devstack using an all on one machine approach?

Thanks so much for your response. I may be back with more questions later. :)

2015-04-03 16:31:57 -0500 received badge  Scholar (source)
2015-04-03 14:40:08 -0500 commented answer Would like OpenStack VMs to be able to communicate with local network

I'll look through your response in greater detail later tonight and see if I can't make some additional progress with OpenStack. If I can't, I'll strongly consider going with RDO.

2015-04-03 14:37:26 -0500 commented answer Would like OpenStack VMs to be able to communicate with local network

Thanks so much for your feedback. I read through the OpenStack documents earlier today and I have a much better understanding of virtual network components like TAP devices, vnetX devices and so forth. I also appreciate your suggestion of using RDO Juno packstack along with the manual steps.

2015-04-03 10:01:13 -0500 asked a question Is it possible to run neutron from devstack using an all on one machine approach?

So, I installed devstack and put together a minimal local.conf file and it installed just fine. Then I realized that I couldn't reach any of the VMs that I was trying to spawn from my local network. I did some research and I think that in order for me to be able to reach the OpenStack VMs from my local area network (192.168.1.X), I need to have devstack-neutron installed along with OVS. Is it possible to use devstack and an all one one machine approach with neutron so that I can reach my OpenStack VMs from my LAN? I've been trying to get this to work for over a week now and I haven't been able to.

2015-04-03 10:01:12 -0500 asked a question Would like OpenStack VMs to be able to communicate with local network


I would like to use DevStack to set up an all-on-one-machine (bare metal) installation of OpenStack that will allow me to launch VMs with the ability for those VMs to communicate over the LAN and reach the internet. I would also like machines on the LAN to be able to communicate directly with the OpenStack VMs.


I installed Ubuntu 14.04 and installed Dev stack with a minimal local.conf configuration file using defaults which gave me networking with Nova networking. The setup and installation was a snap. I could ping the machines on my network just fine. However, I couldn't reach the OpenStack VMs on a network which wasn't surprising to me once I started to investigate the configuration of the environment.

I came to the conclusion that what I really wanted to do was to reinstall using neutron with DevStack to provide the capability that I'm looking for. I didn't know what I was in for. I've been trying to get this to work for around one week solid now (a couple of hours each evening) and I'm no closer than when I started. There are several resources out there on the internet that supposedly show you how to do this but I've tried each one of them and ran into issues each time I've tried it

What's absolutely frustrating is that I can keep the same local.conf file, perform a git clone (after ./ && ./ and removing ./devstack) and I get a different failure. Wow.

So, is it even possible to do what I'm trying to do with devstack? Should I install OpenStack from scratch??

local.conf File:



disable_service n-net

enable-service q-svc q-agt q-dhcp q-l3

Current Error:

    + echo 'stuff "/usr/local/bin/glance-api --config-file=/etc/glance/glance-api.conf
+ [[ -n /opt/stack/logs ]]
+ echo 'logfile /opt/stack/logs/g-api.log.2015-04-02-154834'
+ echo 'log on'
+ screen -S stack -X screen -t g-api
+ local real_logfile=/opt/stack/logs/g-api.log.2015-04-02-154834
+ echo 'LOGDIR: /opt/stack/logs'
LOGDIR: /opt/stack/logs
+ echo 'SCREEN_LOGDIR: '
+ echo 'log: /opt/stack/logs/g-api.log.2015-04-02-154834'
log: /opt/stack/logs/g-api.log.2015-04-02-154834
+ [[ -n /opt/stack/logs ]]
+ screen -S stack -p g-api -X logfile /opt/stack/logs/g-api.log.2015-04-02-154834
+ screen -S stack -p g-api -X log on
+ ln -sf /opt/stack/logs/g-api.log.2015-04-02-154834 /opt/stack/logs/g-api.log
+ [[ -n '' ]]
+ sleep 3
++ echo -ne '\015'
+ NL=$'\r'
+ [[ -n '' ]]
+ screen -S stack -p g-api -X stuff '/usr/local/bin/glance-api --config-file=/etc/glance/glance-api.conf & echo $! >/opt/stack/status/stack/; fg || echo "g-api failed to start" | tee "/opt/stack/status/stack/g-api.failure"
+ is_service_enabled g-graffiti
++ set +o
++ grep xtrace
+ local 'xtrace ...