Ask Your Question

socfreak390's profile - activity

2016-03-21 04:26:38 -0600 received badge  Famous Question (source)
2016-02-29 15:20:43 -0600 received badge  Famous Question (source)
2016-02-16 06:23:15 -0600 received badge  Notable Question (source)
2016-02-11 17:10:37 -0600 received badge  Popular Question (source)
2016-02-11 07:39:44 -0600 received badge  Notable Question (source)
2016-02-11 07:23:42 -0600 asked a question Couldn't obtain IP address of instance

ceilometer-acentral.log keeps giving me this error.

ERROR ceilometer.hardware.discovery [req-48f8d9fd-2a35-4b24-9b71-f6be9cc691bd admin - - - -] Couldn't obtain IP address of instance fa90fd3b-47f1-4d78-99be-f63d2c3ac1be

Any idea how to resolve this? I am running Openstack from devstack

2016-02-11 00:23:53 -0600 answered a question can anybody help me in installing devstack

I guess you are running ./stack.sh as root/superuser Can you try the following?

adduser stack
sudo visudo

Find the part of the file that is labeled "User privilege specification" and change it to the following

# User privilege specification
root    ALL=(ALL:ALL) ALL
stack   ALL=(ALL:ALL) ALL

Close the file, exit and log in as "stack". Download devstack and create /opt/stack

cd /home/stack
git clone https://github.com/openstack-dev/devstack -b stable/liberty
sudo mkdir /opt/stack

Create your local.conf file under /home/stack/devstack and give the following permissions.

sudo chown -R stack:stack /home/stack/devstack
sudo chown -R stack:stack /opt/stack
sudo chmod 770 /home/stack/devstack
sudo chmod 770 /opt/stack

then run ./stack.sh

2016-02-10 23:58:27 -0600 commented answer Problems with devstack and ceilometer

I am having the same issue with stable/liberty.

https://ask.openstack.org/en/question/87937/ceilometer-warning-there-are-no-meters-defined-yet/ (https://ask.openstack.org/en/question...)

2016-01-28 00:15:39 -0600 received badge  Popular Question (source)
2016-01-27 01:13:45 -0600 asked a question Ceilometer Warning: There are no meters defined yet.

I have installed a Openstack All-In-One setup using devstack on a Ubuntu server machine. The installation completed successfully.

Here is my local.conf

[[local|localrc]]

# Credentials
ADMIN_PASSWORD=openstack
MYSQL_PASSWORD=$ADMIN_PASSWORD
RABBIT_PASSWORD=$ADMIN_PASSWORD
SERVICE_PASSWORD=$ADMIN_PASSWORD
SERVICE_TOKEN=$ADMIN_PASSWORD

# Network Configuration
FIXED_RANGE=79.19.0.0/24
NETWORK_GATEWAY=79.19.0.1
FLOATING_RANGE=192.168.1.0/24
PUBLIC_NETWORK_GATEWAY=192.168.1.1
HOST_IP=192.168.1.180
PUBLIC_INTERFACE=eth1
Q_USE_SECGROUP=True
Q_FLOATING_ALLOCATION_POOL=start=192.168.1.185,end=192.168.1.188
Q_L3_ENABLED=True
Q_USE_PROVIDERNET_FOR_PUBLIC=True
OVS_PHYSICAL_BRIDGE=br-ex
PUBLIC_BRIDGE=br-ex
OVS_BRIDGE_MAPPINGS=public:br-ex

# Branch
GLANCE_BRANCH=stable/liberty
HORIZON_BRANCH=stable/liberty
KEYSTONE_BRANCH=stable/liberty
NOVA_BRANCH=stable/liberty
NEUTRON_BRANCH=stable/liberty
HEAT_BRANCH=stable/liberty
CEILOMETER_BRANCH=stable/liberty
TROVE_BRANCH=stable/liberty 

# Enable Logging
LOGFILE=/opt/stack/logs/stack.sh.log
VERBOSE=True
LOG_COLOR=True
SCREEN_LOGDIR=/opt/stack/logs
LOGDAYS=1


# Services
ENABLED_SERVICES=rabbit,mysql,key
ENABLED_SERVICES+=,n-api,n-crt,n-obj,n-cpu,n-cond,n-sch,n-novnc,n-cauth 
ENABLED_SERVICES+=,s-proxy,s-object,s-container,s-account 
ENABLED_SERVICES+=,g-api,g-reg 
ENABLED_SERVICES+=,cinder,c-api,c-vol,c-sch,c-bak 
ENABLED_SERVICES+=,trove,tr-api,tr-tmgr,tr-cond
ENABLED_SERVICES+=,horizon

# Ceilometer
enable_plugin ceilometer git://git.openstack.org/openstack/ceilometer
CEILOMETER_PIPELINE_INTERVAL=60
CEILOMETER_BACKEND=mongodb
ENABLED_SERVICES+=,ceilometer-acompute,ceilometer-acentral,ceilometer-collector,ceilometer-api
ENABLED_SERVICES+=,ceilometer-alarm-notify,ceilometer-alarm-eval,ceilometer-alarm-singleton

# Heat
ENABLED_SERVICES+=,heat,h-api,h-api-cfn,h-api-cw,h-eng

# Neutron
DISABLED_SERVICES=n-net
ENABLED_SERVICES+=,q-svc,q-agt,q-dhcp,q-l3,q-meta,q-fwaas,q-lbaas,q-metering,neutron

# Neutron - Load Balancing
ENABLED_SERVICES+=,q-lbaas

# VLAN configuration
Q_PLUGIN=ml2
ENABLE_TENANT_VLANS=True

# Swift
SWIFT_HASH=66a3d6b56c1f479c8b4e70ab5c2000f5
SWIFT_REPLICAS=1 
SWIFT_DATA_DIR=$DEST/data

# Tempest
enable_service tempest

However when I log in to Dashboard and go to Stats tab under Resources Usage Overview I get this warning

Warning: There are no meters defined yet.

also from the CLI

stack@openstack-kvm:~/devstack$ ceilometer meter-list
+------+------+------+-------------+---------+------------+
| Name | Type | Unit | Resource ID | User ID | Project ID |
+------+------+------+-------------+---------+------------+
+------+------+------+-------------+---------+------------+

Here is my nova .conf

[DEFAULT]
vif_plugging_timeout = 300
vif_plugging_is_fatal = True
linuxnet_interface_driver =
security_group_api = neutron
network_api_class = nova.network.neutronv2.api.API
firewall_driver = nova.virt.firewall.NoopFirewallDriver
compute_driver = libvirt.LibvirtDriver
default_ephemeral_format = ext4
metadata_workers = 2
ec2_workers = 2
osapi_compute_workers = 2
rpc_backend = rabbit
keystone_ec2_url = http://192.168.1.180:5000/v2.0/ec2tokens
ec2_dmz_host = 192.168.1.180
xvpvncproxy_host = 0.0.0.0
novncproxy_host = 0.0.0.0
vncserver_proxyclient_address = 127.0.0.1
vncserver_listen = 127.0.0.1
vnc_enabled = true
xvpvncproxy_base_url = http://192.168.1.180:6081/console
novncproxy_base_url = http://192.168.1.180:6080/vnc_auto.html
notification_driver = messaging
notify_on_state_change = vm_and_task_state
instance_usage_audit_period = hour
instance_usage_audit = True
logging_exception_prefix = %(color)s%(asctime)s.%(msecs)03d TRACE %(name)s ^[[01;35m%(instance)s^[[00m
logging_debug_format_suffix = ^[[00;33mfrom (pid=%(process)d) %(funcName)s %(pathname)s:%(lineno)d^[[00m
logging_default_format_string = %(asctime)s.%(msecs)03d %(color)s%(levelname)s %(name)s [^[[00;36m-%(color)s] ^[[01;35m%(instance)s%(color)s%(message)s^[[00m
logging_context_format_string = %(asctime)s.%(msecs)03d %(color)s%(levelname)s %(name)s [^[[01;36m%(request_id)s ^[[00;36m%(user_name)s %(project_name)s%(color)s] ^[[01;35m%(instance)s%(color)s%(message)s^[[00m
force_config_drive = True
instances_path = /opt/stack/data/nova/instances
state_path = /opt/stack/data/nova
enabled_apis = ec2,osapi_compute,metadata
s3_listen = 0.0.0.0
metadata_listen = 0.0.0.0
ec2_listen = 0.0.0.0
osapi_compute_listen = 0.0.0.0
instance_name_template ...
(more)
2016-01-20 01:16:53 -0600 received badge  Enthusiast
2016-01-20 01:16:53 -0600 received badge  Enthusiast
2015-06-25 02:18:49 -0600 received badge  Famous Question (source)
2015-06-18 02:52:38 -0600 received badge  Famous Question (source)
2015-06-14 20:47:26 -0600 received badge  Notable Question (source)
2015-06-14 20:47:26 -0600 received badge  Popular Question (source)
2015-06-10 02:25:48 -0600 commented answer booting vm from iso file fails

attaching volume to an instance fails

2015-06-10 01:16:27 -0600 commented answer How to attach volume for instance on /dev/hda

you cannot attach volume to an instance in the suspended state.

2015-06-09 09:05:18 -0600 received badge  Supporter (source)
2015-06-09 08:46:36 -0600 asked a question Cannot attach bootable volume to instance

Hello, I am running Openstack Juno on a Ubuntu 14.04 Server Edition machine. I have successfully installed and started Openstack(built using devstack).

I have uploaded a Fedora 19 image and have created a bootable volume out of it. I have also created an instance of the aforesaid image.

Now my problem is whenever I'm trying to attach the volume to an instance, it silently fails after a brief attempt. If I create an instance out of the volume then it does attach but then the instance console shows "Boot failed: not a bootable disk"

Any help is welcome.

2015-06-09 07:36:52 -0600 received badge  Notable Question (source)
2015-06-09 07:36:52 -0600 received badge  Popular Question (source)
2015-04-02 00:49:11 -0600 answered a question Openstack interface vnet0 doesn't forward data to br100.

Yes, continuous ping works. tcpdump shows the same packets in eth0 and br100(same MAC)

route -n on compute node is

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.110.2   0.0.0.0         UG    0      0        0 br100
10.0.0.0        0.0.0.0         255.255.255.0   U     0      0        0 br100
192.168.110.0   0.0.0.0         255.255.255.0   U     0      0        0 br100
192.168.110.0   0.0.0.0         255.255.255.0   U     1      0        0 eth0
192.168.122.0   0.0.0.0         255.255.255.0   U     0      0        0 virbr0

I have noticed ping from 10.0.0.3 with source set as anything other than 10.0.0.3 fails like ping -I 10.0.0.20 8.8.8.8 fails but ping 8.8.8.8 works

2015-04-01 08:34:02 -0600 asked a question Openstack interface vnet0 doesn't forward data to br100.

This is my Openstack single node VM's networking state. During installation I had setup the localrc with the following

HOST_IP=192.168.110.145
FLAT_INTERFACE=eth0

The server had only eth0 interface with IP address:192.168.110.145 before openstack installation and then post installation and running an instance brings it to this state

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet 169.254.169.254/32 scope link lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master br100 state UP group default qlen 1000
    link/ether 00:0c:29:84:b3:07 brd ff:ff:ff:ff:ff:ff
    inet 192.168.110.145/24 brd 192.168.110.255 scope global eth0
       valid_lft forever preferred_lft forever
    inet6 fe80::20c:29ff:fe84:b307/64 scope link
       valid_lft forever preferred_lft forever
3: virbr0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default
    link/ether ee:09:3c:2c:ce:78 brd ff:ff:ff:ff:ff:ff
    inet 192.168.122.1/24 brd 192.168.122.255 scope global virbr0
       valid_lft forever preferred_lft forever
4: br100: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default
    link/ether 00:0c:29:84:b3:07 brd ff:ff:ff:ff:ff:ff
    inet 10.0.0.1/24 brd 10.0.0.255 scope global br100
       valid_lft forever preferred_lft forever
    inet 192.168.110.145/24 scope global br100
       valid_lft forever preferred_lft forever
    inet6 fe80::d8c4:c2ff:fed2:2abc/64 scope link
       valid_lft forever preferred_lft forever
7: vnet0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master br100 state UNKNOWN group default qlen 500
    link/ether fe:16:3e:9f:a8:dd brd ff:ff:ff:ff:ff:ff
    inet6 fe80::fc16:3eff:fe9f:a8dd/64 scope link
       valid_lft forever preferred_lft forever

My questions are:

  1. Is it normal that br100 and eth0 share the same MAC and IP address?
  2. I can ping 8.8.8.8 from the instance, the ICMP data goes from the instance->vnet0->br100->eth0->internet and back but when I generate ICMP traffic from a load tester software towards 8.8.8.8, vnet0 seems to recieve those packets but does not forward it to br100.

I have enabled ICMP traffic in Access & Security.

Essentially I need to send data to and from the instance.