Ask Your Question

MentheAlow's profile - activity

2015-04-16 04:34:43 -0500 received badge  Teacher (source)
2015-04-16 04:18:45 -0500 answered a question How can I send commands to VMs through the CLI?

I think it primarily depends on the hypervisor you're using. For example, if you use OpenVZ, you may use: vzctl *veid* enter to enter into the console.

About nova get-serial-console, you should take a look there: http://blog.oddbit.com/2014/12/22/acc.... There're also nova get-rdp-console, nova get-spice-console and nova get-vnc-console.

2015-04-10 09:47:36 -0500 commented answer HARestarter with HOT

I have a nice CircularDependancyException.. The instance requires the alarm, the alarm requires the restarter and the restarter depends on the instance ~ http://hastebin.com/zepivelume.sm

2015-04-08 06:45:20 -0500 received badge  Enthusiast
2015-04-04 01:53:07 -0500 received badge  Editor (source)
2015-04-03 15:57:10 -0500 commented answer What would be a recommended setup for a HA ceilometer's database?

I'm currently using Juno + Ceilometer HA w/ Percona XtraDB Cluster. I have some alarms thought. Works fine so far with less than 10 compute servers.

2015-04-03 15:56:47 -0500 answered a question What would be a recommended setup for a HA ceilometer's database?

I'm currently using Ceilometer HA w/ Percona XtraDB Cluster. I have some alarms thought. Works fine so far with less than 10 compute servers.

2015-04-03 12:25:56 -0500 commented answer Keystone loses token on a HA setup with Galera.

Your blog post is wrong. You've to use pt-archiver instead of deleting the expired tokens using standard database manipulation commands because it prevents the Keystone database from being blocked for significant time periods while the rows with expired tokens are deleted. http://goo.gl/ROcITh

2015-04-03 12:19:52 -0500 commented answer Keystone loses token on a HA setup with Galera.

This is not an immediate solution because we have multiple keystone servers load-balanced.

2015-04-03 12:12:30 -0500 received badge  Supporter (source)
2015-04-03 12:11:52 -0500 answered a question Keystone loses token on a HA setup with Galera.

Same issue here.

My setup has 3 controllers with MySQL/Galera + HAProxy (Every MySQL server in "backup mode" : only one is actually used). How to reproduce ? Launch 10 instances in Horizon --> 33% will be stuck in "Building - No State" with this error in Keystone logs:

2015-04-03 19:13:46.663 10695 WARNING keystone.common.wsgi [-] Could not find token: 879b4ff1d25a4974ace49cf293734aba

I partially solved it by changing the HAProxy balancing mode from Round-Robin to Source for Keystone Public and Admin clusters. It means that I still have some missing tokens but at least, it doesn't block instance creations anymore. Hope it helps.

2015-04-01 13:12:12 -0500 received badge  Nice Question
2015-03-31 18:16:13 -0500 received badge  Student