Ask Your Question

KoSuKe's profile - activity

2015-11-09 02:29:17 -0500 commented question Error accessing Glance images in Kilo: AttributeError at /project/images/instance-id

I've update OpenStack packages on Ubuntu 14.04 to version 2015.1.2-0ubuntu1~cloud0, and right now it works fine.

2015-11-06 02:49:07 -0500 received badge  Popular Question (source)
2015-11-06 02:48:26 -0500 commented question Error accessing Glance images in Kilo: AttributeError at /project/images/instance-id

I've the same issue. Ubuntu 14.04 + OpenStack Kilo (Multi Node)

2015-10-30 06:21:20 -0500 asked a question l3_ha lost connectivity

I not sure if my issue is related to this bug https://bugs.launchpad.net/neutron/+b..., it's new one or it's a misconfiguration, but I have the same symptoms.

If I create a new router in HA ( # neutron router-create --ha=True router01), everything works fine.

When I create a new router without HA flag or HA=False, if I have an instance with one floating IP and then I assign a floating IP to other instance, I lose external connectivity to both instance (doesn't matter the number of instances, I lose external connectivity with all of them) until I connect to anyone by vnc and I ping to external/internet IP, and then everything works fine again.

Sorry, English is not my native language.

  • Ubuntu 14.04
  • Open vSwitch 2.3.2
  • Kilo 2015.1.1

  • root@network01:/home/administrator# cat /etc/neutron/neutron.conf | grep -v ^$ | grep -v ^#
  • [DEFAULT]
  • verbose = False
  • rpc_backend = rabbit
  • auth_strategy = keystone
  • core_plugin = ml2
  • service_plugins = router
  • allow_overlapping_ips = True
  • dhcp_agents_per_network = 2
  • l3_ha = True
  • max_l3_agents_per_router = 2
  • min_l2_agents_per_router = 2
  • [matchmaker_redis]
  • [matchmaker_ring]
  • [quotas]
  • [agent]
  • root_helper = sudo /usr/bin/neutron-rootwrap /etc/neutron/rootwrap.conf
  • [keystone_authtoken]
  • auth_uri = http://10.8.11.120:5000
  • auth_url = http://10.8.11.120:35357
  • auth_plugin = password
  • project_domain_id = default
  • user_domain_id = default
  • project_name = service
  • username = neutron
  • password = secret
  • [database]
  • [nova]
  • [oslo_concurrency]
  • lock_path = $state_path/lock
  • [oslo_policy]
  • [oslo_messaging_amqp]
  • [oslo_messaging_qpid]
  • [oslo_messaging_rabbit]
  • rabbit_hosts = controller01:5672,controller02:5672
  • rabbit_userid = openstack
  • rabbit_password = secret
  • rabbit_retry_interval = 1
  • rabbit_retry_backoff = 2
  • rabbit_max_retries = 0
  • rabbit_durable_queues = True
  • rabbit_ha_queues = True
  • root@network01:/home/administrator# cat /etc/neutron/l3_agent.ini | grep -v ^$ | grep -v ^#
  • [DEFAULT]
  • verbose = True
  • interface_driver = neutron.agent.linux.interface.OVSInterfaceDriver
  • external_network_bridge =
  • router_delete_namespaces = True
  • root@network01:/home/administrator# cat /etc/neutron/plugins/ml2/ml2_conf.ini | grep -v ^$ | grep -v ^#
  • [ml2]
  • type_drivers = flat,vlan,gre,vxlan
  • tenant_network_types = gre
  • mechanism_drivers = openvswitch
  • [ml2_type_flat]
  • flat_networks = external
  • [ml2_type_vlan]
  • [ml2_type_gre]
  • tunnel_id_ranges = 1:1000
  • [ml2_type_vxlan]
  • [securitygroup]
  • enable_security_group = True
  • enable_ipset = True
  • firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver
  • [ovs]
  • local_ip = 192.168.0.101
  • bridge_mappings = external:br-ex
  • [agent]
  • tunnel_types = gre
  • root@compute01:/home/ubuntu# cat /etc/neutron/neutron.conf | grep -v ^$ | grep -v ^#
  • [DEFAULT]
  • verbose = True
  • rpc_backend = rabbit
  • auth_strategy = keystone
  • core_plugin = ml2
  • service_plugins = router
  • allow_overlapping_ips = True
  • [matchmaker_redis]
  • [matchmaker_ring]
  • [quotas]
  • [agent]
  • root_helper = sudo /usr/bin/neutron-rootwrap /etc/neutron/rootwrap.conf
  • [keystone_authtoken]
  • auth_uri = http://10.8.11.120:5000
  • auth_url = http://10.8.11.120:35357
  • auth_plugin = password
  • project_domain_id = default
  • user_domain_id = default
  • project_name = service
  • username = neutron
  • password = secret
  • [database]
  • [nova]
  • [oslo_concurrency]
  • lock_path = $state_path/lock
  • [oslo_policy]
  • [oslo_messaging_amqp]
  • [oslo_messaging_qpid]
  • [oslo_messaging_rabbit]
  • rabbit_hosts = controller01:5672,controller02:5672
  • rabbit_userid = openstack
  • rabbit_password = secret
  • rabbit_retry_interval = 1
  • rabbit_retry_backoff = 2
  • rabbit_max_retries = 0
  • rabbit_durable_queues = True
  • rabbit_ha_queues = True
  • root@compute01:/home/ubuntu# cat /etc/neutron/plugins/ml2/ml2_conf.ini | grep -v ^$ | grep -v ^#
  • [ml2]
  • type_drivers = flat,vlan,gre,vxlan
  • tenant_network_types = gre
  • mechanism_drivers = openvswitch
  • [ml2_type_flat]
  • [ml2_type_vlan]
  • [ml2_type_gre]
  • tunnel_id_ranges = 1:1000
  • [ml2_type_vxlan]
  • [securitygroup]
  • enable_security_group = True
  • enable_ipset = True
  • firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver
  • [ovs]
  • local_ip = 192.168.0.105
  • [agent]
  • tunnel_types = gre
  • 2015-08-07 08:33:27 -0500 received badge  Scholar (source)
    2015-08-07 06:44:48 -0500 received badge  Teacher (source)
    2015-08-07 04:33:16 -0500 answered a question Compute instances

    Try with this:

    $ nova evacuate instance_name compute_node_online --on-shared-storage
    
    2015-05-29 06:48:40 -0500 received badge  Famous Question (source)
    2015-04-29 05:47:34 -0500 received badge  Notable Question (source)
    2015-04-20 15:36:06 -0500 received badge  Popular Question (source)
    2015-04-20 03:39:44 -0500 asked a question Juno KVM bandwidth quota issue

    Hi,

    I try to create an instance with bandwidth quota, but it doesn't work, I get the same bandwidth with a flavor with quota and without.

    I don't see any error or warning in logs.

    I create a flavor

    nova flavor-create --is-public false limited auto 512 10 2
    
    nova flavor-key limited set quota:vif_inbound_average=1024
    
    nova flavor-key limited set quota:vif_outbound_average=1024
    

    Then I boot an instance with this flavor, and then I run an iperf

    Client connecting to XXX.XXX.XXX.XXX, UDP port 5001
    Sending 1470 byte datagrams
    UDP buffer size: 208 KByte (default)
    -------------------------------------------------------------
    [  3] local 192.168.1.106 port 36275 connected with XXX.XXX.XXX.XXX port 5001
    [  3] Interval      Transfer        Bandwidth
    [  3] 0.0-10.0 sec  1.25MBytes      1.05 Mbits/sec
    [  3] Sent 893 datagrams
    

    -

    # tc qdisc
    qdisc mq 0: dev eth0 root
    qdisc mq 0: dev eth1 root
    qdisc pfifo_fast 0: dev qvo658149a1-8f root refcnt 2 bands 3 priomap  1 2 2 2 1 2 0 0 1 1 1 1 1 1 1 1
    qdisc pfifo_fast 0: dev qvb658149a1-8f root refcnt 2 bands 3 priomap  1 2 2 2 1 2 0 0 1 1 1 1 1 1 1 1
    qdisc htb 1: dev tap658149a1-8f root refcnt 2 r2q 10 default 1 direct_packets_stat 0 direct_qlen 500
    qdisc sfq 2: dev tap658149a1-8f parent 1:1 limit 127p quantum 1514b depth 127 divisor 1024 perturb 10sec
    qdisc ingress ffff: dev tap658149a1-8f parent ffff:fff1 ----------------
    

    -

    ii nova-compute-kvm 1:2014.2.2-0ubuntu1~cloud0 all OpenStack Compute - compute node (KVM)
    ii libvirt-bin 1.2.2-0ubuntu13.1.9 amd64 programs for the libvirt library
    ii nova-compute-libvirt 1:2014.2.2-0ubuntu1~cloud0 all OpenStack Compute - compute node libvirt support
    ii openvswitch-switch 2.3.1-0ubuntu1~cloud0 amd64 Open vSwitch switch implementations
    
    2015-04-16 09:27:07 -0500 received badge  Enthusiast
    2015-04-07 11:49:32 -0500 received badge  Famous Question (source)
    2015-04-07 03:36:32 -0500 received badge  Editor (source)
    2015-04-07 03:34:34 -0500 answered a question Neutron Juno DHCP issue (SOLVED)

    It was something wrong with openvswitch. I upgraded it to 2.3.1 and it's still failing, then I removed openvswtich packages, deleted all directories of it, finally I reinstalled openvswitch 2.0.2 and it works.

    It's not a DHCP issue, it's a openvswtich issue on compute node, if I configure static IPs on instances, on the same compute node, I can't ping between them.

    2015-03-28 02:03:50 -0500 received badge  Student (source)
    2015-03-27 15:48:01 -0500 commented answer Neutron Juno DHCP issue (SOLVED)

    My dnsmasq config file have "dhcp-option-force=26,1454"

    2015-03-27 07:16:23 -0500 received badge  Notable Question (source)
    2015-03-27 06:12:02 -0500 received badge  Popular Question (source)
    2015-03-26 13:33:32 -0500 asked a question Neutron Juno DHCP issue (SOLVED)

    I've installed Juno on Ubuntu 14.04.2 LTS and instances can't get IP from DHCP. No errors in logs.

    Network Node

    root@network:~# ip a
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo
        valid_lft forever preferred_lft forever
    2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
        link/ether 00:50:56:b1:79:07 brd ff:ff:ff:ff:ff:ff
        inet 10.8.1.131/24 brd 10.8.1.255 scope global eth0
        valid_lft forever preferred_lft forever
    3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
        link/ether 00:50:56:b1:2e:45 brd ff:ff:ff:ff:ff:ff
        inet 10.0.1.21/24 brd 10.0.1.255 scope global eth1
        valid_lft forever preferred_lft forever
    4: eth2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master ovs-system state UP group default qlen 1000
        link/ether 00:50:56:b1:12:ba brd ff:ff:ff:ff:ff:ff
    5: ovs-system: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default
        link/ether be:0e:db:dc:3d:56 brd ff:ff:ff:ff:ff:ff
    6: br-ex: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default
        link/ether 00:50:56:b1:12:ba brd ff:ff:ff:ff:ff:ff
    9: br-int: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default
        link/ether d6:bf:05:38:7d:43 brd ff:ff:ff:ff:ff:ff
    13: phy-br-ex: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
        link/ether 1a:74:47:c1:1b:1b brd ff:ff:ff:ff:ff:ff
    14: int-br-ex: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
        link/ether 9e:ae:d6:8e:e3:b0 brd ff:ff:ff:ff:ff:ff
    15: br-tun: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default
        link/ether c6:7b:a3:9b:ea:4e brd ff:ff:ff:ff:ff:ff
    
    root@network:~# ip netns
    qrouter-eb218066-143d-42b4-ba90-0f719defde66
    qdhcp-38639607-391a-4622-ac0e-37d5a32ced1b
    
    root@network:~# ip netns exec qrouter-eb218066-143d-42b4-ba90-0f719defde66 ip a
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo
        valid_lft forever preferred_lft forever
        inet6 ::1/128 scope host
        valid_lft forever preferred_lft forever
    16: qr-3a45f5b8-01: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default
        link/ether fa:16:3e:a8:55:0b brd ff:ff:ff:ff:ff:ff
        inet 192.168.1.1/24 brd 192.168.1.255 scope global qr-3a45f5b8-01
        valid_lft forever preferred_lft forever
        inet6 fe80::f816:3eff:fea8:550b/64 scope link
        valid_lft forever preferred_lft forever ...
    (more)