Ask Your Question

manikanta2006's profile - activity

2016-03-30 05:19:21 -0600 received badge  Popular Question (source)
2016-03-30 05:19:21 -0600 received badge  Famous Question (source)
2016-03-30 05:19:21 -0600 received badge  Notable Question (source)
2015-12-08 23:40:04 -0600 received badge  Famous Question (source)
2015-08-03 23:45:24 -0600 received badge  Famous Question (source)
2015-08-03 23:45:24 -0600 received badge  Notable Question (source)
2015-04-20 03:04:18 -0600 commented question socket.gaierror: (-5, 'No address associated with hostname')

We are testing the IP v6 support for swift 1.12. while starting the services we facing the error .

2015-04-20 00:26:18 -0600 received badge  Popular Question (source)
2015-04-17 11:12:23 -0600 received badge  Notable Question (source)
2015-04-17 04:07:18 -0600 received badge  Famous Question (source)
2015-04-16 20:17:01 -0600 received badge  Popular Question (source)
2015-04-16 07:45:35 -0600 asked a question socket.gaierror: (-5, 'No address associated with hostname')

while starting the services i getting the below error

[root@storage1 swift]# swift-init main start
proxy-server running (1688 - /etc/swift/proxy-server.conf)
proxy-server already started...
Starting container-server...(/etc/swift/container-server.conf)
Starting account-server...(/etc/swift/account-server.conf)
Starting object-server...(/etc/swift/object-server.conf)
Traceback (most recent call last):
  File "/usr/bin/swift-container-server", line 24, in <module>
    'container-server', default_port=6001, **options))
  File "/usr/lib/python2.6/site-packages/swift/common/wsgi.py", line 378, in run_wsgi
    sock = get_socket(conf, default_port=kwargs.get('default_port', 8080))
  File "/usr/lib/python2.6/site-packages/swift/common/wsgi.py", line 150, in get_socket
    bind_addr[0], bind_addr[1], socket.AF_UNSPEC, socket.SOCK_STREAM)
  File "/usr/lib/python2.6/site-packages/eventlet/support/greendns.py", line 173, in getaddrinfo
    rrset = resolve(host)
  File "/usr/lib/python2.6/site-packages/eventlet/support/greendns.py", line 132, in resolve
    raise socket.gaierror(error)
socket.gaierror: (-5, 'No address associated with hostname')

Traceback (most recent call last):
  File "/usr/bin/swift-account-server", line 24, in <module>
    'account-server', default_port=6002, **options))
  File "/usr/lib/python2.6/site-packages/swift/common/wsgi.py", line 378, in run_wsgi
    sock = get_socket(conf, default_port=kwargs.get('default_port', 8080))
  File "/usr/lib/python2.6/site-packages/swift/common/wsgi.py", line 150, in get_socket
    bind_addr[0], bind_addr[1], socket.AF_UNSPEC, socket.SOCK_STREAM)
  File "/usr/lib/python2.6/site-packages/eventlet/support/greendns.py", line 173, in getaddrinfo
    rrset = resolve(host)
  File "/usr/lib/python2.6/site-packages/eventlet/support/greendns.py", line 132, in resolve
    raise socket.gaierror(error)
socket.gaierror: (-5, 'No address associated with hostname')

Traceback (most recent call last):
  File "/usr/bin/swift-object-server", line 27, in <module>
    **options))
  File "/usr/lib/python2.6/site-packages/swift/common/wsgi.py", line 378, in run_wsgi
    sock = get_socket(conf, default_port=kwargs.get('default_port', 8080))
  File "/usr/lib/python2.6/site-packages/swift/common/wsgi.py", line 150, in get_socket
    bind_addr[0], bind_addr[1], socket.AF_UNSPEC, socket.SOCK_STREAM)
  File "/usr/lib/python2.6/site-packages/eventlet/support/greendns.py", line 173, in getaddrinfo
    rrset = resolve(host)
  File "/usr/lib/python2.6/site-packages/eventlet/support/greendns.py", line 132, in resolve
    raise socket.gaierror(error)
socket.gaierror: (-5, 'No address associated with hostname')

[root@storage1 swift]# 

========================

[root@storage1 swift]# cat account-server.conf 

[DEFAULT]
devices = /srv/node/sdb1
mount_check = false
disable_fallocate = true
bind_ip = 2607:f0d0:1002:11::2
bind_port = 6002
workers = 1        
user = swift
log_facility = LOG_LOCAL2 
recon_cache_path = /var/cache/swift
eventlet_debug = true
db_preallocation = on

[pipeline:main]
pipeline = recon account-server

[app:account-server]
use = egg:swift#account

[filter:recon]
use = egg:swift#recon

[account-replicator]

[account-auditor]

[account-reaper]
[root@storage1 swift]# 

============================


[root@storage1 swift]# cat object-server.conf 
[DEFAULT]
devices = /srv/node/sdb1
mount_check = false
disable_fallocate = true
bind_ip = 2607:f0d0:1002:11::2
bind_port = 6000
workers = 1
user = swift
log_facility = LOG_LOCAL2
recon_cache_path = /var/cache/swift
eventlet_debug = true

[pipeline:main]
pipeline = recon object-server

[app:object-server]
use = egg:swift#object

[filter:recon]
use = egg:swift#recon

[object-replicator]

[object-updater]

[object-auditor]
[root@storage1 swift]# 
==================================


[root@storage1 swift]# cat container-server.conf 
[DEFAULT]
devices = /srv/node/sdb1
mount_check = false
disable_fallocate = true
bind_ip = 2607:f0d0:1002:11::2
bind_port = 6001
workers = 1
user = swift ...
(more)
2015-04-15 01:49:00 -0600 asked a question what is the latest version of swift supported on RHEL 6 ?

what is the latest version of swift supported on RHEL 6 ?

2015-04-15 01:47:48 -0600 received badge  Popular Question
2015-04-15 01:38:56 -0600 received badge  Notable Question (source)
2015-04-15 01:38:34 -0600 received badge  Enthusiast
2015-04-14 02:43:03 -0600 received badge  Popular Question (source)
2015-04-14 02:42:57 -0600 received badge  Editor (source)
2015-04-13 13:47:23 -0600 received badge  Popular Question (source)
2015-04-13 10:49:07 -0600 received badge  Student (source)
2015-04-13 02:46:42 -0600 asked a question swift ipv 6 support

we are on swift 1.12 we need to upgrade to swift which supports IP v6 . any suggestions on this please.

2015-04-13 02:19:21 -0600 asked a question Which version of swift supports IPv6 ?

Which version of swift supports IP v6 ?

2015-04-13 01:12:31 -0600 received badge  Notable Question (source)
2015-04-10 11:35:01 -0600 received badge  Popular Question (source)
2015-04-10 01:34:48 -0600 asked a question is there any os requirement for installing openstack swift 2.2.2 ?

is there any os requirement for installing openstack swift 2.2.2 ? Can we install it on rhel 6.2 [64bit ]?

I tired to install on rhel 6.2 but it showing systemd as dependency . But when i checked in some forums its says that systemd is not available for rhel 6.2 [el 6] . please suggest. How to take snapshots in swift before upgrade?

2015-04-08 02:12:09 -0600 received badge  Notable Question (source)
2015-04-02 17:52:34 -0600 received badge  Famous Question (source)
2015-03-31 18:23:56 -0600 received badge  Popular Question (source)
2015-03-31 01:44:02 -0600 asked a question Important files that we need to take backup before swift upgrade

Hi ,

Can u please list the important config files that we need to take backup before a swift upgrade from 1.4 to 2.2 ].

Thanks, Mani.

2015-03-31 01:37:33 -0600 received badge  Notable Question (source)
2015-03-30 17:18:52 -0600 received badge  Popular Question (source)
2015-03-30 01:40:32 -0600 asked a question swift upgrade

Hi,

We need to upgrade swift version on our production setup. Before that we need more clarity on : 1) What is the upgrade path for version 1.4.0 to 2.2.0 . Can we jump the version from 1.4.0 to 2.2.0 seamlessly?

Regards, Manikanta.

2015-03-26 10:03:05 -0600 asked a question Please explain the upgrade process for swift from 1.12 to 2.2

we have a 5 node swift environment running on 1.12 now we want to upgrade to 2.2.