Ask Your Question

magmaiceman's profile - activity

2015-05-12 09:45:18 -0600 received badge  Famous Question (source)
2015-05-09 01:03:41 -0600 received badge  Famous Question (source)
2015-05-09 01:03:41 -0600 received badge  Notable Question (source)
2015-04-15 15:26:45 -0600 received badge  Popular Question (source)
2015-04-14 11:44:52 -0600 asked a question How to RE-configure base IP address of OpenStack host?

Note: Using OpenStack Juno as per RDO single-host installation quick start (packstack --allinone).

After having installed Juno from scratch (as per RDO quick start), everything works as expected. However the base IP address of the system (only a single NIC) is determined by DHCP. Since the original install, DHCP has now changed my base IP address, and as a result OpenStack no longer runs properly (all hard-coded configuration created by "packstack --allinone) is still based on the old IP).

How can I re-configure the existing installation to use the new IP address? (i.e. without having to do a full reinstallation from scratch)

2015-04-02 23:55:59 -0600 received badge  Famous Question (source)
2015-04-01 00:49:43 -0600 received badge  Student (source)
2015-03-28 15:22:41 -0600 received badge  Notable Question (source)
2015-03-28 08:24:26 -0600 received badge  Popular Question (source)
2015-03-27 15:46:31 -0600 asked a question Juno on laptop: fails due to IP changes

Trying to run Juno on a laptop as I need to work in OpenStack environment while away on business.

Using RDO packstack --allinone configuration. Initial configuration was performed while connect to LAN via wired Ethernet connection.

Now, when not connected to this network (no wired connection) I get "Error: unable to retrieve network quota information" and other errors when logging into OpenStack i.e. via localhost. Even if the NIC is configured to the same IP address as it had on the wired network I get this same error. Even if I conned via WiFi I continue to get this and other errors.

Can I not run OpenStack 'offline'? i.e. without external (Internet/LAN) connectivity?

2015-03-27 06:42:40 -0600 received badge  Famous Question (source)
2015-03-26 05:43:37 -0600 received badge  Notable Question (source)
2015-03-26 03:08:18 -0600 received badge  Famous Question (source)
2015-03-25 07:10:32 -0600 received badge  Notable Question (source)
2015-03-25 07:10:32 -0600 received badge  Popular Question (source)
2015-03-25 02:41:24 -0600 received badge  Popular Question (source)
2015-03-25 02:35:35 -0600 received badge  Notable Question (source)
2015-03-25 01:15:56 -0600 received badge  Popular Question (source)
2015-03-24 20:49:09 -0600 answered a question Configure OpenStack on a WiFi-only system?

Thanks echiu for your reply. Although I think perhaps I didn't explain my question very well (or perhaps I am just missing the point). The DEVICE=xxxx and ifcfg-xxxx scripts I am referring to are all on the host - not on the VM. The RDO documentation states to make these changes (in addition to disabling NetworkManager and enabling the network service) on the host. The IP address I have on the host is assigned via DHCP and there is no corresponding ifcfg-xxxx script because of the WiFi nature of the connection, i.e. as opposed to eth0 etc.

Does that clarify things or am I somehow missing the point? I'm trying to determine how to set up the host side of things, where the host's only IP address is assigned via DHCP over WiFi.

2015-03-24 15:59:15 -0600 asked a question Configure OpenStack on a WiFi-only system?

OpenStack Juno installed as per RDO onto a CentOS 7.0 Host. NetworkManager disabled and network service enabled as required.

As per RDO QuickStart instructions, the DEVICE=xxxx variable should be set in the ifcfg-xxxx network script. However, on this particular system my only IP address is via WiFi, and as such no explicit ifcfg-xxxx script exists in the traditional sense (WiFi network can be anything and can't be assumed ahead of time) - normally NetworkManager would be used to configure the address but of course this service is disabled as per RDO instructions.

2015-03-24 15:48:32 -0600 asked a question br-ex not being assigned IP address automatically at boot

OpenStack Juno installed as per RDO onto a CentOS 7.0 Host. (NetworkManager disabled, network service enabled.)

Interface br-ex is not assigned any address (automatically) at boot of OpenStack host:

[root@CentOS7Host02 ~]# ifconfig br-ex
br-ex: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::847e:5dff:feae:814c  prefixlen 64  scopeid 0x20<link>
        ether 86:7e:5d:ae:81:4c  txqueuelen 0  (Ethernet)
        RX packets 23  bytes 1854 (1.8 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 10  bytes 828 (828.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Here is its configuration:

[root@CentOS7Host02 ~]# cat /etc/sysconfig/network-scripts/ifcfg-br-ex
DEVICE=br-ex
DEVICETYPE=ovs
TYPE=OVSBridge
BOOTPROTO=static
IPADDR=172.24.4.225_br_ex
NETMASK=255.255.255.240_br_ex
ONBOOT=yes

Should this not be assigning the address 172.24.4.225 automatically at boot?

Note that if I manually configure the address (i.e. via ifconfig from the command line) then all works well.

2015-03-24 15:40:56 -0600 received badge  Editor (source)
2015-03-24 15:40:37 -0600 answered a question After rebooting OpenStack host, router configuration is lost?

Yes NetworkManager was already disabled and the network service already enabled. Perhaps some race condition at boot? On subsequent reboot I don't see my problem any more. Should I, I will try your suggestion (i.e. for the "YES" option in your answer) before rebooting. Thanks for the info.

2015-03-24 13:14:49 -0600 asked a question After rebooting OpenStack host, router configuration is lost?

OpenStack Juno installed as per RDO onto a CentOS 7.0 Host. Configured several networks, routers etc. Upon reboot of the host, the router configuration can still be seen via Horizon, however the associated netns namespaces are not getting created - indeed a "ip netns" shows no qrouters any more (the qdhcp servers are still there).

Is the configuration not being 'saved' over host reboot? Or just not recreated automatically?