Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

cinder server node is down

Hi ,

My cinder storage node is down. I have installed openstack newton. After installation of cinder-volume on block storage. I proceed with a restart command given below.It show's the status running for a second and then goes inactive/stopped state.

service tgt restart service cinder-volume restart

cinder-volume logs are below

2016-12-05 10:06:45.144 32696 INFO root [-] Generating grammar tables from /usr/lib/python2.7/lib2to3/Grammar.txt 2016-12-05 10:06:45.206 32696 INFO root [-] Generating grammar tables from /usr/lib/python2.7/lib2to3/PatternGrammar.txt 2016-12-05 10:06:45.252 32696 WARNING py.warnings [req-58a488ad-2071-4c82-9a8e-61754158676f - - - - -] /usr/lib/python2.7/dist-packages/oslo_db/sqlalchemy/enginefacade.py:241: NotSupportedWarning: Configuration option(s) ['use_tpool'] not supported exception.NotSupportedWarning

2016-12-05 10:06:45.343 32696 INFO cinder.rpc [req-58a488ad-2071-4c82-9a8e-61754158676f - - - - -] Automatically selected cinder-scheduler objects version 1.11 as minimum service version. 2016-12-05 10:06:45.343 32696 ERROR cinder.cmd.volume [req-58a488ad-2071-4c82-9a8e-61754158676f - - - - -] Volume service ip-10-0-0-174@lvm failed to start. 2016-12-05 10:06:45.343 32696 ERROR cinder.cmd.volume Traceback (most recent call last): 2016-12-05 10:06:45.343 32696 ERROR cinder.cmd.volume File "/usr/lib/python2.7/dist-packages/cinder/cmd/volume.py", line 81, in main 2016-12-05 10:06:45.343 32696 ERROR cinder.cmd.volume binary='cinder-volume') 2016-12-05 10:06:45.343 32696 ERROR cinder.cmd.volume File "/usr/lib/python2.7/dist-packages/cinder/service.py", line 268, in create 2016-12-05 10:06:45.343 32696 ERROR cinder.cmd.volume service_name=service_name) 2016-12-05 10:06:45.343 32696 ERROR cinder.cmd.volume File "/usr/lib/python2.7/dist-packages/cinder/service.py", line 150, in __init__ 2016-12-05 10:06:45.343 32696 ERROR cinder.cmd.volume args, *kwargs) 2016-12-05 10:06:45.343 32696 ERROR cinder.cmd.volume File "/usr/lib/python2.7/dist-packages/cinder/volume/manager.py", line 235, in __init__ 2016-12-05 10:06:45.343 32696 ERROR cinder.cmd.volume args, *kwargs) 2016-12-05 10:06:45.343 32696 ERROR cinder.cmd.volume File "/usr/lib/python2.7/dist-packages/cinder/manager.py", line 156, in __init__ 2016-12-05 10:06:45.343 32696 ERROR cinder.cmd.volume self.scheduler_rpcapi = scheduler_rpcapi.SchedulerAPI() 2016-12-05 10:06:45.343 32696 ERROR cinder.cmd.volume File "/usr/lib/python2.7/dist-packages/cinder/rpc.py", line 188, in __init__ 2016-12-05 10:06:45.343 32696 ERROR cinder.cmd.volume serializer = base.CinderObjectSerializer(obj_version_cap) 2016-12-05 10:06:45.343 32696 ERROR cinder.cmd.volume File "/usr/lib/python2.7/dist-packages/cinder/objects/base.py", line 412, in __init__ 2016-12-05 10:06:45.343 32696 ERROR cinder.cmd.volume raise exception.CappedVersionUnknown(version=version_cap) 2016-12-05 10:06:45.343 32696 ERROR cinder.cmd.volume CappedVersionUnknown: Unrecoverable Error: Versioned Objects in DB are capped to unknown version 1.11. 2016-12-05 10:06:45.343 32696 ERROR cinder.cmd.volume 2016-12-05 10:06:45.345 32696 ERROR cinder.cmd.volume [req-58a488ad-2071-4c82-9a8e-61754158676f - - - - -] No volume service(s) started successfully, terminating. 2016-12-05 10:06:46.273 32718 WARNING oslo_reports.guru_meditation_report [-] Guru mediation now registers SIGUSR1 and SIGUSR2 by default for backward compatibility. SIGUSR1 will no longer be registered in a future release, so please use SIGUSR2 to generate reports. 2016-12-05 10:06:46.396 32718 INFO root [-] Generating grammar tables from /usr/lib/python2.7/lib2to3/Grammar.txt 2016-12-05 10:06:46.459 32718 INFO root [-] Generating grammar tables from /usr/lib/python2.7/lib2to3/PatternGrammar.txt 2016-12-05 10:06:46.505 32718 WARNING py.warnings [req-ce7e5428-0dd3-4bc2-b877-73ed003f6210 - - - - -] /usr/lib/python2.7/dist-packages/oslo_db/sqlalchemy/enginefacade.py:241: NotSupportedWarning: Configuration option(s) ['use_tpool'] not supported exception.NotSupportedWarning

2016-12-05 10:06:46.595 32718 INFO cinder.rpc [req-ce7e5428-0dd3-4bc2-b877-73ed003f6210 - - - - -] Automatically selected cinder-scheduler objects version 1.11 as minimum service version. 2016-12-05 10:06:46.596 32718 ERROR cinder.cmd.volume [req-ce7e5428-0dd3-4bc2-b877-73ed003f6210 - - - - -] Volume service ip-10-0-0-174@lvm failed to start. 2016-12-05 10:06:46.596 32718 ERROR cinder.cmd.volume Traceback (most recent call last): 2016-12-05 10:06:46.596 32718 ERROR cinder.cmd.volume File "/usr/lib/python2.7/dist-packages/cinder/cmd/volume.py", line 81, in main 2016-12-05 10:06:46.596 32718 ERROR cinder.cmd.volume binary='cinder-volume') 2016-12-05 10:06:46.596 32718 ERROR cinder.cmd.volume File "/usr/lib/python2.7/dist-packages/cinder/service.py", line 268, in create 2016-12-05 10:06:46.596 32718 ERROR cinder.cmd.volume service_name=service_name) 2016-12-05 10:06:46.596 32718 ERROR cinder.cmd.volume File "/usr/lib/python2.7/dist-packages/cinder/service.py", line 150, in __init__ 2016-12-05 10:06:46.596 32718 ERROR cinder.cmd.volume args, *kwargs) 2016-12-05 10:06:46.596 32718 ERROR cinder.cmd.volume File "/usr/lib/python2.7/dist-packages/cinder/volume/manager.py", line 235, in __init__ 2016-12-05 10:06:46.596 32718 ERROR cinder.cmd.volume args, *kwargs) 2016-12-05 10:06:46.596 32718 ERROR cinder.cmd.volume File "/usr/lib/python2.7/dist-packages/cinder/manager.py", line 156, in __init__ 2016-12-05 10:06:46.596 32718 ERROR cinder.cmd.volume self.scheduler_rpcapi = scheduler_rpcapi.SchedulerAPI() 2016-12-05 10:06:46.596 32718 ERROR cinder.cmd.volume File "/usr/lib/python2.7/dist-packages/cinder/rpc.py", line 188, in __init__ 2016-12-05 10:06:46.596 32718 ERROR cinder.cmd.volume serializer = base.CinderObjectSerializer(obj_version_cap) 2016-12-05 10:06:46.596 32718 ERROR cinder.cmd.volume File "/usr/lib/python2.7/dist-packages/cinder/objects/base.py", line 412, in __init__ 2016-12-05 10:06:46.596 32718 ERROR cinder.cmd.volume raise exception.CappedVersionUnknown(version=version_cap) 2016-12-05 10:06:46.596 32718 ERROR cinder.cmd.volume CappedVersionUnknown: Unrecoverable Error: Versioned Objects in DB are capped to unknown version 1.11. 2016-12-05 10:06:46.596 32718 ERROR cinder.cmd.volume 2016-12-05 10:06:46.597 32718 ERROR cinder.cmd.volume [req-ce7e5428-0dd3-4bc2-b877-73ed003f6210 - - - - -] No volume service(s) started successfully, terminating.

if any more info is required please let me know.

regards

Rohan

cinder server node is down

Hi ,

My cinder storage node is down. I have installed openstack newton. After installation of cinder-volume on block storage. I proceed with a restart command given below.It show's the status running for a second and then goes inactive/stopped state.

 service tgt restart
service cinder-volume restart

restart

cinder-volume logs are below

2016-12-05 10:06:45.144 32696 INFO root [-] Generating grammar tables from /usr/lib/python2.7/lib2to3/Grammar.txt
2016-12-05 10:06:45.206 32696 INFO root [-] Generating grammar tables from /usr/lib/python2.7/lib2to3/PatternGrammar.txt
2016-12-05 10:06:45.252 32696 WARNING py.warnings [req-58a488ad-2071-4c82-9a8e-61754158676f - - - - -] /usr/lib/python2.7/dist-packages/oslo_db/sqlalchemy/enginefacade.py:241: NotSupportedWarning: Configuration option(s) ['use_tpool'] not supported
  exception.NotSupportedWarning

exception.NotSupportedWarning 2016-12-05 10:06:45.343 32696 INFO cinder.rpc [req-58a488ad-2071-4c82-9a8e-61754158676f - - - - -] Automatically selected cinder-scheduler objects version 1.11 as minimum service version. 2016-12-05 10:06:45.343 32696 ERROR cinder.cmd.volume [req-58a488ad-2071-4c82-9a8e-61754158676f - - - - -] Volume service ip-10-0-0-174@lvm failed to start. 2016-12-05 10:06:45.343 32696 ERROR cinder.cmd.volume Traceback (most recent call last): 2016-12-05 10:06:45.343 32696 ERROR cinder.cmd.volume File "/usr/lib/python2.7/dist-packages/cinder/cmd/volume.py", line 81, in main 2016-12-05 10:06:45.343 32696 ERROR cinder.cmd.volume binary='cinder-volume') 2016-12-05 10:06:45.343 32696 ERROR cinder.cmd.volume File "/usr/lib/python2.7/dist-packages/cinder/service.py", line 268, in create 2016-12-05 10:06:45.343 32696 ERROR cinder.cmd.volume service_name=service_name) 2016-12-05 10:06:45.343 32696 ERROR cinder.cmd.volume File "/usr/lib/python2.7/dist-packages/cinder/service.py", line 150, in __init__ 2016-12-05 10:06:45.343 32696 ERROR cinder.cmd.volume args, *kwargs) *args, **kwargs) 2016-12-05 10:06:45.343 32696 ERROR cinder.cmd.volume File "/usr/lib/python2.7/dist-packages/cinder/volume/manager.py", line 235, in __init__ 2016-12-05 10:06:45.343 32696 ERROR cinder.cmd.volume args, *kwargs) *args, **kwargs) 2016-12-05 10:06:45.343 32696 ERROR cinder.cmd.volume File "/usr/lib/python2.7/dist-packages/cinder/manager.py", line 156, in __init__ 2016-12-05 10:06:45.343 32696 ERROR cinder.cmd.volume self.scheduler_rpcapi = scheduler_rpcapi.SchedulerAPI() 2016-12-05 10:06:45.343 32696 ERROR cinder.cmd.volume File "/usr/lib/python2.7/dist-packages/cinder/rpc.py", line 188, in __init__ 2016-12-05 10:06:45.343 32696 ERROR cinder.cmd.volume serializer = base.CinderObjectSerializer(obj_version_cap) 2016-12-05 10:06:45.343 32696 ERROR cinder.cmd.volume File "/usr/lib/python2.7/dist-packages/cinder/objects/base.py", line 412, in __init__ 2016-12-05 10:06:45.343 32696 ERROR cinder.cmd.volume raise exception.CappedVersionUnknown(version=version_cap) 2016-12-05 10:06:45.343 32696 ERROR cinder.cmd.volume CappedVersionUnknown: Unrecoverable Error: Versioned Objects in DB are capped to unknown version 1.11. 2016-12-05 10:06:45.343 32696 ERROR cinder.cmd.volume 2016-12-05 10:06:45.345 32696 ERROR cinder.cmd.volume [req-58a488ad-2071-4c82-9a8e-61754158676f - - - - -] No volume service(s) started successfully, terminating. 2016-12-05 10:06:46.273 32718 WARNING oslo_reports.guru_meditation_report [-] Guru mediation now registers SIGUSR1 and SIGUSR2 by default for backward compatibility. SIGUSR1 will no longer be registered in a future release, so please use SIGUSR2 to generate reports. 2016-12-05 10:06:46.396 32718 INFO root [-] Generating grammar tables from /usr/lib/python2.7/lib2to3/Grammar.txt 2016-12-05 10:06:46.459 32718 INFO root [-] Generating grammar tables from /usr/lib/python2.7/lib2to3/PatternGrammar.txt 2016-12-05 10:06:46.505 32718 WARNING py.warnings [req-ce7e5428-0dd3-4bc2-b877-73ed003f6210 - - - - -] /usr/lib/python2.7/dist-packages/oslo_db/sqlalchemy/enginefacade.py:241: NotSupportedWarning: Configuration option(s) ['use_tpool'] not supported exception.NotSupportedWarning

exception.NotSupportedWarning 2016-12-05 10:06:46.595 32718 INFO cinder.rpc [req-ce7e5428-0dd3-4bc2-b877-73ed003f6210 - - - - -] Automatically selected cinder-scheduler objects version 1.11 as minimum service version. 2016-12-05 10:06:46.596 32718 ERROR cinder.cmd.volume [req-ce7e5428-0dd3-4bc2-b877-73ed003f6210 - - - - -] Volume service ip-10-0-0-174@lvm failed to start. 2016-12-05 10:06:46.596 32718 ERROR cinder.cmd.volume Traceback (most recent call last): 2016-12-05 10:06:46.596 32718 ERROR cinder.cmd.volume File "/usr/lib/python2.7/dist-packages/cinder/cmd/volume.py", line 81, in main 2016-12-05 10:06:46.596 32718 ERROR cinder.cmd.volume binary='cinder-volume') 2016-12-05 10:06:46.596 32718 ERROR cinder.cmd.volume File "/usr/lib/python2.7/dist-packages/cinder/service.py", line 268, in create 2016-12-05 10:06:46.596 32718 ERROR cinder.cmd.volume service_name=service_name) 2016-12-05 10:06:46.596 32718 ERROR cinder.cmd.volume File "/usr/lib/python2.7/dist-packages/cinder/service.py", line 150, in __init__ 2016-12-05 10:06:46.596 32718 ERROR cinder.cmd.volume args, *kwargs) *args, **kwargs) 2016-12-05 10:06:46.596 32718 ERROR cinder.cmd.volume File "/usr/lib/python2.7/dist-packages/cinder/volume/manager.py", line 235, in __init__ 2016-12-05 10:06:46.596 32718 ERROR cinder.cmd.volume args, *kwargs) *args, **kwargs) 2016-12-05 10:06:46.596 32718 ERROR cinder.cmd.volume File "/usr/lib/python2.7/dist-packages/cinder/manager.py", line 156, in __init__ 2016-12-05 10:06:46.596 32718 ERROR cinder.cmd.volume self.scheduler_rpcapi = scheduler_rpcapi.SchedulerAPI() 2016-12-05 10:06:46.596 32718 ERROR cinder.cmd.volume File "/usr/lib/python2.7/dist-packages/cinder/rpc.py", line 188, in __init__ 2016-12-05 10:06:46.596 32718 ERROR cinder.cmd.volume serializer = base.CinderObjectSerializer(obj_version_cap) 2016-12-05 10:06:46.596 32718 ERROR cinder.cmd.volume File "/usr/lib/python2.7/dist-packages/cinder/objects/base.py", line 412, in __init__ 2016-12-05 10:06:46.596 32718 ERROR cinder.cmd.volume raise exception.CappedVersionUnknown(version=version_cap) 2016-12-05 10:06:46.596 32718 ERROR cinder.cmd.volume CappedVersionUnknown: Unrecoverable Error: Versioned Objects in DB are capped to unknown version 1.11. 2016-12-05 10:06:46.596 32718 ERROR cinder.cmd.volume 2016-12-05 10:06:46.597 32718 ERROR cinder.cmd.volume [req-ce7e5428-0dd3-4bc2-b877-73ed003f6210 - - - - -] No volume service(s) started successfully, terminating.

terminating.

if any more info is required please let me know.

regards

Rohan