Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Slaves in OVS bond are disabled

Hi,

I have an openstack setup installed on Cent OS. I created a Open Vswitch (OVS) bond on 2 interfaces :

Bridge "br-ex3" Controller "tcp:127.0.0.1:6633" is_connected: true fail_mode: secure Port "phy-br-ex3" Interface "phy-br-ex3" type: patch options: {peer="int-br-ex3"} Port "br-ex3" Interface "br-ex3" type: internal Port "bond0" Interface "ens1f1" Interface "ens1f0" ovs_version: "2.5.0"

But both slaves are disabled :

[root@psxsvtg81 ~]# ovs-appctl bond/show bond0 ---- bond0 ---- bond_mode: active-backup bond may use recirculation: no, Recirc-ID : -1 bond-hash-basis: 0 updelay: 0 ms downdelay: 0 ms lacp_status: configured active slave mac: 00:00:00:00:00:00(none)

slave ens1f0: disabled may_enable: false

slave ens1f1: disabled may_enable: false

Why would this happen and how do I debug this ?

Slaves in OVS bond are disabled

Hi,

I have an openstack setup installed on Cent OS. I created a Open Vswitch (OVS) bond on 2 interfaces :

 Bridge "br-ex3"
        Controller "tcp:127.0.0.1:6633"
            is_connected: true
        fail_mode: secure
        Port "phy-br-ex3"
            Interface "phy-br-ex3"
                type: patch
                options: {peer="int-br-ex3"}
        Port "br-ex3"
            Interface "br-ex3"
                type: internal
        Port "bond0"
            Interface "ens1f1"
            Interface "ens1f0"
    ovs_version: "2.5.0"

"2.5.0"

But both slaves are disabled :

[root@psxsvtg81 ~]# ovs-appctl bond/show bond0 ---- bond0 ---- bond_mode: active-backup bond may use recirculation: no, Recirc-ID : -1 bond-hash-basis: 0 updelay: 0 ms downdelay: 0 ms lacp_status: configured active slave mac: 00:00:00:00:00:00(none)

slave ens1f0: disabled may_enable: false

slave ens1f1: disabled may_enable: false

Why would this happen and how do I debug this ?

Slaves in OVS bond are disabled

Hi,

I have an openstack setup installed on Cent OS. I created a Open Vswitch (OVS) bond on 2 interfaces :

 Bridge "br-ex3"
        Controller "tcp:127.0.0.1:6633"
            is_connected: true
        fail_mode: secure
        Port "phy-br-ex3"
            Interface "phy-br-ex3"
                type: patch
                options: {peer="int-br-ex3"}
        Port "br-ex3"
            Interface "br-ex3"
                type: internal
        Port "bond0"
            Interface "ens1f1"
            Interface "ens1f0"
    ovs_version: "2.5.0"

But both slaves are disabled :

[root@psxsvtg81 ~]# ovs-appctl bond/show bond0
---- bond0 ----
bond_mode: active-backup
bond may use recirculation: no, Recirc-ID : -1
bond-hash-basis: 0
updelay: 0 ms
downdelay: 0 ms
lacp_status: configured
active slave mac: 00:00:00:00:00:00(none)

00:00:00:00:00:00(none) slave ens1f0: disabled may_enable: false

false slave ens1f1: disabled may_enable: false

false

Why would this happen and how do I debug this ?