Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

DB update failed during magnum install

I am following this guide: http://docs.openstack.org/project-install-guide/container-infrastructure-management/newton/install-ubuntu.html to install Magnum (Newton) in Ubuntu 16.04.

I have the following error when populating the magnum database:

# su -s /bin/sh -c "magnum-db-manage upgrade" magnum
    ...
      File "/usr/lib/python2.7/dist-packages/oslo_db/sqlalchemy/migration_cli/manager.py", line 47, in __init__
        raise ValueError('There must be at least one plugin active.')
    ValueError: There must be at least one plugin active.

Note: I had previously installed and removed the magnum packages. I had also manually removed the "magnum" database before re-installing the packages.