Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

how to reslove erlang dependencies? where to find the repositories for libwx_gtk3u_*

For past few days, I have been getting erlang and erlang-wx dependencies while install openstack through packstack. I can see this both for kilo and mitaka version of openstack. Where can i find the repositories for libwx_gtk3u_*?

Last week I installed mitaka, but i didn't had this issue. I believe it started from 6th Oct, Thursday 2016.

Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (centos-openstack-kilo) Requires: libwx_gtk3u_html-3.0.so.0()(64bit) Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (centos-openstack-kilo) Requires: libwx_gtk3u_xrc-3.0.so.0()(64bit) Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (centos-openstack-kilo) Requires: libwx_gtk3u_stc-3.0.so.0()(64bit) Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (centos-openstack-kilo) Requires: libwx_gtk3u_core-3.0.so.0()(64bit) Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (centos-openstack-kilo) Requires: libwx_gtk3u_aui-3.0.so.0(WXU_3.0)(64bit) Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (centos-openstack-kilo) Requires: libwx_gtk3u_html-3.0.so.0(WXU_3.0)(64bit) Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (centos-openstack-kilo) Requires: libwx_gtk3u_xrc-3.0.so.0(WXU_3.0)(64bit) Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (centos-openstack-kilo) Requires: libwx_gtk3u_gl-3.0.so.0(WXU_3.0)(64bit) Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (centos-openstack-kilo) Requires: libwx_gtk3u_adv-3.0.so.0()(64bit) Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (centos-openstack-kilo) Requires: libwx_gtk3u_core-3.0.so.0(WXU_3.0)(64bit) Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (centos-openstack-kilo) Requires: libwx_baseu-3.0.so.0()(64bit) Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (centos-openstack-kilo) Requires: libwx_baseu-3.0.so.0(WXU_3.0)(64bit) Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (centos-openstack-kilo) Requires: libwx_gtk3u_gl-3.0.so.0()(64bit) Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (centos-openstack-kilo) Requires: libwx_gtk3u_adv-3.0.so.0(WXU_3.0)(64bit) Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (centos-openstack-kilo) Requires: libwx_gtk3u_stc-3.0.so.0(WXU_3.0)(64bit) Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (centos-openstack-kilo) Requires: libwx_baseu_xml-3.0.so.0()(64bit) Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (centos-openstack-kilo) Requires: libwx_gtk3u_aui-3.0.so.0()(64bit) You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest