Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

VM GRE Poor performance


I have Openstack Juno with Neutron (GRE) running on Ubuntu 14.04. I have allocated one VM in two different compute nodes. When I run iperf between the two compute nodes I have close to 1Gbps (they are connected using 1Gbps NICs). I have tried to change MTU size to 1450 as recommended in:

I have set-up the DHCP agent to set the mtu on VMs. This is how it looks dhcp_agent.ini: interface_driver = neutron.agent.linux.interface.OVSInterfaceDriver handle_internal_only_routers = TRUE external_network_bridge = br-ex ovs_use_veth = True use_namespaces = True dmasq_config_file = /etc/neutron/dnsmasq.conf

and dnsmasq-neutron.conf: dhcp-option-force=26,1450

I have tried as well to disable gro using: ethtool -K eth0 gro off on the VM. However, the performance between VM to VM allocated in different compute nodes is so poor (close to 100Mbps). If I run multiple tcp sessions I get around 200 Mbps max (sum).

I have tried to find out where is the mistake or bottleneck but I could not find it. Can anyone give me some advices for finding out the bottleneck? or anyone has face this problem before?