Revision history [back]

click to hide/show revision 1
initial version

asked 2014-01-01 14:07:24 -0500

mili gravatar image

neutron base network problem

Dear Openstack members,

I have an issue with my neutron base network creation section on the tutorial. I'm using Havana and Ubuntu 12.04 server

My problem is when I'm creating the base network with command: neutron net-create ext-net --router:external=True --provider:network_type vlan --provider:physical_network physnet1 --provider:segmentation_id 1002 (tried 2 as well)

I'm getting: 400-{u'NeutronError': {u'message': u'Invalid input for operation: Unknown provider:physical_network physnet1.', u'type': u'InvalidInput', u'detail': u''}}

I found someone with similar issue http://www.gossamer-threads.com/lists/openstack/operators/32720 but it looks like my problem is different.

Please look below for status from my nodes:

/etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini:(network node and compute nodes)

tenant_network_type = vlan

network_vlan_ranges = physnet1:1000:2999

bridge_mappings = physnet1:br-eth1

And this is what i have on the controller node:

tenant_network_type = vlan

network_vlan_ranges = physne1:1000:2999

I dont have bridge_mappings on the controller node.

neutron agent-list +--------------------------------------+--------------------+------------+-------+----------------+ | id | agent_type | host | alive | admin_state_up | +--------------------------------------+--------------------+------------+-------+----------------+ | 2ef3dcec-f260-4e98-8b9a-198e24d88d7c | DHCP agent | network1 | :-) | True | | 33d10ca1-ce11-409f-9edf-e975f51433cd | L3 agent | network1 | :-) | True | | 3d4dc89c-4f26-4d3b-8f52-bfb4e388bf8e | Open vSwitch agent | compute3 | :-) | True | | 5ca1fc0b-b900-49aa-9e56-f208e175eb8a | Open vSwitch agent | compute1 | :-) | True | | a1ea053b-ce61-4f4a-8802-bff4b0aa4147 | Open vSwitch agent | controller | :-) | True | | c9187828-c201-49a3-b543-fc77deacfed4 | Open vSwitch agent | compute2 | :-) | True | | f9e8ccd0-2eb5-46b1-ad72-a9d81e31c79c | Open vSwitch agent | network1 | :-) | True | +--------------------------------------+--------------------+------------+-------+----------------+

Is it possible that there is conflict between nova-network and neutron as i installed nova-net first then netron.

I just realized very strange network interfaces on one of
Please let me know if there is any other information needed

Your help is really appreciated.

neutron base network problem

Dear Openstack members,

I have an issue with my neutron base network creation section on the tutorial. I'm using Havana and Ubuntu 12.04 server

My problem is when I'm creating the base network with command: neutron net-create ext-net --router:external=True --provider:network_type vlan --provider:physical_network physnet1 --provider:segmentation_id 1002 (tried 2 as well)

I'm getting: 400-{u'NeutronError': {u'message': u'Invalid input for operation: Unknown provider:physical_network physnet1.', u'type': u'InvalidInput', u'detail': u''}}

I found someone with similar issue http://www.gossamer-threads.com/lists/openstack/operators/32720 but it looks like my problem is different.

Please look below for status from my nodes:

/etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini:(network node and compute nodes)

tenant_network_type = vlan

network_vlan_ranges = physnet1:1000:2999

bridge_mappings = physnet1:br-eth1

And this is what i have on the controller node:

tenant_network_type = vlan

network_vlan_ranges = physne1:1000:2999

I dont have bridge_mappings on the controller node.

neutron agent-list +--------------------------------------+--------------------+------------+-------+----------------+ | id | agent_type | host | alive | admin_state_up | +--------------------------------------+--------------------+------------+-------+----------------+ | 2ef3dcec-f260-4e98-8b9a-198e24d88d7c | DHCP agent | network1 | :-) | True | | 33d10ca1-ce11-409f-9edf-e975f51433cd | L3 agent | network1 | :-) | True | | 3d4dc89c-4f26-4d3b-8f52-bfb4e388bf8e | Open vSwitch agent | compute3 | :-) | True | | 5ca1fc0b-b900-49aa-9e56-f208e175eb8a | Open vSwitch agent | compute1 | :-) | True | | a1ea053b-ce61-4f4a-8802-bff4b0aa4147 | Open vSwitch agent | controller | :-) | True | | c9187828-c201-49a3-b543-fc77deacfed4 | Open vSwitch agent | compute2 | :-) | True | | f9e8ccd0-2eb5-46b1-ad72-a9d81e31c79c | Open vSwitch agent | network1 | :-) | True | +--------------------------------------+--------------------+------------+-------+----------------+

Is it possible that there is conflict between nova-network and neutron as i installed nova-net first then netron.

I just realized very strange network interfaces on one of
Please let me know if there is any other information needed

Your help is really appreciated.

neutron base network problem

Dear Openstack members,

I have an issue with my neutron base network creation section on the tutorial. I'm using Havana and Ubuntu 12.04 server

My problem is when I'm creating the base network with command:

 neutron net-create ext-net --router:external=True  --provider:network_type vlan --provider:physical_network  physnet1 --provider:segmentation_id 1002  (tried 2 as well)

well)

I'm getting: getting:

 400-{u'NeutronError': {u'message': u'Invalid input for operation: Unknown provider:physical_network physnet1.', u'type': u'InvalidInput', u'detail': u''}}

u''}}

I found someone with similar issue http://www.gossamer-threads.com/lists/openstack/operators/32720 but it looks like my problem is different.

Please look below for status from my nodes:

/etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini:(network node and compute nodes)

nodes) tenant_network_type = vlan

vlan network_vlan_ranges = physnet1:1000:2999

bridge_mappings = physnet1:br-eth1

physnet1:br-eth1

And this is what i have on the controller node:

tenant_network_type = vlan

vlan network_vlan_ranges = physne1:1000:2999

physne1:1000:2999

I dont have bridge_mappings on the controller node.

neutron agent-list
+--------------------------------------+--------------------+------------+-------+----------------+
| id                                   | agent_type         | host       | alive | admin_state_up |
+--------------------------------------+--------------------+------------+-------+----------------+
| 2ef3dcec-f260-4e98-8b9a-198e24d88d7c | DHCP agent         | network1   | :-)   | True           |
| 33d10ca1-ce11-409f-9edf-e975f51433cd | L3 agent           | network1   | :-)   | True           |
| 3d4dc89c-4f26-4d3b-8f52-bfb4e388bf8e | Open vSwitch agent | compute3   | :-)   | True           |
| 5ca1fc0b-b900-49aa-9e56-f208e175eb8a | Open vSwitch agent | compute1   | :-)   | True           |
| a1ea053b-ce61-4f4a-8802-bff4b0aa4147 | Open vSwitch agent | controller | :-)   | True           |
| c9187828-c201-49a3-b543-fc77deacfed4 | Open vSwitch agent | compute2   | :-)   | True           |
| f9e8ccd0-2eb5-46b1-ad72-a9d81e31c79c | Open vSwitch agent | network1   | :-)   | True           |
+--------------------------------------+--------------------+------------+-------+----------------+

+--------------------------------------+--------------------+------------+-------+----------------+

Is it possible that there is conflict between nova-network and neutron as i installed nova-net first then netron.

Please let me know if there is any other information needed

Your help is really appreciated. netron?