Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

asked 2013-12-30 12:39:45 -0500

mili gravatar image

Confused about physnet1

Hi,

I have setup neutron fully according to ubuntu installation guide. My environment is HAVANA on ubuntu 12.0.4. I ave dedicated network node, dedicated controll node and dedicated compute node. I'm useing VLANS

The last step of configuring neutron is setting up the base network with the command: neutron net-create ext-net --router:external=True --provider:network_type vlan --provider:physical_network physnet1 --provider:segmentation_id 1002

I get he error : 400-{u'NeutronError': {u'message': u'Invalid input for operation: Unknown provider:physical_network physnet1.', u'type': u'InvalidInput', u'detail': u''}}

I was searching a bit to figure out my problem but no luck. I'm now thinking that instead of physnet1 i should use my data interface on my neutron node ie eth1.

Please advice as I really dont know what is happening here.

Cheers

Confused about physnet1

Hi,

I have setup neutron fully according to ubuntu installation guide. My environment is HAVANA on ubuntu 12.0.4. I ave dedicated network node, dedicated controll node and dedicated compute node. I'm useing VLANS

The last step of configuring neutron is setting up the base network with the command: neutron net-create ext-net --router:external=True --provider:network_type vlan --provider:physical_network physnet1 --provider:segmentation_id 1002

I get he error : 400-{u'NeutronError': {u'message': u'Invalid input for operation: Unknown provider:physical_network physnet1.', u'type': u'InvalidInput', u'detail': u''}}

I was searching a bit to figure out my problem but no luck. I'm now thinking that instead of physnet1 i should use my data interface on my neutron node ie eth1.

Please advice as I really dont know what is happening here.

Cheers

UPDATE:

Hi SamYaple,

Thanks for the quick response, Below is my configuration on the network node #/etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini:

network_vlan_ranges = physnet1:1000:2999 bridge_mappings = physnet1:br-eth1

And this is what i have on the controller node: network_vlan_ranges = physne1:1000:2999 I dont have bridge_mappings on the controller node.

I have not changed anything and dont know what to do, Here is the server log from the controller: 2013-12-30 19:23:24.099 1390 ERROR neutron.api.v2.resource [-] create failed 2013-12-30 19:23:24.099 1390 TRACE neutron.api.v2.resource Traceback (most recent call last): 2013-12-30 19:23:24.099 1390 TRACE neutron.api.v2.resource File "/usr/lib/python2.7/dist-packages/neutron/api/v2/resource.py", line 84, in resource 2013-12-30 19:23:24.099 1390 TRACE neutron.api.v2.resource result = method(request=request, *args) 2013-12-30 19:23:24.099 1390 TRACE neutron.api.v2.resource File "/usr/lib/python2.7/dist-packages/neutron/api/v2/base.py", line 405, in create 2013-12-30 19:23:24.099 1390 TRACE neutron.api.v2.resource obj = obj_creator(request.context, *kwargs) 2013-12-30 19:23:24.099 1390 TRACE neutron.api.v2.resource File "/usr/lib/python2.7/dist-packages/neutron/plugins/openvswitch/ovs_neutron_plugin.py", line 472, in create_network 2013-12-30 19:23:24.099 1390 TRACE neutron.api.v2.resource network['network']) 2013-12-30 19:23:24.099 1390 TRACE neutron.api.v2.resource File "/usr/lib/python2.7/dist-packages/neutron/plugins/openvswitch/ovs_neutron_plugin.py", line 460, in _process_provider_create 2013-12-30 19:23:24.099 1390 TRACE neutron.api.v2.resource raise q_exc.InvalidInput(error_message=msg) 2013-12-30 19:23:24.099 1390 TRACE neutron.api.v2.resource InvalidInput: Invalid input for operation: Unknown provider:physical_network physnet0. 2013-12-30 19:23:24.099 1390 TRACE neutron.api.v2.resource

and also open-vswich log on the controller: ---> looks like im in trouble Command: ['ip', '-o', 'link', 'show', 'br-int'] Exit code: 1 Stdout: '' Stderr: 'Device "br-int" does not exist.\n'

I only have one nic on the controller node and it is for management. I can add another if I have to

I just turned verborse and debugging on, will I see it on the console or the logfile?