Revision history [back]

click to hide/show revision 1
initial version

asked 2016-08-25 06:30:35 -0500

agti gravatar image

ERROR (AttributeError): 'Namespace' object has no attribute 'os_project_domain_id'

Hi, I'm using Devstack on a Ubuntu 16.04 Virtualbox VM. The installation process worked fine, I could access Horizon and create VMs. The strange thing is that I am unable to use CLI commands, getting this weird error:

ubuntu@ubuntu-VM:~/devstack/devstack/accrc/admin$ pwd
/home/ubuntu/devstack/devstack/accrc/admin

ubuntu@ubuntu-VM:~/devstack/devstack/accrc/admin$ cat admin 
# OpenStack USER ID = 8a8ec35c04b541f8bc9b16bda1692d05
export OS_USERNAME="admin"
# OpenStack project ID = ef38d04b89e046048d5016f0b1fd7f7c
export OS_PROJECT_NAME="admin"
export OS_AUTH_URL="http://10.0.2.15/identity_v2_admin"
export OS_CACERT=""
export NOVA_CERT="/home/ubuntu/devstack/devstack/accrc/cacert.pem"
export OS_AUTH_TYPE=v2password
export OS_PASSWORD="secret"
export OS_USER_DOMAIN_ID=default
unset OS_USER_DOMAIN_NAME
export OS_PROJECT_DOMAIN_ID=default
unset OS_PROJECT_DOMAIN_NAME

ubuntu@ubuntu-VM:~/devstack/devstack/accrc/admin$ source admin 

ubuntu@ubuntu-VM:~/devstack/devstack/accrc/admin$ nova list
ERROR (AttributeError): 'Namespace' object has no attribute 'os_project_domain_id'

I tried commenting the unset variable statements on adminrc file but nothing changed. Any hint on what is wrong is appreciated.