Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

live-migration unable to execute QEMU command 'migrate'

i have set up my CentOS7+RDO Liberty environment and everything works fine. I would like to get non-shared block storage working; so running:

nova --insecure live-migration --block-migrate  9cc0eaa5-f14b-4ed1-86d3-cfd2453958ce neb0007.slac.stanford.edu

results in... nothing! but looking through the nova-compute logs i see:

Live Migration failure: internal error: unable to execute QEMU command 'migrate': this feature or command is not currently supported

my/etc/nova/nova.conf contains:

[libvirt]
virt_type=kvm
block_migration_flag=VIR_MIGRATE_UNDEFINE_SOURCE, VIR_MIGRATE_PEER2PEER, VIR_MIGRATE_NON_SHARED_INC, VIR_MIGRATE_LIVE

my /etc/libvirt/libvirtd.conf

listen_tcp=1
tcp_port="16509"
listen_addr="0.0.0.0"
listen_tls=0
auth_tcp="none"

my /etc/sysconfig/libvirtd:

LIBVIRTD_ARGS="--listen"

my rpms:

# rpm -qa | grep libvirt
libvirt-client-1.2.17-13.el7_2.5.x86_64
libvirt-daemon-driver-nwfilter-1.2.17-13.el7_2.5.x86_64
libvirt-python-1.2.17-2.el7.x86_64
libvirt-daemon-1.2.17-13.el7_2.5.x86_64
libvirt-daemon-driver-qemu-1.2.17-13.el7_2.5.x86_64
libvirt-daemon-driver-nodedev-1.2.17-13.el7_2.5.x86_64
libvirt-daemon-driver-interface-1.2.17-13.el7_2.5.x86_64
libvirt-daemon-driver-storage-1.2.17-13.el7_2.5.x86_64
libvirt-daemon-kvm-1.2.17-13.el7_2.5.x86_64
libvirt-daemon-driver-network-1.2.17-13.el7_2.5.x86_64
libvirt-daemon-driver-secret-1.2.17-13.el7_2.5.x86_64

any pointers?

live-migration unable to execute QEMU command 'migrate'

i have set up my CentOS7+RDO Liberty environment and everything works fine. I would like to get non-shared block storage working; so running:

nova --insecure live-migration --block-migrate  9cc0eaa5-f14b-4ed1-86d3-cfd2453958ce neb0007.slac.stanford.edu
neb0007

results in... nothing! but looking through the nova-compute logs i see:

Live Migration failure: internal error: unable to execute QEMU command 'migrate': this feature or command is not currently supported

my/etc/nova/nova.conf contains:

[libvirt]
virt_type=kvm
block_migration_flag=VIR_MIGRATE_UNDEFINE_SOURCE, VIR_MIGRATE_PEER2PEER, VIR_MIGRATE_NON_SHARED_INC, VIR_MIGRATE_LIVE

my /etc/libvirt/libvirtd.conf

listen_tcp=1
tcp_port="16509"
listen_addr="0.0.0.0"
listen_tls=0
auth_tcp="none"

my /etc/sysconfig/libvirtd:

LIBVIRTD_ARGS="--listen"

my rpms:

# rpm -qa | grep libvirt
libvirt-client-1.2.17-13.el7_2.5.x86_64
libvirt-daemon-driver-nwfilter-1.2.17-13.el7_2.5.x86_64
libvirt-python-1.2.17-2.el7.x86_64
libvirt-daemon-1.2.17-13.el7_2.5.x86_64
libvirt-daemon-driver-qemu-1.2.17-13.el7_2.5.x86_64
libvirt-daemon-driver-nodedev-1.2.17-13.el7_2.5.x86_64
libvirt-daemon-driver-interface-1.2.17-13.el7_2.5.x86_64
libvirt-daemon-driver-storage-1.2.17-13.el7_2.5.x86_64
libvirt-daemon-kvm-1.2.17-13.el7_2.5.x86_64
libvirt-daemon-driver-network-1.2.17-13.el7_2.5.x86_64
libvirt-daemon-driver-secret-1.2.17-13.el7_2.5.x86_64

any pointers?