Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

No network communication on a 3 node Havana setup

Hello,

I've been struggling with neutron for the past few days and I can't get instances to receive addresses using DHCP or reach anything outside the same physical host. My setup consists of three nodes, all running Ubuntu Server 12.04 with Havana installed from Cloudarchive (per http://docs.openstack.org/trunk/install-guide/install/apt/content/):

  • Network node: Connected to the WAN (eth0) and LAN (eth1, 10.130.10.201) networks running neutron dhcp-agent, l3-agent, metadata-agent and plugin-openvswitch-agent.
  • Management node: Connected only to the LAN network (eth0, 10.130.10.202) and running neutron (server, plugin-openvswitch-agent), postgresql, rabbitmq, keystone, glance, nova (api, conductor, cert, vnc proxy and scheduler) and horizon.
  • Compute node: Connected only to the LAN network (eth0, 10.130.10.11) and running nova-compute and neutron-plugin-openvswitch-agent

Everything aside from networking works as expected so far, and two instances running on the same compute node are able to reach each other if I log on using the console and assign an address manually.

On the neutron server log (management node) I can see the following message whenever I launch an instance:

2013-12-23 12:52:13.151 862 WARNING neutron.db.agentschedulers_db [-] Fail scheduling network {'status': u'ACTIVE', 'subnets': [u'be9659ca-1ee7-4c35-b36c-d082a581495f'], 'name': u'Alpha', 'provider:physical_network': None, 'admin_state_up': True, 'tenant_id': u'04968d54151d4bb29d477f754e099728', 'provider:network_type': u'local', 'router:external': False, 'shared': False, 'id': u'031dcf57-c259-41f2-be2a-1541f88d3238', 'provider:segmentation_id': None}

General info:

  • neutron net list: http://pastebin.com/J9Y7w9iS
  • neutron subnets: http://pastebin.com/pqFyVQPy
  • neutron routers: http://pastebin.com/A8mf7gUz

Configuration files and logs follow:

Network node:

  • /etc/neutron/neutron.conf: http://pastebin.com/3VY2GcPA
  • /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini: http://pastebin.com/0CpVyiZs
  • /etc/neutron/l3_agent.ini: http://pastebin.com/kLCUd6HW
  • /etc/neutron/api-paste.ini: http://pastebin.com/QU7MwsB8
  • /etc/neutron/dhcp_agent.ini: http://pastebin.com/ReHsfYUE
  • /etc/neutron/dhcp_agent.ini: metadata_agent.ini http://pastebin.com/tX6bhxkD
  • ovs-vsctl show: http://pastebin.com/HDtCrnFH
  • ovs-ofctl show br-tun: http://pastebin.com/87SShbjB

Compute node:

  • /etc/neutron/neutron.conf: http://pastebin.com/4GNZyyjc
  • /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini: http://pastebin.com/yA9XiJGA
  • ovs-vsctl show: http://pastebin.com/YG0SpmLQ
  • ovs-ofctl show br-tun: http://pastebin.com/1YNAj0qH

Management Node:

  • Server Log: http://pastebin.com/AdKCfUQh
  • /etc/neutron/neutron.conf: http://pastebin.com/5DSddTsu
  • /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini: http://pastebin.com/G11HbZER

No network communication on a 3 node Havana setup

Hello,

I've been struggling with neutron for the past few days and I can't get instances to receive addresses using DHCP or reach anything outside the same physical host. My setup consists of three nodes, all running Ubuntu Server 12.04 with Havana installed from Cloudarchive (per http://docs.openstack.org/trunk/install-guide/install/apt/content/):

  • Network node: Connected to the WAN (eth0) and LAN (eth1, 10.130.10.201) networks running neutron dhcp-agent, l3-agent, metadata-agent and plugin-openvswitch-agent.
  • Management node: Connected only to the LAN network (eth0, 10.130.10.202) and running neutron (server, plugin-openvswitch-agent), postgresql, rabbitmq, keystone, glance, nova (api, conductor, cert, vnc proxy and scheduler) and horizon.
  • Compute node: Connected only to the LAN network (eth0, 10.130.10.11) and running nova-compute and neutron-plugin-openvswitch-agent

Everything aside from networking works as expected so far, and two instances running on the same compute node are able to reach each other if I log on using the console and assign an address manually.

On the neutron server log (management node) I can see the following message whenever I launch an instance:

2013-12-23 12:52:13.151 862 WARNING neutron.db.agentschedulers_db [-] Fail scheduling network {'status': u'ACTIVE', 'subnets': [u'be9659ca-1ee7-4c35-b36c-d082a581495f'], 'name': u'Alpha', 'provider:physical_network': None, 'admin_state_up': True, 'tenant_id': u'04968d54151d4bb29d477f754e099728', 'provider:network_type': u'local', 'router:external': False, 'shared': False, 'id': u'031dcf57-c259-41f2-be2a-1541f88d3238', 'provider:segmentation_id': None}

General info:

  • neutron net list: http://pastebin.com/J9Y7w9iS
  • neutron subnets: http://pastebin.com/pqFyVQPy
  • neutron routers: http://pastebin.com/A8mf7gUz

Configuration files and logs follow:

Network node:

  • /etc/neutron/neutron.conf: http://pastebin.com/3VY2GcPA
  • /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini: http://pastebin.com/0CpVyiZs
  • /etc/neutron/l3_agent.ini: http://pastebin.com/kLCUd6HW
  • /etc/neutron/api-paste.ini: http://pastebin.com/QU7MwsB8
  • /etc/neutron/dhcp_agent.ini: http://pastebin.com/ReHsfYUE
  • /etc/neutron/dhcp_agent.ini: metadata_agent.ini http://pastebin.com/tX6bhxkD
  • ovs-vsctl show: http://pastebin.com/HDtCrnFH
  • ovs-ofctl show br-tun: http://pastebin.com/87SShbjB

Compute node:

  • /etc/nova/nova.conf: http://pastebin.com/eR4czuEM
  • /etc/neutron/neutron.conf: http://pastebin.com/4GNZyyjc
  • /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini: http://pastebin.com/yA9XiJGA
  • ovs-vsctl show: http://pastebin.com/YG0SpmLQ
  • ovs-ofctl show br-tun: http://pastebin.com/1YNAj0qH

Management Node:

  • Server Log: http://pastebin.com/AdKCfUQh
  • /etc/nova/nova.conf: http://pastebin.com/3kDt53zY
  • /etc/neutron/neutron.conf: http://pastebin.com/5DSddTsu
  • /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini: http://pastebin.com/G11HbZER
click to hide/show revision 3
No.3 Revision

No network communication on a 3 node Havana setup

Hello,

I've been struggling with neutron for the past few days and I can't get instances to receive addresses using DHCP or reach anything outside the same physical host. My setup consists of three nodes, all running Ubuntu Server 12.04 with Havana installed from Cloudarchive (per http://docs.openstack.org/trunk/install-guide/install/apt/content/):

  • Network node: Connected to the WAN (eth0) and LAN (eth1, 10.130.10.201) networks running neutron dhcp-agent, l3-agent, metadata-agent and plugin-openvswitch-agent.
  • Management node: Connected only to the LAN network (eth0, 10.130.10.202) and running neutron (server, plugin-openvswitch-agent), postgresql, rabbitmq, keystone, glance, nova (api, conductor, cert, vnc proxy and scheduler) and horizon.
  • Compute node: Connected only to the LAN network (eth0, 10.130.10.11) and running nova-compute and neutron-plugin-openvswitch-agent

Everything aside from networking works as expected so far, and two instances running on the same compute node are able to reach each other if I log on using the console and assign an address manually.

On the neutron server log (management node) I can see the following message whenever I launch an instance:

2013-12-23 12:52:13.151 862 WARNING neutron.db.agentschedulers_db [-] Fail scheduling network {'status': u'ACTIVE', 'subnets': [u'be9659ca-1ee7-4c35-b36c-d082a581495f'], 'name': u'Alpha', 'provider:physical_network': None, 'admin_state_up': True, 'tenant_id': u'04968d54151d4bb29d477f754e099728', 'provider:network_type': u'local', 'router:external': False, 'shared': False, 'id': u'031dcf57-c259-41f2-be2a-1541f88d3238', 'provider:segmentation_id': None}

General info:

  • neutron net list: http://pastebin.com/J9Y7w9iS
  • neutron subnets: http://pastebin.com/pqFyVQPy
  • neutron routers: http://pastebin.com/A8mf7gUz

Configuration files and logs follow:

Network node:

  • /etc/neutron/neutron.conf: http://pastebin.com/3VY2GcPA
  • /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini: http://pastebin.com/0CpVyiZs
  • /etc/neutron/l3_agent.ini: http://pastebin.com/kLCUd6HW
  • /etc/neutron/api-paste.ini: http://pastebin.com/QU7MwsB8
  • /etc/neutron/dhcp_agent.ini: http://pastebin.com/ReHsfYUE
  • /etc/neutron/dhcp_agent.ini: metadata_agent.ini http://pastebin.com/tX6bhxkD
  • ovs-vsctl show: http://pastebin.com/HDtCrnFH
  • ovs-ofctl show br-tun: http://pastebin.com/87SShbjB

Compute node:

  • /etc/nova/nova.conf: http://pastebin.com/eR4czuEM
  • /etc/neutron/neutron.conf: http://pastebin.com/4GNZyyjc
  • /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini: http://pastebin.com/yA9XiJGA
  • ovs-vsctl show: http://pastebin.com/YG0SpmLQ
  • ovs-ofctl show br-tun: http://pastebin.com/1YNAj0qH

Management Node:

  • Server Log: http://pastebin.com/AdKCfUQh
  • /etc/nova/nova.conf: http://pastebin.com/3kDt53zY
  • /etc/neutron/neutron.conf: http://pastebin.com/5DSddTsu
  • /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini: http://pastebin.com/G11HbZER

No network communication on a 3 node Havana setup

Hello,

I've been struggling with neutron for the past few days and I can't get instances to receive addresses using DHCP or reach anything outside the same physical host. My setup consists of three nodes, all running Ubuntu Server 12.04 with Havana installed from Cloudarchive (per http://docs.openstack.org/trunk/install-guide/install/apt/content/):

  • Network node: Connected to the WAN (eth0) and LAN (eth1, 10.130.10.201) networks running neutron dhcp-agent, l3-agent, metadata-agent and plugin-openvswitch-agent.
  • Management node: Connected only to the LAN network (eth0, 10.130.10.202) and running neutron (server, plugin-openvswitch-agent), postgresql, rabbitmq, keystone, glance, nova (api, conductor, cert, vnc proxy and scheduler) and horizon.
  • Compute node: Connected only to the LAN network (eth0, 10.130.10.11) and running nova-compute and neutron-plugin-openvswitch-agent

Everything aside from networking works as expected so far, and two instances running on the same compute node are able to reach each other if I log on using the console and assign an address manually.

On the neutron server log (management node) I can see the following message whenever I launch an instance:

2013-12-23 12:52:13.151 862 WARNING neutron.db.agentschedulers_db [-] Fail scheduling network {'status': u'ACTIVE', 'subnets': [u'be9659ca-1ee7-4c35-b36c-d082a581495f'], 'name': u'Alpha', 'provider:physical_network': None, 'admin_state_up': True, 'tenant_id': u'04968d54151d4bb29d477f754e099728', 'provider:network_type': u'local', 'router:external': False, 'shared': False, 'id': u'031dcf57-c259-41f2-be2a-1541f88d3238', 'provider:segmentation_id': None}

General info:

  • neutron net list: http://pastebin.com/J9Y7w9iS
  • neutron subnets: http://pastebin.com/pqFyVQPy
  • neutron routers: http://pastebin.com/A8mf7gUz

Configuration files and logs follow:

Network node:

  • /etc/neutron/neutron.conf: http://pastebin.com/3VY2GcPA
  • /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini: http://pastebin.com/0CpVyiZs
  • /etc/neutron/l3_agent.ini: http://pastebin.com/kLCUd6HW
  • /etc/neutron/api-paste.ini: http://pastebin.com/QU7MwsB8
  • /etc/neutron/dhcp_agent.ini: http://pastebin.com/ReHsfYUE
  • /etc/neutron/dhcp_agent.ini: metadata_agent.ini http://pastebin.com/tX6bhxkD
  • ovs-vsctl show: http://pastebin.com/HDtCrnFH
  • ovs-ofctl show br-tun: http://pastebin.com/87SShbjB

Compute node:

  • /etc/nova/nova.conf: http://pastebin.com/eR4czuEM
  • /etc/neutron/neutron.conf: http://pastebin.com/4GNZyyjc
  • /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini: http://pastebin.com/yA9XiJGA
  • ovs-vsctl show: http://pastebin.com/YG0SpmLQ
  • ovs-ofctl show br-tun: http://pastebin.com/1YNAj0qH

Management Node:

  • Server Log: http://pastebin.com/AdKCfUQh
  • /etc/nova/nova.conf: http://pastebin.com/3kDt53zY
  • /etc/neutron/neutron.conf: http://pastebin.com/5DSddTsu
  • /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini: http://pastebin.com/G11HbZER

tcpdump output when launching a new instance

  • Compute node: http://pastebin.com/A8Gkst4W
  • Network node: http://pastebin.com/XTAKA7fA (no data at all)

No network communication on a 3 node Havana setup

Hello,

I've been struggling with neutron for the past few days and I can't get instances to receive addresses using DHCP or reach anything outside the same physical host. My setup consists of three nodes, all running Ubuntu Server 12.04 with Havana installed from Cloudarchive (per http://docs.openstack.org/trunk/install-guide/install/apt/content/):

  • Network node: Connected to the WAN (eth0) and LAN (eth1, 10.130.10.201) networks running neutron dhcp-agent, l3-agent, metadata-agent and plugin-openvswitch-agent.
  • Management node: Connected only to the LAN network (eth0, 10.130.10.202) and running neutron (server, plugin-openvswitch-agent), postgresql, rabbitmq, keystone, glance, nova (api, conductor, cert, vnc proxy and scheduler) and horizon.
  • Compute node: Connected only to the LAN network (eth0, 10.130.10.11) and running nova-compute and neutron-plugin-openvswitch-agent

Everything aside from networking works as expected so far, and two instances running on the same compute node are able to reach each other if I log on using the console and assign an address manually.

On the neutron server log (management node) I can see the following message whenever I launch an instance:

2013-12-23 12:52:13.151 862 WARNING neutron.db.agentschedulers_db [-] Fail scheduling network {'status': u'ACTIVE', 'subnets': [u'be9659ca-1ee7-4c35-b36c-d082a581495f'], 'name': u'Alpha', 'provider:physical_network': None, 'admin_state_up': True, 'tenant_id': u'04968d54151d4bb29d477f754e099728', 'provider:network_type': u'local', 'router:external': False, 'shared': False, 'id': u'031dcf57-c259-41f2-be2a-1541f88d3238', 'provider:segmentation_id': None}

General info:

  • neutron net list: http://pastebin.com/J9Y7w9iS
  • neutron subnets: http://pastebin.com/pqFyVQPy
  • neutron routers: http://pastebin.com/A8mf7gUz

Configuration files and logs follow:

Network node:

  • /etc/neutron/neutron.conf: http://pastebin.com/3VY2GcPA
  • /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini: http://pastebin.com/0CpVyiZs
  • /etc/neutron/l3_agent.ini: http://pastebin.com/kLCUd6HW
  • /etc/neutron/api-paste.ini: http://pastebin.com/QU7MwsB8
  • /etc/neutron/dhcp_agent.ini: http://pastebin.com/ReHsfYUE
  • /etc/neutron/dhcp_agent.ini: metadata_agent.ini http://pastebin.com/tX6bhxkD
  • ovs-vsctl show: http://pastebin.com/HDtCrnFH
  • ovs-ofctl show br-tun: http://pastebin.com/87SShbjB

Compute node:

  • /etc/nova/nova.conf: http://pastebin.com/eR4czuEM
  • /etc/neutron/neutron.conf: http://pastebin.com/4GNZyyjc
  • /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini: http://pastebin.com/yA9XiJGA
  • ovs-vsctl show: http://pastebin.com/YG0SpmLQ
  • ovs-ofctl show br-tun: http://pastebin.com/1YNAj0qH

Management Node:

  • Server Log: http://pastebin.com/AdKCfUQh
  • /etc/nova/nova.conf: http://pastebin.com/3kDt53zY
  • /etc/neutron/neutron.conf: http://pastebin.com/5DSddTsu
  • /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini: http://pastebin.com/G11HbZER

tcpdump Tcpdump output when launching a new instanceinstance:

  • Compute node: http://pastebin.com/A8Gkst4W
  • Network node: http://pastebin.com/XTAKA7fA (no data at all)

No network communication on a 3 node Havana setup

Hello,

I've been struggling with neutron for the past few days and I can't get instances to receive addresses using DHCP or reach anything outside the same physical host. My setup consists of three nodes, all running Ubuntu Server 12.04 with Havana installed from Cloudarchive (per http://docs.openstack.org/trunk/install-guide/install/apt/content/):

  • Network node: Connected to the WAN (eth0) and LAN (eth1, 10.130.10.201) networks running neutron dhcp-agent, l3-agent, metadata-agent and plugin-openvswitch-agent.
  • Management node: Connected only to the LAN network (eth0, 10.130.10.202) and running neutron (server, plugin-openvswitch-agent), postgresql, rabbitmq, keystone, glance, nova (api, conductor, cert, vnc proxy and scheduler) and horizon.
  • Compute node: Connected only to the LAN network (eth0, 10.130.10.11) and running nova-compute and neutron-plugin-openvswitch-agent

Everything aside from networking works as expected so far, and two instances running on the same compute node are able to reach each other if I log on using the console and assign an address manually.

On the neutron server log (management node) I can see the following message whenever I launch an instance:

2013-12-23 12:52:13.151 862 WARNING neutron.db.agentschedulers_db [-] Fail scheduling network {'status': u'ACTIVE', 'subnets': [u'be9659ca-1ee7-4c35-b36c-d082a581495f'], 'name': u'Alpha', 'provider:physical_network': None, 'admin_state_up': True, 'tenant_id': u'04968d54151d4bb29d477f754e099728', 'provider:network_type': u'local', 'router:external': False, 'shared': False, 'id': u'031dcf57-c259-41f2-be2a-1541f88d3238', 'provider:segmentation_id': None}

General info:

  • neutron net list: http://pastebin.com/J9Y7w9iS
  • neutron subnets: http://pastebin.com/pqFyVQPy
  • neutron routers: http://pastebin.com/A8mf7gUz

Configuration files and logs follow:

Network node:

  • /etc/neutron/neutron.conf: http://pastebin.com/3VY2GcPA
  • /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini: http://pastebin.com/0CpVyiZs
  • /etc/neutron/l3_agent.ini: http://pastebin.com/kLCUd6HW
  • /etc/neutron/api-paste.ini: http://pastebin.com/QU7MwsB8
  • /etc/neutron/dhcp_agent.ini: http://pastebin.com/ReHsfYUE
  • /etc/neutron/dhcp_agent.ini: metadata_agent.ini http://pastebin.com/tX6bhxkD
  • ovs-vsctl show: http://pastebin.com/HDtCrnFH
  • ovs-ofctl show br-tun: http://pastebin.com/87SShbjB

Compute node:

  • /etc/nova/nova.conf: http://pastebin.com/eR4czuEM
  • /etc/neutron/neutron.conf: http://pastebin.com/4GNZyyjc
  • /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini: http://pastebin.com/yA9XiJGA
  • ovs-vsctl show: http://pastebin.com/YG0SpmLQ
  • ovs-ofctl show br-tun: http://pastebin.com/1YNAj0qH

Management Node:

  • Server Log: http://pastebin.com/AdKCfUQh
  • /etc/nova/nova.conf: http://pastebin.com/3kDt53zY
  • /etc/neutron/neutron.conf: http://pastebin.com/5DSddTsu
  • /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini: http://pastebin.com/G11HbZER

Tcpdump output when launching a new instance:

  • Compute node: http://pastebin.com/A8Gkst4W
  • Network node: http://pastebin.com/XTAKA7fA (no data at all)

No network communication on a 3 node Havana setup

Hello,

I've been struggling with neutron for the past few days and I can't get instances to receive addresses using DHCP or reach anything outside the same physical host. My setup consists of three nodes, all running Ubuntu Server 12.04 with Havana installed from Cloudarchive (per http://docs.openstack.org/trunk/install-guide/install/apt/content/):

  • Network node: Connected to the WAN (eth0) and LAN (eth1, 10.130.10.201) networks running neutron dhcp-agent, l3-agent, metadata-agent and plugin-openvswitch-agent.
  • Management node: Connected only to the LAN network (eth0, 10.130.10.202) and running neutron (server, plugin-openvswitch-agent), postgresql, rabbitmq, keystone, glance, nova (api, conductor, cert, vnc proxy and scheduler) and horizon.
  • Compute node: Connected only to the LAN network (eth0, 10.130.10.11) and running nova-compute and neutron-plugin-openvswitch-agent

Everything aside from networking works as expected so far, and two instances running on the same compute node are able to reach each other if I log on using the console and assign an address manually.

On the neutron server log (management node) I can see the following message whenever I launch an instance:

2013-12-23 12:52:13.151 862 WARNING neutron.db.agentschedulers_db [-] Fail scheduling network {'status': u'ACTIVE', 'subnets': [u'be9659ca-1ee7-4c35-b36c-d082a581495f'], 'name': u'Alpha', 'provider:physical_network': None, 'admin_state_up': True, 'tenant_id': u'04968d54151d4bb29d477f754e099728', 'provider:network_type': u'local', 'router:external': False, 'shared': False, 'id': u'031dcf57-c259-41f2-be2a-1541f88d3238', 'provider:segmentation_id': None}

General info:

  • neutron net list: http://pastebin.com/J9Y7w9iS
  • neutron subnets: http://pastebin.com/pqFyVQPy
  • neutron routers: http://pastebin.com/A8mf7gUz

Configuration files and logs follow:

Network node:

  • /etc/neutron/neutron.conf: http://pastebin.com/3VY2GcPA
  • /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini: http://pastebin.com/0CpVyiZs
  • /etc/neutron/l3_agent.ini: http://pastebin.com/kLCUd6HW
  • /etc/neutron/api-paste.ini: http://pastebin.com/QU7MwsB8
  • /etc/neutron/dhcp_agent.ini: http://pastebin.com/ReHsfYUE
  • /etc/neutron/dhcp_agent.ini: metadata_agent.ini http://pastebin.com/tX6bhxkD
  • ovs-vsctl show: http://pastebin.com/HDtCrnFH
  • ovs-ofctl show br-tun: http://pastebin.com/87SShbjB

Compute node:

  • /etc/nova/nova.conf: http://pastebin.com/eR4czuEM
  • /etc/neutron/neutron.conf: http://pastebin.com/4GNZyyjc
  • /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini: http://pastebin.com/yA9XiJGA
  • ovs-vsctl show: http://pastebin.com/YG0SpmLQ
  • ovs-ofctl show br-tun: http://pastebin.com/1YNAj0qH

Management Node:

  • Server Log: http://pastebin.com/AdKCfUQh
  • /etc/nova/nova.conf: http://pastebin.com/3kDt53zY
  • /etc/neutron/neutron.conf: http://pastebin.com/5DSddTsu
  • /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini: http://pastebin.com/G11HbZER

Tcpdump output when launching a new instance:

  • Compute node: http://pastebin.com/A8Gkst4W
  • Network node: http://pastebin.com/XTAKA7fA

No network communication on a 3 node Havana setup

I've been struggling with neutron for the past few days and I can't get instances to receive addresses using DHCP or reach anything outside the same physical host. My setup consists of three nodes, all running Ubuntu Server 12.04 with Havana installed from Cloudarchive (per http://docs.openstack.org/trunk/install-guide/install/apt/content/):

  • Network node: Connected to the WAN (eth0) and LAN (eth1, 10.130.10.201) networks running neutron dhcp-agent, l3-agent, metadata-agent and plugin-openvswitch-agent.
  • Management node: Connected only to the LAN network (eth0, 10.130.10.202) and running neutron (server, plugin-openvswitch-agent), postgresql, rabbitmq, keystone, glance, nova (api, conductor, cert, vnc proxy and scheduler) and horizon.
  • Compute node: Connected only to the LAN network (eth0, 10.130.10.11) and running nova-compute and neutron-plugin-openvswitch-agent

Everything aside from networking works as expected so far, and two instances running on the same compute node are able to reach each other if I log on using the console and assign an address manually.

On the neutron server log (management node) I can see the following message whenever I launch an instance:

2013-12-23 12:52:13.151 862 WARNING neutron.db.agentschedulers_db [-] Fail scheduling network {'status': u'ACTIVE', 'subnets': [u'be9659ca-1ee7-4c35-b36c-d082a581495f'], 'name': u'Alpha', 'provider:physical_network': None, 'admin_state_up': True, 'tenant_id': u'04968d54151d4bb29d477f754e099728', 'provider:network_type': u'local', 'router:external': False, 'shared': False, 'id': u'031dcf57-c259-41f2-be2a-1541f88d3238', 'provider:segmentation_id': None}

General info:

  • neutron net list: http://pastebin.com/J9Y7w9iS
  • neutron subnets: http://pastebin.com/pqFyVQPy
  • neutron routers: http://pastebin.com/A8mf7gUz

Configuration files and logs follow:

Network node:

  • /etc/neutron/neutron.conf: http://pastebin.com/3VY2GcPA
  • /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini: http://pastebin.com/0CpVyiZs
  • /etc/neutron/l3_agent.ini: http://pastebin.com/kLCUd6HW
  • /etc/neutron/api-paste.ini: http://pastebin.com/QU7MwsB8
  • /etc/neutron/dhcp_agent.ini: http://pastebin.com/ReHsfYUE
  • /etc/neutron/dhcp_agent.ini: metadata_agent.ini http://pastebin.com/tX6bhxkD
  • ovs-vsctl show: http://pastebin.com/HDtCrnFH
  • ovs-ofctl show br-tun: http://pastebin.com/87SShbjB

Compute node:

  • /etc/nova/nova.conf: http://pastebin.com/eR4czuEM
  • /etc/neutron/neutron.conf: http://pastebin.com/4GNZyyjc
  • /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini: http://pastebin.com/yA9XiJGA
  • ovs-vsctl show: http://pastebin.com/YG0SpmLQ
  • ovs-ofctl show br-tun: http://pastebin.com/1YNAj0qH

Management Node:

  • Server Log: http://pastebin.com/AdKCfUQh
  • /etc/nova/nova.conf: http://pastebin.com/3kDt53zY
  • /etc/neutron/neutron.conf: http://pastebin.com/5DSddTsu
  • /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini: http://pastebin.com/G11HbZER

Tcpdump output when launching a new instance:

  • Compute node: http://pastebin.com/A8Gkst4W
  • Network node: http://pastebin.com/XTAKA7fA