Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Trove - Timeout for service changing to active. No usage create-event sent.

Dear all,

I've got 12 servers with openstack (icehouse). I've installed trove and configured it with the mysql image downloaded from:http://tarballs.openstack.org/trove/images/ubuntu

However, when I try to fire up an instance I get this:

TRACE trove.common.utils Traceback (most recent call last):
TRACE trove.common.utils   File "/usr/lib/python2.7/dist-packages/trove/common/utils.py", line 213, in _inner
TRACE trove.common.utils     self.f(*self.args, **self.kw)
TRACE trove.common.utils   File "/usr/lib/python2.7/dist-packages/trove/common/utils.py", line 254, in poll_and_check
TRACE trove.common.utils     raise exception.PollTimeOut
TRACE trove.common.utils PollTimeOut: Polling request timed out.
TRACE trove.common.utils
ERROR trove.taskmanager.models [req-......] Timeout for service changing to active. No usage create-event sent.
DEBUG trove.taskmanager.models [req-......] end create_instance for id: 7f4c7f74-ae91-4fc4-8ccc-897db38edc51 create_instance /usr/lib/python2.7/dist-packages/trove/taskmanager/models.py:272

The images shows up in nova but it gets stuck on build status. I had to remove it manually from the database in order to stop it.

Could you give me a hint if it's a configuration problem or an image problem (i have to create my own, with tools)? I just wanted to test the service before creating my customized images.

Thanks a lot for any help, Kind Regards, Riccardo.