Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

nova-compute service disabled on seeting auth_tcp="none" in libvirtd.conf

Heyy, I was configuring live migration in Openstack Kilo on ubuntu 14.04 server. On setting auth_tcp="none" in /etc/libvirt/libvirtd.conf, the nova-compute service gets disabled.

Reason: AUTO: Connection to libvirt lost: 0

State : Down

Following are the configuration files :

/etc/libvirt/libvirtd.conf:

listen_tls = 0    
listen_tcp = 1    
auth_tcp="none"

/etc/default/libvirt-bin:

# Defaults for libvirt-bin initscript (/etc/init.d/libvirt-bin)
# This is a POSIX shell fragment

# Start libvirtd to handle qemu/kvm:
start_libvirtd="yes"

# options passed to libvirtd, add "-l" to listen on tcp
#libvirtd_opts="-d"
libvirtd_opts="-d -l"

# pass in location of kerberos keytab
#export KRB5_KTNAME=/etc/libvirt/libvirt.keytab

/etc/nova/nova.conf :

[DEFAULT]
dhcpbridge_flagfile=/etc/nova/nova.conf
dhcpbridge=/usr/bin/nova-dhcpbridge
logdir=/var/log/nova
state_path=/var/lib/nova
lock_path=/var/lock/nova
force_dhcp_release=True
libvirt_use_virtio_for_bridges=True
verbose=True
ec2_private_dns_show_ip=True
api_paste_config=/etc/nova/api-paste.ini
enabled_apis=ec2,osapi_compute,metadata

rpc_backend = rabbit
auth_strategy = keystone
my_ip = 10.0.30.32
vnc_enabled = True
vncserver_listen = 0.0.0.0
vncserver_proxyclient_address = 10.0.30.32
novncproxy_base_url = http://controller:6080/vnc_auto.html

network_api_class = nova.network.neutronv2.api.API
security_group_api = neutron
linuxnet_interface_driver = nova.network.linux_net.LinuxOVSInterfaceDriver
firewall_driver = nova.virt.firewall.NoopFirewallDriver
live_migration_retry_count = 30
#libvirt_type = kvm
#compute_driver = libvirt.LibvirtDriver
#allow_resize_to_same_host=True

debug = True

[keystone_authtoken]
auth_uri = http://controller:5000
auth_url = http://controller:35357
auth_plugin = password
project_domain_id = default
user_domain_id = default
project_name = service
username = nova
password = novauser
[oslo_messaging_rabbit]

rabbit_host = controller
rabbit_userid = openstack
rabbit_password = stackrabbit

[glance]
host = controller

[oslo_concurrency]
lock_path = /var/lib/nova/tmp

[neutron]
url = http://controller:9696
auth_strategy = keystone
admin_auth_url = http://controller:35357/v2.0
admin_tenant_name = service
admin_username = neutron
admin_password = neutronuser

[libvirt]
#added for live migration
live_migration_bandwidth = 0
live_migration_uri = qemu+tcp://%s/system
live_migration_flag = VIR_MIGRATE_UNDEFINE_SOURCE,VIR_MIGRATE_PEER2PEER, VIR_MIGRATE_LIVE, VIR_MIGRATE_TUNNELLED
block_migration_flag=VIR_MIGRATE_UNDEFINE_SOURCE,VIR_MIGRATE_PEER2PEER,VIR_MIGRATE_NON_SHARED_INC, VIR_MIGRATE_LIVE
virt_type = kvm

If there any information required please let me know. I am stuck with this issue for quite sometime now. Any help will be appreciated.

Thanks.

nova-compute service disabled on seeting auth_tcp="none" in libvirtd.conf

Heyy, I was configuring live migration in Openstack Kilo on ubuntu 14.04 server. I intend to perform live migration with block migrate since I cannot use a shared storage.

On setting auth_tcp="none" in /etc/libvirt/libvirtd.conf, the nova-compute service gets disabled.

Reason: AUTO: Connection to libvirt lost: 0

State : Down

Following are the configuration files :

/etc/libvirt/libvirtd.conf:

listen_tls = 0    
listen_tcp = 1    
auth_tcp="none"

/etc/default/libvirt-bin:

# Defaults for libvirt-bin initscript (/etc/init.d/libvirt-bin)
# This is a POSIX shell fragment

# Start libvirtd to handle qemu/kvm:
start_libvirtd="yes"

# options passed to libvirtd, add "-l" to listen on tcp
#libvirtd_opts="-d"
libvirtd_opts="-d -l"

# pass in location of kerberos keytab
#export KRB5_KTNAME=/etc/libvirt/libvirt.keytab

/etc/nova/nova.conf :

[DEFAULT]
dhcpbridge_flagfile=/etc/nova/nova.conf
dhcpbridge=/usr/bin/nova-dhcpbridge
logdir=/var/log/nova
state_path=/var/lib/nova
lock_path=/var/lock/nova
force_dhcp_release=True
libvirt_use_virtio_for_bridges=True
verbose=True
ec2_private_dns_show_ip=True
api_paste_config=/etc/nova/api-paste.ini
enabled_apis=ec2,osapi_compute,metadata

rpc_backend = rabbit
auth_strategy = keystone
my_ip = 10.0.30.32
vnc_enabled = True
vncserver_listen = 0.0.0.0
vncserver_proxyclient_address = 10.0.30.32
novncproxy_base_url = http://controller:6080/vnc_auto.html

network_api_class = nova.network.neutronv2.api.API
security_group_api = neutron
linuxnet_interface_driver = nova.network.linux_net.LinuxOVSInterfaceDriver
firewall_driver = nova.virt.firewall.NoopFirewallDriver
live_migration_retry_count = 30
#libvirt_type = kvm
#compute_driver = libvirt.LibvirtDriver
#allow_resize_to_same_host=True

debug = True

[keystone_authtoken]
auth_uri = http://controller:5000
auth_url = http://controller:35357
auth_plugin = password
project_domain_id = default
user_domain_id = default
project_name = service
username = nova
password = novauser
[oslo_messaging_rabbit]

rabbit_host = controller
rabbit_userid = openstack
rabbit_password = stackrabbit

[glance]
host = controller

[oslo_concurrency]
lock_path = /var/lib/nova/tmp

[neutron]
url = http://controller:9696
auth_strategy = keystone
admin_auth_url = http://controller:35357/v2.0
admin_tenant_name = service
admin_username = neutron
admin_password = neutronuser

[libvirt]
#added for live migration
live_migration_bandwidth = 0
live_migration_uri = qemu+tcp://%s/system
live_migration_flag = VIR_MIGRATE_UNDEFINE_SOURCE,VIR_MIGRATE_PEER2PEER, VIR_MIGRATE_LIVE, VIR_MIGRATE_TUNNELLED
block_migration_flag=VIR_MIGRATE_UNDEFINE_SOURCE,VIR_MIGRATE_PEER2PEER,VIR_MIGRATE_NON_SHARED_INC, VIR_MIGRATE_LIVE
virt_type = kvm

If there any information required please let me know. I am stuck with this issue for quite sometime now. Any help will be appreciated.

Thanks.

nova-compute service disabled on seeting auth_tcp="none" in libvirtd.conf

Heyy, I was configuring live migration in Openstack Kilo on ubuntu 14.04 server. I intend to perform live migration with block migrate since I cannot use a shared storage.

On setting auth_tcp="none" in /etc/libvirt/libvirtd.conf, the nova-compute service gets disabled.

Reason: AUTO: Connection to libvirt lost: 0

State : Down

Following are the configuration files :

/etc/libvirt/libvirtd.conf:

listen_tls = 0    
listen_tcp = 1    
auth_tcp="none"

/etc/default/libvirt-bin:

# Defaults for libvirt-bin initscript (/etc/init.d/libvirt-bin)
# This is a POSIX shell fragment

# Start libvirtd to handle qemu/kvm:
start_libvirtd="yes"

# options passed to libvirtd, add "-l" to listen on tcp
#libvirtd_opts="-d"
libvirtd_opts="-d -l"

# pass in location of kerberos keytab
#export KRB5_KTNAME=/etc/libvirt/libvirt.keytab

/etc/nova/nova.conf :

[DEFAULT]
dhcpbridge_flagfile=/etc/nova/nova.conf
dhcpbridge=/usr/bin/nova-dhcpbridge
logdir=/var/log/nova
state_path=/var/lib/nova
lock_path=/var/lock/nova
force_dhcp_release=True
libvirt_use_virtio_for_bridges=True
verbose=True
ec2_private_dns_show_ip=True
api_paste_config=/etc/nova/api-paste.ini
enabled_apis=ec2,osapi_compute,metadata

rpc_backend = rabbit
auth_strategy = keystone
my_ip = 10.0.30.32
vnc_enabled = True
vncserver_listen = 0.0.0.0
vncserver_proxyclient_address = 10.0.30.32
novncproxy_base_url = http://controller:6080/vnc_auto.html

network_api_class = nova.network.neutronv2.api.API
security_group_api = neutron
linuxnet_interface_driver = nova.network.linux_net.LinuxOVSInterfaceDriver
firewall_driver = nova.virt.firewall.NoopFirewallDriver
live_migration_retry_count = 30
#libvirt_type = kvm
#compute_driver = libvirt.LibvirtDriver
#allow_resize_to_same_host=True

debug = True

[keystone_authtoken]
auth_uri = http://controller:5000
auth_url = http://controller:35357
auth_plugin = password
project_domain_id = default
user_domain_id = default
project_name = service
username = nova
password = novauser
[oslo_messaging_rabbit]

rabbit_host = controller
rabbit_userid = openstack
rabbit_password = stackrabbit

[glance]
host = controller

[oslo_concurrency]
lock_path = /var/lib/nova/tmp

[neutron]
url = http://controller:9696
auth_strategy = keystone
admin_auth_url = http://controller:35357/v2.0
admin_tenant_name = service
admin_username = neutron
admin_password = neutronuser

[libvirt]
#added for live migration
live_migration_bandwidth = 0
live_migration_uri = qemu+tcp://%s/system
live_migration_flag = VIR_MIGRATE_UNDEFINE_SOURCE,VIR_MIGRATE_PEER2PEER, VIR_MIGRATE_LIVE, VIR_MIGRATE_TUNNELLED
block_migration_flag=VIR_MIGRATE_UNDEFINE_SOURCE,VIR_MIGRATE_PEER2PEER,VIR_MIGRATE_NON_SHARED_INC, VIR_MIGRATE_LIVE
virt_type = kvm

If there any information required please let me know. I am stuck with this issue for quite sometime now. Any help will be appreciated.

Thanks.