Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Cant mount into HDFS in OpenStack

I tested a Single node HDFS setup in ubuntu 14.04 instance in my OpenStack cluster. Every thing is working fine regarding the HDFS cluster.

jps  

15829 NameNode

16137 SecondaryNameNode

21238 Jps

15953 DataNode

hadoop fs -df

Filesystem                     Size   Used     Available  Use%

hdfs://myhdfs:54310  528311836672  24576  500850139136    0%

Then I tried to mount the file system to another node in my cluster by following the link http://www.cloudera.com/documentation/archive/cdh/4-x/4-7-1/CDH4-Installation-Guide/cdh4ig_topic_28.html

When I tried to mount the file system to /mnt/hdfs like below

hadoop-fuse-dfs dfs://myhdfs:54310 /mnt/hdfs/ -d

it waits for long time and gives the error

unique: 2, opcode: GETATTR (3), nodeid: 1, insize: 56, pid: 11800
getattr /    
16/05/04 16:25:00 INFO ipc.Client: Retrying connect to server: myhdfs/10.141.141.20:54310. Already tried 0 time(s); maxRetries=45

I added ip of myhdfs in /etc/hosts also...

I checked log files of hadoop and every thing is fine..

Does networking between the OpenStack Instances creates any problem?? If so how to troubleshoot it?? because same setup in my local virtualbox environment is working fine.. If anyone have idea about this it will be really helpful..