Revision history [back]

click to hide/show revision 1
initial version

External network for new Mitaka install?

I have completed an install of OpenStack using the Guide For Ubuntu.

The guide did not cover network creation, just neutron service setup.

I am able to create a private network that instances get assigned an IP from and instances can ping each other over that.

I am not able to understand how to set up a public network and a router to use that.

My physical external network is 10.102.24.0/24 with a gateway of 10.102.24.0.1 and em2 on both controller and compute1 are physically connected to this network per the guide with the interface configured but no IP assigned.

I have a range in that network set aside for dhcp use within this OpenStack build of 10.102.24.120 through 130. I also have 10.102.24.211 and 10.102.24.212 available.

I have tried making a new network of 10.102.24.0/24 with the gateway of 10.102.24.1. I created the range of 120-130. I then created a router and assigned 10.102.24.211 to it. When I try to assign a gateway to the router there are no external networks available.

What are my next steps to create a correctly configured external network in OpenStack?

External network for new Mitaka install?

I have completed an install of OpenStack using the Guide For Ubuntu.

The guide did not cover network creation, just neutron service setup.

I am able to create a private network that instances get assigned an IP from and instances can ping each other over that.

I am not able to understand how to set up a public network and a virtual router to use that.

My physical external network is 10.102.24.0/24 with a gateway of 10.102.24.0.1 and em2 on both controller and compute1 are physically connected to this network per the guide with the interface configured but no IP assigned.

I have a range in that network set aside for dhcp use within this OpenStack build of 10.102.24.120 through 130. I also have 10.102.24.211 and 10.102.24.212 available.

I have tried making a new network of 10.102.24.0/24 with the gateway of 10.102.24.1. I created the range of 120-130. I then created a router and assigned 10.102.24.211 to it. When I try to assign a gateway to the router there are no external networks available.

What are my next steps to create a correctly configured external network in OpenStack?