Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Running delorean fails: Git won't fetch sources

Up to about one week ago I could run delorean [1] just fine. But since a couple of days, downloading the sources fails with

[IN]: 
dlrn --config-file projects.ini --order

[OUT:]
INFO:dlrn:Params: Namespace(build_env=None, config_file='projects.ini', dev=False, head_only=False, info_repo=None, local=False, log_commands=False, order=True, package_name=None, recheck=False, run=None, status=False, stop=False, use_public=False)
INFO:dlrn:Getting http://review.rdoproject.org/r/p/puppet/puppet-aodh-distgit.git to ./data/puppet-aodh_distro
Traceback (most recent call last):
  File "/usr/bin/dlrn", line 10, in <module>
    sys.exit(main())
  File "/root/delorean/DLRN/dlrn/shell.py", line 213, in main
    options.local, options.dev, package)
  File "/root/delorean/DLRN/dlrn/shell.py", line 550, in getinfo
    distro, distro_dir, distro_branch, local=local)
  File "/root/delorean/DLRN/dlrn/shell.py", line 494, in refreshrepo
    sh.git.clone(url, path)
  File "/usr/lib/python2.7/site-packages/sh.py", line 1021, in __call__
    return RunningCommand(cmd, call_args, stdin, stdout, stderr)
  File "/usr/lib/python2.7/site-packages/sh.py", line 486, in __init__
    self.wait()
  File "/usr/lib/python2.7/site-packages/sh.py", line 500, in wait
    self.handle_command_exit_code(exit_code)
  File "/usr/lib/python2.7/site-packages/sh.py", line 516, in handle_command_exit_code
    raise exc(self.ran, self.process.stdout, self.process.stderr)
sh.ErrorReturnCode_128: 

  RAN: '/usr/bin/git clone http://review.rdoproject.org/r/p/puppet/puppet-aodh-distgit.git ./data/puppet-aodh_distro'

  STDOUT:
Cloning into './data/puppet-aodh_distro'...


  STDERR:
fatal: unable to access 'http://review.rdoproject.org/r/p/puppet/puppet-aodh-distgit.git/': Encountered end of file

puppet-aodh is just the first item in the list of sources that get cloned/synchronized, the others (around ~200) also don't work. I have not made any functional changes to the project.

Running the faulty command by hand nets the exact same result:

[IN]:
git clone http://review.rdoproject.org/r/p/puppet/puppet-aodh.git

[OUT]:
Cloning into 'puppet-aodh'...
fatal: unable to access 'http://review.rdoproject.org/r/p/puppet/puppet-aodh.git/': Encountered end of file

The url format is dictated by the rdoinfo package [2] that gets downloaded since no info_repo is supplied, and is identical to the url given in (for example) the pupped-aodh repository [3]. Note, that the alternatively offered ssh-based git link does download the source correctly:

[IN]:
git clone ssh://<username>@review.rdoproject.org:29418/puppet/puppet-aodh.git

[OUT]:
Cloning into 'puppet-aodh'...
remote: Counting objects: 507, done
remote: Finding sources: 100% (507/507)
remote: Total 507 (delta 295), reused 507 (delta 295)
Receiving objects: 100% (507/507), 91.21 KiB | 0 bytes/s, done.
Resolving deltas: 100% (295/295), done.
Checking connectivity... done.

While I could hack around the problem using this approach, I would prefer not to.

After trying to fix the problem by hand for a while, I wiped the VM I ran delorean in and rebuild it from scratch. Sure enough, the error persisted. This struck me as really strange -- there obviously is no format error in the url, and I am fairly certain that the setup where delorean ran successfully was recreated through the VM-rebuild.

There were no recent, i.e. <7 day, changes in the project, so I am clueless as to what could be the reason for this behaviour. Any help on the cause of the problem would be greatly appreciated.


[1] https://github.com/openstack-packages/DLRN

[2] https://github.com/redhat-openstack/rdoinfo

[3a] https://review.rdoproject.org/r/gitweb?p=puppet/puppet-aodh.git;a=summary

[3b] https://review.rdoproject.org/r/#/admin/projects/puppet/puppet-aodh