Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Network unreachable on Fedora VM

Hello,

I am new to OpenStack and I have problem that my Fedora VM instance doesn't get IP address. I have VirtualBox All-in-one Packstack installation on CentOS7. I don't see any Errors in logs, neither Nova, neither Neutron. I'm using ovs networking.

Correct error from Fedora instance is: Calling 'http://169.254.169.254/2009-04-04/meta-data/instance-id' failed [116/120s]: request error [('Connection aborted.', OSError(101, 'Network is unreachable'))]

With nova list I see following:

+--------------------------------------+------------+--------+------------+-------------+--------------------+ | ID | Name | Status | Task State | Power State | Networks | +--------------------------------------+------------+--------+------------+-------------+--------------------+ | 0f9d37ac-6c16-4ee3-9623-654bcd1235ab | TestFedora | ACTIVE | - | Running | public=10.20.0.107 | +--------------------------------------+------------+--------+------------+-------------+--------------------+

Which would lead me to believe that my instance has IP assigned, but while Fedora instance is booting I see error that network is no reachable.

Network listing

+--------------------------------------+---------+---------------------------------------------------+ | id | name | subnets | +--------------------------------------+---------+---------------------------------------------------+ | 6a98ab75-7b18-458a-b992-e627cc15b48b | public | e66599db-a8fe-40e9-a185-62460955179d 10.20.0.0/24 | | 32683122-bd69-4adc-b58e-ef1bbc33eb7e | private | 2809b588-b78e-49c9-b1e3-2b8c77007ad0 10.0.30.0/24 | +--------------------------------------+---------+---------------------------------------------------+

I even went and on CentOS7 (where packstack all-in-one is installed) I disabled IPTABLES.

Please can somebody help me with further troubleshooting.

Thank you, Nenchy

Network unreachable on Fedora VM

Hello,

I am new to OpenStack and I have problem that my Fedora VM instance doesn't get IP address. I have VirtualBox All-in-one Packstack installation on CentOS7. I don't see any Errors in logs, neither Nova, neither Neutron. I'm using ovs networking.

Correct error from Fedora instance is: is:

Calling 'http://169.254.169.254/2009-04-04/meta-data/instance-id' failed [116/120s]: request error [('Connection aborted.', OSError(101, 'Network is unreachable'))]

unreachable'))]

With nova list list I see following:

+--------------------------------------+------------+--------+------------+-------------+--------------------+
| ID                                   | Name       | Status | Task State | Power State | Networks           |
+--------------------------------------+------------+--------+------------+-------------+--------------------+
| 0f9d37ac-6c16-4ee3-9623-654bcd1235ab | TestFedora | ACTIVE | -          | Running     | public=10.20.0.107 |
+--------------------------------------+------------+--------+------------+-------------+--------------------+

+--------------------------------------+------------+--------+------------+-------------+--------------------+

Which would lead me to believe that my instance has IP assigned, but while Fedora instance is booting I see error that network is no reachable.

Network listing

+--------------------------------------+---------+---------------------------------------------------+
| id                                   | name    | subnets                                           |
+--------------------------------------+---------+---------------------------------------------------+
| 6a98ab75-7b18-458a-b992-e627cc15b48b | public  | e66599db-a8fe-40e9-a185-62460955179d 10.20.0.0/24 |
| 32683122-bd69-4adc-b58e-ef1bbc33eb7e | private | 2809b588-b78e-49c9-b1e3-2b8c77007ad0 10.0.30.0/24 |
+--------------------------------------+---------+---------------------------------------------------+

+--------------------------------------+---------+---------------------------------------------------+

I even went and on CentOS7 (where packstack all-in-one is installed) I disabled IPTABLES.

Please can somebody help me with further troubleshooting.

Thank you, Nenchy