Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

devstack multinode problem

hello! i want use openstack with devstack multinode,

  1. i use two hosts : 10.3.21.201 with localrc :**/

    HOST_IP=10.3.21.201 FLAT_INTERFACE=eth0 FIXED_RANGE=10.3.20.0/23 FLOATING_RANGE=192.168.42.128/25 MULTI_HOST=1 LOGFILE=/opt/stack/logs/stack.sh.log ADMIN_PASSWORD=test DATABASE_PASSWORD=test RABBIT_PASSWORD=test SERVICE_PASSWORD=test

  2. and 10.3.20.166 with localrc HOST_IP=10.3.21.166 FLAT_INTERFACE=eth0 FIXED_RANGE=10.3.20.0/23 FLOATING_RANGE=192.168.42.128/25 MULTI_HOST=1 LOGFILE=/opt/stack/logs/stack.sh.log ADMIN_PASSWORD=test DATABASE_PASSWORD=test RABBIT_PASSWORD=test SERVICE_PASSWORD=test DATABASE_TYPE=mysql SERVICE_HOST=10.3.21.201 MYSQL_HOST=$SERVICE_HOST RABBIT_HOST=$SERVICE_HOST GLANCE_HOSTPORT=$SERVICE_HOST:9292 ENABLED_SERVICES=n-cpu,n-net,n-api-meta,c-vol NOVA_VNC_ENABLED=True NOVNCPROXY_URL="http://$SERVICE_HOST:6080/vnc_auto.html" VNCSERVER_LISTEN=$HOST_IP VNCSERVER_PROXYCLIENT_ADDRESS=$VNCSERVER_LISTEN

the problem when i use nova hypervisor-list i hav just the service host (10.3.20.201) thanks

devstack multinode problem

hello! i want use openstack with devstack multinode,

  1. i I use two hosts : 10.3.21.201 with localrc :**/with localrc

    HOST_IP=10.3.21.201 
    FLAT_INTERFACE=eth0 
    FIXED_RANGE=10.3.20.0/23
    FLOATING_RANGE=192.168.42.128/25 
    MULTI_HOST=1
    LOGFILE=/opt/stack/logs/stack.sh.log
    ADMIN_PASSWORD=test
    DATABASE_PASSWORD=test 
    RABBIT_PASSWORD=test
    SERVICE_PASSWORD=test

  2. SERVICE_PASSWORD=test
  3. and 10.3.20.166 with localrc localrc

    HOST_IP=10.3.21.166 
    FLAT_INTERFACE=eth0 
    FIXED_RANGE=10.3.20.0/23 
    FLOATING_RANGE=192.168.42.128/25 
    MULTI_HOST=1
    LOGFILE=/opt/stack/logs/stack.sh.log
    ADMIN_PASSWORD=test
    DATABASE_PASSWORD=test 
    RABBIT_PASSWORD=test
    SERVICE_PASSWORD=test
    DATABASE_TYPE=mysql 
    SERVICE_HOST=10.3.21.201 
    MYSQL_HOST=$SERVICE_HOST 
    RABBIT_HOST=$SERVICE_HOST 
    GLANCE_HOSTPORT=$SERVICE_HOST:9292 
    ENABLED_SERVICES=n-cpu,n-net,n-api-meta,c-vol
    NOVA_VNC_ENABLED=True
    NOVNCPROXY_URL="http://$SERVICE_HOST:6080/vnc_auto.html"
    VNCSERVER_LISTEN=$HOST_IP
    VNCSERVER_PROXYCLIENT_ADDRESS=$VNCSERVER_LISTEN
VNCSERVER_PROXYCLIENT_ADDRESS=$VNCSERVER_LISTEN

the problem when i use nova hypervisor-list i hav just the service host (10.3.20.201) thanks

devstack multinode problem

hello! i want use openstack with devstack multinode,

I use two hosts : 10.3.21.201 with localrclocalrc HOST_IP=10.3.21.201 SERVICE_HOST=10.3.21.201 MYSQL_HOST=10.3.21.201 RABBIT_HOST=10.3.21.201 GLANCE_HOSTPORT=10.3.21.201:9292 ADMIN_PASSWORD=test DATABASE_PASSWORD=test RABBIT_PASSWORD=test SERVICE_PASSWORD=test

HOST_IP=10.3.21.201 
FLAT_INTERFACE=eth0 
FIXED_RANGE=10.3.20.0/23
FLOATING_RANGE=192.168.42.128/25 
MULTI_HOST=1
LOGFILE=/opt/stack/logs/stack.sh.log
ADMIN_PASSWORD=test
DATABASE_PASSWORD=test 
RABBIT_PASSWORD=test
SERVICE_PASSWORD=test

Do not use Nova-Network

and 10.3.20.166 with localrcdisable_service n-net

HOST_IP=10.3.21.166 

Enable Neutron

FLAT_INTERFACE=eth0 FIXED_RANGE=10.3.20.0/23

ENABLED_SERVICES+=,q-svc,q-dhcp,q-meta,q-agt,q-l3

FLOATING_RANGE=192.168.42.128/25 MULTI_HOST=1 LOGFILE=/opt/stack/logs/stack.sh.log

Neutron options

Q_USE_SECGROUP=True FLOATING_RANGE="10.3.20.0/23" FIXED_RANGE="10.0.0.0/24" Q_FLOATING_ALLOCATION_POOL=start=10.3.21.0,end=10.3.21.20 PUBLIC_NETWORK_GATEWAY="10.3.20.1"

HOST_IP=10.3.21.201 SERVICE_HOST=10.3.21.201 MYSQL_HOST=10.3.21.201 RABBIT_HOST=10.3.21.201 GLANCE_HOSTPORT=10.3.21.201:9292 ADMIN_PASSWORD=test DATABASE_PASSWORD=test DATABASE_PASSWORD=test RABBIT_PASSWORD=test SERVICE_PASSWORD=test

RABBIT_PASSWORD=test SERVICE_PASSWORD=test DATABASE_TYPE=mysql SERVICE_HOST=10.3.21.201

Do not use Nova-Network

MYSQL_HOST=$SERVICE_HOST RABBIT_HOST=$SERVICE_HOST

disable_service n-net

GLANCE_HOSTPORT=$SERVICE_HOST:9292 ENABLED_SERVICES=n-cpu,n-net,n-api-meta,c-vol NOVA_VNC_ENABLED=True NOVNCPROXY_URL="http://$SERVICE_HOST:6080/vnc_auto.html" VNCSERVER_LISTEN=$HOST_IP VNCSERVER_PROXYCLIENT_ADDRESS=$VNCSERVER_LISTEN

Enable Neutron

ENABLED_SERVICES+=,q-svc,q-dhcp,q-meta,q-agt,q-l3

Neutron options

Q_USE_SECGROUP=True FLOATING_RANGE="10.3.20.0/23" FIXED_RANGE="10.0.0.0/24" Q_FLOATING_ALLOCATION_POOL=start=10.3.21.0,end=10.3.21.20 PUBLIC_NETWORK_GATEWAY="10.3.20.1"

the problem when i use nova hypervisor-list "nova hypervisor-list" i hav see just the service name of host (10.3.20.201) with ip 10.3.21.201 thanks