Ask Your Question

Revision history [back]

Aborting wait for keystone to start

Hi,

I installed a fresh Openstack Havana and I make saome changes on keystone.conf to configure LDAP and SSL. Now, when I execute service openstack-keystone start prompt show me this message (after a long time):

# service openstack-keystone start
Starting keystone:                                         [  OK  ]

Aborting wait for keystone to start

I don't know what is the reason for this fail. However, If I execute keystone-all --debug the server starts, but I only can make requests via CURL, the keystone client can't communicate with the server.

Someone knows what is the problem? Any clue?

Regards.

Aborting wait for keystone to start

Hi,

I installed a fresh Openstack Havana and I make saome changes on keystone.conf to configure LDAP and SSL. Now, when I execute service openstack-keystone start prompt show me this message (after a long time):

# service openstack-keystone start
Starting keystone:                                         [  OK  ]

Aborting wait for keystone to start

I don't know what is the reason for this fail. However, If I execute keystone-all --debug the server starts, but I only can make requests via CURL, the keystone client can't communicate with the server.

Someone knows what is the problem? Any clue?

UPDATE:

Ok, I don't know how but I step forward a bit. Now, when I start openstack-keystone the keystone.log is wrote. But, if I execute keystone user-list it raises this message:

Authorization Failed: Unable to establish connection to https://128.142.153.64:35357/v3/tokens

And the log file is not updated with any information.

Regards.