Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

can't reach external network VMWare

I was working through the Documentation of Liberty RDO.

My System contains a Controller Node with Network (VMWare Machine) and a Nova Node which is a Physical one. Everything works fine except that i cannot ping the Router from External and Vice Versa.

The Network is using Linuxbridge, which causes the problem.

I'm Using CentOS 7, and had to downgrade the IPRoute as mentioned in another post, as the Router would not add a secondary Interface.

After some analysis, i can see, that on the Bridge, which is connecting the external Net and the Cloud Router, will get some arp "who-has" but never receives a reply from the Router on the External Net.

For me it seems like a bug from VMWare, does anyone have similar problems?

TCPDump to see the who-has requests: tcpdump -elnXXi brq0805d2f3-0b -s 100 port not 22

It's just like i need to setup arp-proxy.

Thanks in advance.

can't reach external network VMWare

I was working through the Documentation of Liberty RDO.

My System contains a contains:

  • Controller Node with Network (VMWare Machine) and a (Virtual Machine on ESX) also has installed Neutron on it
  • Nova Node which is a Physical one. (Physical Machine)

Everything works fine except that i cannot ping the created Router from External public and Vice Versa.

The Network is using Linuxbridge, which causes the problem.

Linuxbridge.

As I'm Using using CentOS 7, and there was a problem with the iproute which i had to downgrade the IPRoute as mentioned in another post, as the Router would not add a secondary Interface.

After some analysis, i can see, this thread https://ask.openstack.org/en/question/87705/neutronagentl3router_info-cannot-create-namespace-file-file-exists/

When the router tries to ping the gateway, i was able to tcpdump the communication and it seems like that on the Bridge, which is connecting the external Net and the Cloud Router, will get some arp the "who-has" <ip of="" gateway=""> gets sent but never receives a reply reply. To assure the public network is running i temporarily assign it an IP Address and i can ping the gateway from the Router on the External Net.there.

For me it seems like a bug from VMWare, does as it doesn't forward the who-has requests. Does anyone have encounter similar problems?

With TCPDump to see the who-has requests: i used the following command to watch the network traffice:

tcpdump -elnXXi brq0805d2f3-0b -s 100 port not 22

It's just like i need to setup arp-proxy.

Thanks in advance.advance for any help.

can't reach external network VMWare

I was working through the Documentation of Liberty RDO.

My System contains:

  • Controller (Virtual Machine on ESX) also has installed Neutron on it
  • Nova (Physical Machine)

Everything works fine except that i cannot ping the created Router from public and Vice Versa.

The Network is using Linuxbridge.

As I'm using CentOS 7, there was a problem with the iproute which i had to downgrade as mentioned in this thread https://ask.openstack.org/en/question/87705/neutronagentl3router_info-cannot-create-namespace-file-file-exists/

When the router tries to ping the gateway, i was able to tcpdump the communication and it seems like that the "who-has" <ip of="" gateway=""> gets sent but never receives a reply. To assure the public network is running i temporarily assign it an IP Address and i can ping the gateway from there.

For me it seems like a bug from VMWare, as it doesn't forward the who-has requests. Does anyone encounter similar problems?

With TCPDump i used the following command to watch the network traffice:

traffic:

tcpdump -elnXXi brq0805d2f3-0b -s 100 port not 22

22

Thanks in advance for any help.