Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

instance can ping external, but can't get web site

I am already installed keystone, glance, neutron, nova base vmware workstation by following openstack installation document http://docs.openstack.org/kilo/install-guide/install/yum/content/. there are three nodes in my testing environment, one controller, one network and one compute

After installation, i can start a instance, can ping external from this instance. Every thing looks fine, but one question:

When i execute curl http://www.google.com from this instance, we can get follow:

[root@host-10-0-10-5 ~]# curl http://www.google.com
<HTML><HEAD><meta http-equiv="content-type" content="text/html;charset=utf-8">
<TITLE>302 Moved</TITLE></HEAD><BODY>
<H1>302 Moved</H1> The document has moved <A HREF="http://www.google.com.hk/url?sa=p&hl=zh-CN&pref=hkredirect&pval=yes&q=http://www.google.com.hk/%3Fgws_rd%3Dcr&ust=1458650998707327&usg=AFQjCNGsNs_L6PnFeMGENP0BEcgWOvulyQ">here</A>.
</BODY></HTML>

It's seem normal here, but when we continue execute curl http://www.google.com.hk/url?sa=p&hl=zh-CN&pref=hkredirect&pval=yes&q=http://www.google.com.hk/%3Fgws_rd%3Dcr&ust=1458650998707327&usg=AFQjCNGsNs_L6PnFeMGENP0BEcgWOvulyQ, some things happened that i can't understand. when we execute above command, some time, i can get partial response, but most time i get nothing, and the command was hanging, not return.

Very kindly for any idea for this issue? I'm a newbee of openstack, if you have any idea about this, please provide the details about troubshooting process.

instance can ping external, but can't get web site

I am already installed keystone, glance, neutron, nova base vmware workstation by following openstack installation document http://docs.openstack.org/kilo/install-guide/install/yum/content/. http://docs.openstack.org/kilo/install-guide/install/yum/content/. there are three nodes in my testing environment, one controller, one network and one compute

After installation, i can start a instance, can ping external from this instance. Every thing looks fine, but one question:

When i execute curl http://www.google.com http://www.google.com from this instance, we can get follow:

[root@host-10-0-10-5 ~]# curl http://www.google.com
<HTML><HEAD><meta http-equiv="content-type" content="text/html;charset=utf-8">
<TITLE>302 Moved</TITLE></HEAD><BODY>
<H1>302 Moved</H1> The document has moved <A HREF="http://www.google.com.hk/url?sa=p&hl=zh-CN&pref=hkredirect&pval=yes&q=http://www.google.com.hk/%3Fgws_rd%3Dcr&ust=1458650998707327&usg=AFQjCNGsNs_L6PnFeMGENP0BEcgWOvulyQ">here</A>.
</BODY></HTML></BODY></HTML>

It's seem normal here, but when we continue execute curl http://www.google.com.hk/url?sa=p&hl=zh-CN&pref=hkredirect&pval=yes&q=http://www.google.com.hk/%3Fgws_rd%3Dcr&ust=1458650998707327&usg=AFQjCNGsNs_L6PnFeMGENP0BEcgWOvulyQ, http://www.google.com.hk/url?sa=p&amp;hl=zh-CN&amp;pref=hkredirect&amp;pval=yes&amp;q=http://www.google.com.hk/%3Fgws_rd%3Dcr&amp;ust=1458650998707327&amp;usg=AFQjCNGsNs_L6PnFeMGENP0BEcgWOvulyQ, some things happened that i can't understand. when we execute above command, some time, i can get partial response, but most time i get nothing, and the command was hanging, not return.

Very kindly for any idea for this issue? I'm a newbee of openstack, if you have any idea about this, please provide the details about troubshooting process.