Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

linux bridge physical interface mapping

I am running OpenStack Liberty on a three node setup on ubuntu server 14.04 with the official canonical cloudarchive repository.

I've setup an ext-net which is a flat network. And my demo-net uses vxlan(segmention-id: 98).

The problem is that the eth2 on the network node is correctly connected to eth2, but the internal instance-tunnel bridge (vxlan-98) is not.

My linux-bridge configuration (ML2) is.

[linux_bridge]
physical_interface_mappings = vxlan-98:eth1,external:eth2

[vxlan]
enable_vxlan = True
local_ip = 192.168.2.10
l2_population = True

[agent]
prevent_arp_spoofing = True

[securitygroup]
enable_security_group = True
enable_ipset = True
firewall_driver = neutron.agent.linux.iptables_firewall.IptablesFirewallDriver

brctl shows:

network:~$ brctl show
bridge name     bridge id               STP enabled     interfaces
brq60960441-d6          8000.00e07d8bcd8b       no              eth2
                                                        tapce854a52-72
brqbe23e062-4e          8000.0060085c8491       no              
                                                        tap4d535359-3d
                                                        tapcc83ffb3-43
                                                        vxlan-94

If i manually connect brqbe23e062-4e (instance tunnel bridge) with eth1, everything works fine, so I guess, that the

physical_interface_mappings = vxlan-98:eth1,external:eth2

linux bridge physical interface mapping

I am running OpenStack Liberty on a three node setup on ubuntu server 14.04 with the official canonical cloudarchive repository.

I've setup an ext-net which is a flat network. And my demo-net uses vxlan(segmention-id: 98).

The problem is that the eth2 on the network node is correctly connected to eth2, but the internal instance-tunnel bridge (vxlan-98) is not.

My linux-bridge configuration (ML2) is.

[linux_bridge]
physical_interface_mappings = vxlan-98:eth1,external:eth2

[vxlan]
enable_vxlan = True
local_ip = 192.168.2.10
l2_population = True

[agent]
prevent_arp_spoofing = True

[securitygroup]
enable_security_group = True
enable_ipset = True
firewall_driver = neutron.agent.linux.iptables_firewall.IptablesFirewallDriver

brctl shows:

network:~$ brctl show
bridge name     bridge id               STP enabled     interfaces
brq60960441-d6          8000.00e07d8bcd8b       no              eth2
                                                        tapce854a52-72
brqbe23e062-4e          8000.0060085c8491       no              
                                                        tap4d535359-3d
                                                        tapcc83ffb3-43
                                                        vxlan-94

If i manually connect brqbe23e062-4e (instance tunnel bridge) with eth1, everything works fine, so I guess, that the

physical_interface_mappings = vxlan-98:eth1,external:eth2

linux bridge physical interface mapping

I am running OpenStack Liberty on a three node setup on ubuntu server 14.04 with the official canonical cloudarchive repository.

I've setup an ext-net which is a flat network. And my demo-net uses vxlan(segmention-id: 98).

The problem is that the eth2 on the network node is correctly connected to eth2, but the internal instance-tunnel bridge (vxlan-98) is not.

My linux-bridge configuration (ML2) is.

[linux_bridge]
physical_interface_mappings = vxlan-98:eth1,external:eth2

[vxlan]
enable_vxlan = True
local_ip = 192.168.2.10
l2_population = True

[agent]
prevent_arp_spoofing = True

[securitygroup]
enable_security_group = True
enable_ipset = True
firewall_driver = neutron.agent.linux.iptables_firewall.IptablesFirewallDriver

brctl shows:

network:~$ brctl show
bridge name     bridge id               STP enabled     interfaces
brq60960441-d6          8000.00e07d8bcd8b       no              eth2
                                                        tapce854a52-72
brqbe23e062-4e          8000.0060085c8491       no              
                                                        tap4d535359-3d
                                                        tapcc83ffb3-43
                                                        vxlan-94

If i manually connect brqbe23e062-4e (instance tunnel bridge) with eth1, everything works fine, so I guess, that the

physical_interface_mappings = vxlan-98:eth1,external:eth2

line is wrong.