Ask Your Question

Revision history [back]

Enabling Gnocchi in DevStack fails

Hi,

I tried to enable Gnocchi service in devstack but failed with the following errors:

+ [[ -n /opt/stack/logs ]]
+ echo 'logfile /opt/stack/logs/key-access.log.2016-02-29-160029'
+ echo 'log on'
+ screen -S stack -p key-access -X stuff 'sudo tail -f /var/log/apache2/keystone_access.log & echo $! >/opt/stack/status/stack/key-access.pid; fg |' echo "key-access failed to start" | tee "/opt/stack/status/stack/key-access.failure"
+ echo 'Waiting for keystone to start...'
Waiting for keystone to start...
+ wait_for_service 60 http://192.168.2.154:5000/v2.0/
+ local timeout=60
+ local url=http://192.168.2.154:5000/v2.0/
+ timeout 60 sh -c 'while ! curl -g -k --noproxy '\''*'\'' -s http://192.168.2.154:5000/v2.0/ >/dev/null; do sleep 1; done'
+ is_service_enabled tls-proxy
++ grep xtrace
++ set +o
+ local 'xtrace=set -o xtrace'
+ set +o xtrace
+ return 1
+ restart_service memcached
+ is_ubuntu
+ [[ -z deb ]]
+ '[' deb = deb ']'
+ sudo /usr/sbin/service memcached restart
Restarting memcached: memcached.
+ SERVICE_ENDPOINT=http://192.168.2.154:35357/v2.0
+ is_service_enabled tls-proxy
++ grep xtrace
++ set +o
+ local 'xtrace=set -o xtrace'
+ set +o xtrace
+ return 1
+ export OS_TOKEN=ubuntu
+ OS_TOKEN=ubuntu
+ export OS_URL=http://192.168.2.154:35357/v2.0
+ OS_URL=http://192.168.2.154:35357/v2.0
+ create_keystone_accounts
++ get_or_create_project admin default
++ local project_id
+++ openstack --os-url=http://192.168.2.154:5000/v3 --os-identity-api-version=3 project create admin --domain=default --or-show -f value -c id
Could not find resource default
++ project_id=
++ echo
+ local admin_tenant=
++ get_or_create_user admin ubuntu default
++ local user_id
++ [[ ! -z '' ]]
++ local email=
+++ openstack user create admin --password ubuntu --os-url=http://192.168.2.154:5000/v3 --os-identity-api-version=3 --domain=default --or-show -f value -c id
Could not find resource default
++ user_id=
++ echo
+ local admin_user=
++ get_or_create_role admin
++ local role_id
+++ openstack role create admin --os-url=http://192.168.2.154:5000/v3 --os-identity-api-version=3 --or-show -f value -c id
Internal Server Error (HTTP 500)
++ role_id=
++ echo
+ local admin_role=
+ get_or_add_user_project_role
+ local user_role_id
++ get_field 1
++ local data field
++ grep '  '
++ read data
++ openstack role list --user --os-url=http://192.168.2.154:5000/v3 --os-identity-api-version=3 --column ID --project --column Name
usage: openstack role list [-h] [-f {csv,json,table,value,yaml}] [-c COLUMN]
                           [--max-width <integer>] [--noindent]
                           [--quote {all,minimal,none,nonnumeric}]
                           [--domain <domain> | --project <project>]
                           [--user <user> | --group <group>]
                           [--group-domain <group-domain>]
                           [--project-domain <project-domain>]
                           [--user-domain <user-domain>] [--inherited]
openstack role list: error: argument --user: expected one argument
+ user_role_id=
+ [[ -z '' ]]
+ openstack role add --user --project --os-url=http://192.168.2.154:5000/v3 --os-identity-api-version=3
usage: openstack role add [-h] [--domain <domain> | --project <project>]
                          [--user <user> | --group <group>]
                          [--group-domain <group-domain>]
                          [--project-domain <project-domain>]
                          [--user-domain <user-domain>] [--inherited]
                          <role>
openstack role add: error: argument --user: expected one argument
+ exit_trap
+ local r=2
++ jobs -p
+ jobs=
+ [[ -n '' ]]
+ kill_spinner
+ '[' '!' -z '' ']'
+ [[ 2 -ne 0 ]]
+ echo 'Error on exit'
Error on exit
+ generate-subunit 1456741823 4330 fail
+ [[ -z /opt/stack/logs ]]
+ /home/ubuntu/devstack/tools/worlddump.py -d /opt/stack/logs
World dumping... see /opt/stack/logs/worlddump-2016-02-29-114233.txt for details
+ exit 2

Notably, this error occur only whenever I enable the Gnnochi service in devstack using local.conf file. Below is my local.conf file for your reference:

[[local|localrc]]
FLOATING_RANGE=192.168.2.224/27
FIXED_RANGE=10.11.12.0/24
FIXED_NETWORK_SIZE=256
FLAT_INTERFACE=eth0
ADMIN_PASSWORD=supersecret
DATABASE_PASSWORD=supersecret
RABBIT_PASSWORD=supersecret
SERVICE_PASSWORD=supersecret

enable_plugin gnocchi https://git.openstack.org/openstack/gnocchi

P.S:- When I tried without gnocchi plugin in local.conf file, I get the devstack successfully up and running.

Any advise or guidance would be greatly appreciated..!!.

Thanks in advance! Vinoth

Enabling Gnocchi in DevStack fails

Hi,

I tried to enable Gnocchi service in devstack liberty but failed with the following errors:

+ [[ -n /opt/stack/logs ]]
+ echo 'logfile /opt/stack/logs/key-access.log.2016-02-29-160029'
+ echo 'log on'
+ screen -S stack -p key-access -X stuff 'sudo tail -f /var/log/apache2/keystone_access.log & echo $! >/opt/stack/status/stack/key-access.pid; fg |' echo "key-access failed to start" | tee "/opt/stack/status/stack/key-access.failure"
+ echo 'Waiting for keystone to start...'
Waiting for keystone to start...
+ wait_for_service 60 http://192.168.2.154:5000/v2.0/
+ local timeout=60
+ local url=http://192.168.2.154:5000/v2.0/
+ timeout 60 sh -c 'while ! curl -g -k --noproxy '\''*'\'' -s http://192.168.2.154:5000/v2.0/ >/dev/null; do sleep 1; done'
+ is_service_enabled tls-proxy
++ grep xtrace
++ set +o
+ local 'xtrace=set -o xtrace'
+ set +o xtrace
+ return 1
+ restart_service memcached
+ is_ubuntu
+ [[ -z deb ]]
+ '[' deb = deb ']'
+ sudo /usr/sbin/service memcached restart
Restarting memcached: memcached.
+ SERVICE_ENDPOINT=http://192.168.2.154:35357/v2.0
+ is_service_enabled tls-proxy
++ grep xtrace
++ set +o
+ local 'xtrace=set -o xtrace'
+ set +o xtrace
+ return 1
+ export OS_TOKEN=ubuntu
+ OS_TOKEN=ubuntu
+ export OS_URL=http://192.168.2.154:35357/v2.0
+ OS_URL=http://192.168.2.154:35357/v2.0
+ create_keystone_accounts
++ get_or_create_project admin default
++ local project_id
+++ openstack --os-url=http://192.168.2.154:5000/v3 --os-identity-api-version=3 project create admin --domain=default --or-show -f value -c id
Could not find resource default
++ project_id=
++ echo
+ local admin_tenant=
++ get_or_create_user admin ubuntu default
++ local user_id
++ [[ ! -z '' ]]
++ local email=
+++ openstack user create admin --password ubuntu --os-url=http://192.168.2.154:5000/v3 --os-identity-api-version=3 --domain=default --or-show -f value -c id
Could not find resource default
++ user_id=
++ echo
+ local admin_user=
++ get_or_create_role admin
++ local role_id
+++ openstack role create admin --os-url=http://192.168.2.154:5000/v3 --os-identity-api-version=3 --or-show -f value -c id
Internal Server Error (HTTP 500)
++ role_id=
++ echo
+ local admin_role=
+ get_or_add_user_project_role
+ local user_role_id
++ get_field 1
++ local data field
++ grep '  '
++ read data
++ openstack role list --user --os-url=http://192.168.2.154:5000/v3 --os-identity-api-version=3 --column ID --project --column Name
usage: openstack role list [-h] [-f {csv,json,table,value,yaml}] [-c COLUMN]
                           [--max-width <integer>] [--noindent]
                           [--quote {all,minimal,none,nonnumeric}]
                           [--domain <domain> | --project <project>]
                           [--user <user> | --group <group>]
                           [--group-domain <group-domain>]
                           [--project-domain <project-domain>]
                           [--user-domain <user-domain>] [--inherited]
openstack role list: error: argument --user: expected one argument
+ user_role_id=
+ [[ -z '' ]]
+ openstack role add --user --project --os-url=http://192.168.2.154:5000/v3 --os-identity-api-version=3
usage: openstack role add [-h] [--domain <domain> | --project <project>]
                          [--user <user> | --group <group>]
                          [--group-domain <group-domain>]
                          [--project-domain <project-domain>]
                          [--user-domain <user-domain>] [--inherited]
                          <role>
openstack role add: error: argument --user: expected one argument
+ exit_trap
+ local r=2
++ jobs -p
+ jobs=
+ [[ -n '' ]]
+ kill_spinner
+ '[' '!' -z '' ']'
+ [[ 2 -ne 0 ]]
+ echo 'Error on exit'
Error on exit
+ generate-subunit 1456741823 4330 fail
+ [[ -z /opt/stack/logs ]]
+ /home/ubuntu/devstack/tools/worlddump.py -d /opt/stack/logs
World dumping... see /opt/stack/logs/worlddump-2016-02-29-114233.txt for details
+ exit 2

Notably, this error occur only whenever I enable the Gnnochi service in devstack using local.conf file. Below is my local.conf file for your reference:

[[local|localrc]]
FLOATING_RANGE=192.168.2.224/27
FIXED_RANGE=10.11.12.0/24
FIXED_NETWORK_SIZE=256
FLAT_INTERFACE=eth0
ADMIN_PASSWORD=supersecret
DATABASE_PASSWORD=supersecret
RABBIT_PASSWORD=supersecret
SERVICE_PASSWORD=supersecret

enable_plugin gnocchi https://git.openstack.org/openstack/gnocchi

P.S:- When I tried without gnocchi plugin in local.conf file, I get the devstack successfully up and running.

Any advise or guidance would be greatly appreciated..!!.

Thanks in advance! Vinoth