Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

ERROR: openstack Internal Server Error (HTTP 500) after installing the Telemetry module

Hi

I have setup 5 node lab using CentOS7. Everything was working fine , I also launch a instance which was showing in output of nova list but later when I installed telemetry module as per the kilo installation guide and rebooted all nodes. Now nothing is working fine , I am getting below error. same is in nova list output

[root@controller2 ~]# openstack user list

WARNING: keystoneclient.auth.identity.generic.base Discovering versions from the identity service failed when creating the password plugin. Attempting to determine version from URL. ERROR: openstack Internal Server Error (HTTP 500)

[root@controller2 ~]# nova list

No handlers could be found for logger "keystoneclient.auth.identity.generic.base" ERROR (InternalServerError): Internal Server Error (HTTP 500)

ERROR: openstack Internal Server Error (HTTP 500) after installing the Telemetry module

Hi

I have setup 5 node lab using CentOS7. Everything was working fine , I also launch a instance which was showing in output of nova list but later when I installed telemetry module as per the kilo installation guide and rebooted all nodes. Now nothing is working fine , I am getting below error. same is in nova list output

 [root@controller2 ~]# openstack user list

list

WARNING: keystoneclient.auth.identity.generic.base Discovering versions from the identity service failed when creating the password plugin. Attempting to determine version from URL. ERROR: openstack Internal Server Error (HTTP 500)

500)

[root@controller2 ~]# nova list

list

No handlers could be found for logger "keystoneclient.auth.identity.generic.base" ERROR (InternalServerError): Internal Server Error (HTTP 500)

500)

ERROR: openstack Internal Server Error (HTTP 500) after installing the Telemetry module

Hi

I have setup 5 node lab using CentOS7. Everything was working fine , I also launch a instance which was showing in output of nova list but later when I installed telemetry module as per the kilo installation guide and rebooted all nodes. Now nothing is working fine , I am getting below error. same is in nova list output

 [root@controller2 ~]# openstack user list

WARNING: keystoneclient.auth.identity.generic.base Discovering versions from the identity service failed when creating the password plugin. Attempting to determine version from URL.
ERROR: openstack Internal Server Error (HTTP 500)


[root@controller2 ~]# nova list

No handlers could be found for logger "keystoneclient.auth.identity.generic.base"
ERROR (InternalServerError): Internal Server Error (HTTP 500)

UPDATE:

Please find output

[root@controller2 ~]# nova-manage service list
Option "verbose" from group "DEFAULT" is deprecated for removal.  Its value may be silently ignored in the future.

Binary           Host                                 Zone             Status     State Updated_At
nova-conductor   controller2                          internal         enabled    :-)   2016-02-27 03:32:08
nova-consoleauth controller2                          internal         enabled    :-)   2016-02-27 03:32:02
nova-scheduler   controller2                          internal         enabled    :-)   2016-02-27 03:32:05
nova-cert        controller2                          internal         enabled    XXX   2016-02-19 16:12:15
nova-compute     compute1                             nova             enabled    XXX   2016-02-19 16:09:31
nova-network     compute1                             internal         enabled    XXX   2016-02-19 16:09:29
[root@controller2 ~]#

[root@controller2 ~]# ls -ld  /var/www/cgi-bin/keystone
drwxr-xr-x 2 keystone keystone 29 Jan 23 07:02 /var/www/cgi-bin/keystone

[root@controller2 ~]# ls -ltr  /var/www/cgi-bin/keystone
total 8
-rwxr-xr-x 1 keystone keystone 939 Jan 23 07:02 main
-rwxr-xr-x 1 keystone keystone 939 Jan 23 07:02 admin
[root@controller2 ~]#

I did not find any update - once the it was showing error . Before that everything was working fine

[root@controller2 nova]# ls -ltr /var/log/nova/ | tail

-rw-r--r-- 1 nova nova  279940 Feb  6 00:53 nova-consoleauth.log-20160206.gz
-rw-r--r-- 1 nova nova  281536 Feb  6 01:02 nova-cert.log-20160206.gz
-rw-r--r-- 1 nova nova  321412 Feb  6 03:46 nova-scheduler.log-20160206.gz
-rw-r--r-- 1 nova nova  892202 Feb 10 05:57 nova-conductor.log-20160210.gz
-rw-r--r-- 1 nova nova 2527405 Feb 19 11:12 nova-consoleauth.log
-rw-r--r-- 1 nova nova 2903495 Feb 19 11:12 nova-scheduler.log
-rw-r--r-- 1 nova nova 2597521 Feb 19 11:12 nova-cert.log
-rw-r--r-- 1 nova nova 3832452 Feb 19 11:12 nova-conductor.log
-rw-r--r-- 1 nova nova  227691 Feb 19 11:12 nova-api.log
-rw-r--r-- 1 nova nova   24258 Feb 19 11:12 nova-novncproxy.log
[root@controller2 nova]#