Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

unable to install openstack with heatenabled using devstack

hie im new to openstack, im trying to install openstack with heat enabled using devstack and followed the instructions Clone devstack

$git clone https://github.com/openstack-dev/devstack.git

Clone devstack-heat

$git clone https://github.com/svashu/devstack-heat.git

Copy localrc from devstack-heat to devstack

$ cp devstack-heat/localrc devstack

Modify the devstack/localrc for IP and password modifications

Deploy your Devstack

$cd devstack && ./stack.sh

and this is the last phrase in my terminal

2016-02-16 14:31:29.598 | Discovering versions from the identity service failed when creating the password plugin. Attempting to determine version from URL. 2016-02-16 14:31:29.599 | Could not determine a suitable URL for the plugin 2016-02-16 14:31:29.645 | + /home/vv/devstack/lib/keystone:bootstrap_keystone:L582: token_id= 2016-02-16 14:31:29.645 | + /home/vv/devstack/lib/keystone:bootstrap_keystone:L1: exit_trap 2016-02-16 14:31:29.645 | + ./stack.sh:exit_trap:L474: local r=1 2016-02-16 14:31:29.646 | ++ ./stack.sh:exit_trap:L475: jobs -p 2016-02-16 14:31:29.647 | + ./stack.sh:exit_trap:L475: jobs= 2016-02-16 14:31:29.647 | + ./stack.sh:exit_trap:L478: [[ -n '' ]] 2016-02-16 14:31:29.647 | + ./stack.sh:exit_trap:L484: kill_spinner 2016-02-16 14:31:29.647 | + ./stack.sh:kill_spinner:L370: '[' '!' -z '' ']' 2016-02-16 14:31:29.647 | + ./stack.sh:exit_trap:L486: [[ 1 -ne 0 ]] 2016-02-16 14:31:29.647 | + ./stack.sh:exit_trap:L487: echo 'Error on exit' 2016-02-16 14:31:29.647 | Error on exit 2016-02-16 14:31:29.647 | + ./stack.sh:exit_trap:L488: generate-subunit 1455632612 477 fail 2016-02-16 14:31:29.887 | + ./stack.sh:exit_trap:L489: [[ -z /opt/stack/logs ]] 2016-02-16 14:31:29.888 | + ./stack.sh:exit_trap:L492: /home/vv/devstack/tools/worlddump.py -d /opt/stack/logs 2016-02-16 14:31:30.038 | ovs-ofctl: br-int is not a bridge or a socket 2016-02-16 14:31:30.047 | ovs-ofctl: br-tun is not a bridge or a socket 2016-02-16 14:31:30.055 | ovs-ofctl: br-ex is not a bridge or a socket 2016-02-16 14:31:30.061 | ovs-ofctl: br-int is not a bridge or a socket 2016-02-16 14:31:30.069 | ovs-ofctl: br-tun is not a bridge or a socket 2016-02-16 14:31:30.078 | ovs-ofctl: br-ex is not a bridge or a socket 2016-02-16 14:31:30.299 | + ./stack.sh:exit_trap:L498: exit 1

unable to install openstack with heatenabled using devstack

hie im new to openstack, im trying to install openstack with heat enabled using devstack and followed the instructions Clone devstack

$git clone https://github.com/openstack-dev/devstack.git

https://github.com/openstack-dev/devstack.git

Clone devstack-heat

$git clone https://github.com/svashu/devstack-heat.git

https://github.com/svashu/devstack-heat.git

Copy localrc from devstack-heat to devstack

$ cp devstack-heat/localrc devstack

devstack

Modify the devstack/localrc for IP and password modifications

Deploy your Devstack

$cd devstack && ./stack.sh

./stack.sh

and this is the last phrase in my terminal

2016-02-16 14:31:29.598 | Discovering versions from the identity service failed when creating the password plugin. Attempting to determine version from URL.
2016-02-16 14:31:29.599 | Could not determine a suitable URL for the plugin
2016-02-16 14:31:29.645 | + /home/vv/devstack/lib/keystone:bootstrap_keystone:L582:   token_id=
2016-02-16 14:31:29.645 | + /home/vv/devstack/lib/keystone:bootstrap_keystone:L1:   exit_trap
2016-02-16 14:31:29.645 | + ./stack.sh:exit_trap:L474:   local r=1
2016-02-16 14:31:29.646 | ++ ./stack.sh:exit_trap:L475:   jobs -p
2016-02-16 14:31:29.647 | + ./stack.sh:exit_trap:L475:   jobs=
2016-02-16 14:31:29.647 | + ./stack.sh:exit_trap:L478:   [[ -n '' ]]
2016-02-16 14:31:29.647 | + ./stack.sh:exit_trap:L484:   kill_spinner
2016-02-16 14:31:29.647 | + ./stack.sh:kill_spinner:L370:   '[' '!' -z '' ']'
2016-02-16 14:31:29.647 | + ./stack.sh:exit_trap:L486:   [[ 1 -ne 0 ]]
2016-02-16 14:31:29.647 | + ./stack.sh:exit_trap:L487:   echo 'Error on exit'
2016-02-16 14:31:29.647 | Error on exit
2016-02-16 14:31:29.647 | + ./stack.sh:exit_trap:L488:   generate-subunit 1455632612 477 fail
2016-02-16 14:31:29.887 | + ./stack.sh:exit_trap:L489:   [[ -z /opt/stack/logs ]]
2016-02-16 14:31:29.888 | + ./stack.sh:exit_trap:L492:   /home/vv/devstack/tools/worlddump.py -d /opt/stack/logs
2016-02-16 14:31:30.038 | ovs-ofctl: br-int is not a bridge or a socket
2016-02-16 14:31:30.047 | ovs-ofctl: br-tun is not a bridge or a socket
2016-02-16 14:31:30.055 | ovs-ofctl: br-ex is not a bridge or a socket
2016-02-16 14:31:30.061 | ovs-ofctl: br-int is not a bridge or a socket
2016-02-16 14:31:30.069 | ovs-ofctl: br-tun is not a bridge or a socket
2016-02-16 14:31:30.078 | ovs-ofctl: br-ex is not a bridge or a socket
2016-02-16 14:31:30.299 | + ./stack.sh:exit_trap:L498:   exit 1

1