Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Erros devstack stable/liberty install behind proxy self-signed ssl certificate

I'm trying to install DevStack stable/liberty on my Ubuntu 14.4.03 Trusty (all-in-one VM). My Ubuntu is behind a proxy that is a purposeful MITM with self signed certificates. I set http_proxy, https_proxy, no_proxy in .bashrc. I set defaults env_keep with sudo visudo. I changed git://git to https://git for GIT_BASE in stackrc. But when I ran ./stack.sh, I got the error below. Is there a way to set no ssl verify wholesale to run the entire stack.sh? If not, how many places do I need to disable checking self-signed certificates so stack.sh won't fail? Or, how many places do I need to accept the self-signed certificates? Thanks in advance for any tips or suggestions. Errors: /tmp/tmpNqoXHr/pip.zip/pip/_vendor/requests/packages/urllib3/util/ssl_.py:315: SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#snimissingwarning. /tmp/tmpNqoXHr/pip.zip/pip/_vendor/requests/packages/urllib3/util/ssl_.py:120: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning. Could not fetch URL https://pypi.python.org/simple/pip/: There was a problem confirming the ssl certificate: [Errno 1] _ssl.c:510: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed - skipping Could not find a version that satisfies the requirement pip<8 (from -c /home/vx/devstack-stable-liberty/tools/cap-pip.txt (line 1)) (from versions: ) No matching distribution found for pip<8 (from -c /home/vx/devstack-stable-liberty/tools/cap-pip.txt (line 1)) stack.sh failed: