Revision history [back]

click to hide/show revision 1
initial version

ERROR: openstackclient.shell Exception raised: (pbr 0.11.0 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('pbr>=1.6')

I am installing Manila on Ubuntu 14.04. I am following this: http://docs.openstack.org/developer/manila/adminref/quick_start.html and have set up keystone using http://docs.openstack.org/kilo/install-guide/install/apt/content/ch_keystone.html. I am very new to OpenStack community. Any help would be really appreciated. I created user in openstack for Manila. After that I executed following set of commands : git clone -b stable/kilo https://github.com/openstack/manila sudo python setup.py install sudo pip install python-manilaclient>=1.0.4 When I create new role / add user I get error : ERROR: openstackclient.shell Exception raised: (pbr 0.11.0 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('pbr>=1.6'), set(['python-keystoneclient', 'stevedore', 'oslo.utils']))

After reading existing threads on similar issue. I executed : pip install --upgrade setuptools However, the problem still exists.