Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

subnet interface status is down in router when create new routers

This is my scenario:

  • Liberty
  • RDO
  • Centos 7

Topology:

(Internet)----(1)Physical Router(2)-----(em1)Manager(em2)----(em1)Compute node

Physical Router:

  • Interface 1: xxx.yyy.zzz.www
  • Interface 2: 192.168.70.1/24

Manager:

  • em1: 192.168.70.10/24
  • em2: 192.168.80.1/24

Compute node:

  • em1: 192.168.80.13/24

This is what I do first:

In "Manager" I add this line to /etc/sysctl.conf:

net.ipv4.ip_forward = 1

Then, in "Manager":

# systemctl stop NetworkManager
# systemctl disable NetworkManager
# systemctl enable network
# systemctl disable firewalld
# systemctl stop firewalld
# yum update -y
# yum install -y https://rdoproject.org/repos/rdo-release.rpm
# yum update -y
# yum install -y openstack-packstack
# yum update -y

Reboot the box.

Then, in the "Compute Node" server I do the same than in the "Manager" server. All the traffic pass thru the "Manager" server, that has IP forwarding enabled.

Then, I generate the answer file:

packstack --gen-answer-file=respuestas.cfg

The only change I made on the response file:

CONFIG_COMPUTE_HOSTS=192.168.80.13

So, everything is installed on the Server called "Manager" and the only thing is installed on the other server is Nova (and Neutron Agent).

Once everything is installed, in the "Manager" server, I create the file /etc/sysconfig/network-scripts/ifcfg-br-ex and put this in there:

DEVICE=br-ex
DEVICETYPE=ovs
TYPE=OVSBridge
BOOTROTO=static
IPADD=192.168.80.1
NETMSK=255.255.255.0 
DNS1=8.8.8.8
ONBOOT=yes

Then, in "Manager" I edit the /etc/sysconfig/network-scripts/ifcfg-em2 file and add/change this:

TYPE=OVSPort
DEVICETYPE=ovs
OVS_BRIDGE=br-ex

And then, I edit /etc/neutron/plugin.ini and add this:

network_vlan_ranges = physnet1
bridge_mappings = physnet1:br-ex

Finally, I restart network service:

# systemctl restart network.service

In Horizon, I create the correct rules in "Access & Security"/"Security Groups" section.

Now, due the "demo" project is created, I will use that internal network and router to connect my first instance (that is launched on the "admin" project). In order to do that, I edit the "private" network, make it shared, and then I'm able to launch an instance (cirros), ping the router (default gateway) and everything. I Can use floating IPs and they work fine.

The problem is when I want to create new networks/routers. This is what I do, as "admin" user:

# . keystonerc_admin
# neutron router-create router_test 
# neutron net-create network_new_lan --provider:network_type vxlan
# neutron subnet-create --name subnet_new_lan --enable_dhcp --allocation-pool=start=172.16.90.2,end=172.16.90.254 --gateway=172.16.90.1 --dns-nameserver 8.8.8.8 network_new_lan 172.16.90.0/24
# neutron router-interface-add router_test subnet=subnet_new_lan

At this point, If I see in the "interfaces" section inside Project/Network/Routers in Horizon, in the "router_test" router, I'll see a "Down" status in the internal interface (which is the one we just created).

Any instance that uses this internal subnet (subnet_new_lan) will not get an IP and, of course, will not have connectivity to the router nor internet, nor nothing (because it doesn't have IP!).

Due I'm able to do everything with the router and networks from the "demo" project, I'm possitive there is no connectivity issues (packages from the Compute node server pass thru the Manager server and then goes to the internet).

I don't know where is my problem, but I ran out of ideas. Please help!

subnet interface status is down in router when create new routers

This is my scenario:

  • Liberty
  • RDO
  • Centos 7

Topology:

(Internet)----(1)Physical Router(2)-----(em1)Manager(em2)----(em1)Compute node

Physical Router:

  • Interface 1: xxx.yyy.zzz.www
  • Interface 2: 192.168.70.1/24

Manager:

  • em1: 192.168.70.10/24
  • em2: 192.168.80.1/24

Compute node:

  • em1: 192.168.80.13/24

This is what I do first:

In "Manager" I add this line to /etc/sysctl.conf:

net.ipv4.ip_forward = 1

Then, in "Manager":

# systemctl stop NetworkManager
# systemctl disable NetworkManager
# systemctl enable network
# systemctl disable firewalld
# systemctl stop firewalld
# yum update -y
# yum install -y https://rdoproject.org/repos/rdo-release.rpm
# yum update -y
# yum install -y openstack-packstack
# yum update -y

Reboot the box.

Then, in the "Compute Node" server I do the same than in the "Manager" server. All the traffic pass thru the "Manager" server, that has IP forwarding enabled.

Then, I generate the answer file:

packstack --gen-answer-file=respuestas.cfg

The only change I made on the response file:

CONFIG_COMPUTE_HOSTS=192.168.80.13

So, everything is installed on the Server called "Manager" and the only thing is installed on the other server is Nova (and Neutron Agent).

Once everything is installed, in the "Manager" server, I create the file /etc/sysconfig/network-scripts/ifcfg-br-ex and put this in there:

DEVICE=br-ex
DEVICETYPE=ovs
TYPE=OVSBridge
BOOTROTO=static
IPADD=192.168.80.1
NETMSK=255.255.255.0 
DNS1=8.8.8.8
ONBOOT=yes

Then, in "Manager" I edit the /etc/sysconfig/network-scripts/ifcfg-em2 file and add/change this:

TYPE=OVSPort
DEVICETYPE=ovs
OVS_BRIDGE=br-ex

And then, I edit /etc/neutron/plugin.ini and add this:

network_vlan_ranges = physnet1
bridge_mappings = physnet1:br-ex

Finally, I restart network service:

# systemctl restart network.service

In Horizon, I create the correct rules in "Access & Security"/"Security Groups" section.

Now, due the "demo" project is created, I will use that internal network and router to connect my first instance (that is launched on the "admin" project). In order to do that, I edit the "private" network, make it shared, and then I'm able to launch an instance (cirros), ping the router (default gateway) and everything. I Can use floating IPs and they work fine.

The problem is when I want to create new networks/routers. This is what I do, as "admin" user:

# . keystonerc_admin
# neutron router-create router_test 
# neutron net-create network_new_lan --provider:network_type vxlan
# neutron subnet-create --name subnet_new_lan --enable_dhcp --allocation-pool=start=172.16.90.2,end=172.16.90.254 --gateway=172.16.90.1 --dns-nameserver 8.8.8.8 network_new_lan 172.16.90.0/24
# neutron router-interface-add router_test subnet=subnet_new_lan

UPDATE:

When I add an interface, I see this error in /var/log/neutron/server.log:

2015-12-28 13:43:51.478 5798 WARNING neutron.plugins.ml2.drivers.mech_agent [req-f46a9d2f-41c6-4227-abf1-d6cd2c635477 - - - - -] Attempting to bind with dead agent: {'binary': u'neutron-openvswitch-agent', 'description': None, 'admin_state_up': True, 'heartbeat_timestamp': datetime.datetime(2015, 12, 24, 16, 54, 8), 'alive': False, 'topic': u'N/A', 'host': u'manager.network.local', 'agent_type': u'Open vSwitch agent', 'created_at': datetime.datetime(2015, 12, 24, 16, 41, 8), 'started_at': datetime.datetime(2015, 12, 24, 16, 41, 8), 'id': u'6dd8092a-1f61-4308-9086-8aea154aee9c', 'configurations': {u'in_distributed_mode': False, u'arp_responder_enabled': False, u'tunneling_ip': u'192.168.70.10', u'devices': 2, u'log_agent_heartbeats': False, u'l2_population': False, u'tunnel_types': [u'vxlan'], u'enable_distributed_routing': False, u'bridge_mappings': {}}}
2015-12-28 13:43:51.479 5798 ERROR neutron.plugins.ml2.managers [req-f46a9d2f-41c6-4227-abf1-d6cd2c635477 - - - - -] Failed to bind port afbd8713-9931-49f3-b847-4e6d4f6a2a52 on host manager.network.local
2015-12-28 13:43:51.479 5798 ERROR neutron.plugins.ml2.managers [req-f46a9d2f-41c6-4227-abf1-d6cd2c635477 - - - - -] Failed to bind port afbd8713-9931-49f3-b847-4e6d4f6a2a52 on host manager.network.local

END UPDATE

At this point, If I see in the "interfaces" section inside Project/Network/Routers in Horizon, in the "router_test" router, I'll see a "Down" status in the internal interface (which is the one we just created).

Any instance that uses this internal subnet (subnet_new_lan) will not get an IP and, of course, will not have connectivity to the router nor internet, nor nothing (because it doesn't have IP!).

Due I'm able to do everything with the router and networks from the "demo" project, I'm possitive there is no connectivity issues (packages from the Compute node server pass thru the Manager server and then goes to the internet).

I don't know where is my problem, but I ran out of ideas. Please help!

subnet interface status is down in router when create new routers

This is my scenario:

  • Liberty
  • RDO
  • Centos 7

Topology:

(Internet)----(1)Physical Router(2)-----(em1)Manager(em2)----(em1)Compute node

Physical Router:

  • Interface 1: xxx.yyy.zzz.www
  • Interface 2: 192.168.70.1/24

Manager:

  • em1: 192.168.70.10/24
  • em2: 192.168.80.1/24

Compute node:

  • em1: 192.168.80.13/24

This is what I do first:

In "Manager" I add this line to /etc/sysctl.conf:

net.ipv4.ip_forward = 1

Then, in "Manager":

# systemctl stop NetworkManager
# systemctl disable NetworkManager
# systemctl enable network
# systemctl disable firewalld
# systemctl stop firewalld
# yum update -y
# yum install -y https://rdoproject.org/repos/rdo-release.rpm
# yum update -y
# yum install -y openstack-packstack
# yum update -y

Reboot the box.

Then, in the "Compute Node" server I do the same than in the "Manager" server. All the traffic pass thru the "Manager" server, that has IP forwarding enabled.

Then, I generate the answer file:

packstack --gen-answer-file=respuestas.cfg

The only change I made on the response file:

CONFIG_COMPUTE_HOSTS=192.168.80.13

So, everything is installed on the Server called "Manager" and the only thing is installed on the other server is Nova (and Neutron Agent).

Once everything is installed, in the "Manager" server, I create the file /etc/sysconfig/network-scripts/ifcfg-br-ex and put this in there:

DEVICE=br-ex
DEVICETYPE=ovs
TYPE=OVSBridge
BOOTROTO=static
IPADD=192.168.80.1
NETMSK=255.255.255.0 
DNS1=8.8.8.8
ONBOOT=yes

Then, in "Manager" I edit the /etc/sysconfig/network-scripts/ifcfg-em2 file and add/change this:

TYPE=OVSPort
DEVICETYPE=ovs
OVS_BRIDGE=br-ex

And then, I edit /etc/neutron/plugin.ini and add this:

network_vlan_ranges = physnet1
bridge_mappings = physnet1:br-ex

Finally, I restart network service:

# systemctl restart network.service

In Horizon, I create the correct rules in "Access & Security"/"Security Groups" section.

Now, due the "demo" project is created, I will use that internal network and router to connect my first instance (that is launched on the "admin" project). In order to do that, I edit the "private" network, make it shared, and then I'm able to launch an instance (cirros), ping the router (default gateway) and everything. I Can use floating IPs and they work fine.

The problem is when I want to create new networks/routers. This is what I do, as "admin" user:

# . keystonerc_admin
# neutron router-create router_test 
# neutron net-create network_new_lan --provider:network_type vxlan
# neutron subnet-create --name subnet_new_lan --enable_dhcp --allocation-pool=start=172.16.90.2,end=172.16.90.254 --gateway=172.16.90.1 --dns-nameserver 8.8.8.8 network_new_lan 172.16.90.0/24
# neutron router-interface-add router_test subnet=subnet_new_lan

UPDATE:

When I add an interface, interface to the router (like in the prior command), I see this error in /var/log/neutron/server.log:

2015-12-28 13:43:51.478 5798 WARNING neutron.plugins.ml2.drivers.mech_agent [req-f46a9d2f-41c6-4227-abf1-d6cd2c635477 - - - - -] Attempting to bind with dead agent: {'binary': u'neutron-openvswitch-agent', 'description': None, 'admin_state_up': True, 'heartbeat_timestamp': datetime.datetime(2015, 12, 24, 16, 54, 8), 'alive': False, 'topic': u'N/A', 'host': u'manager.network.local', 'agent_type': u'Open vSwitch agent', 'created_at': datetime.datetime(2015, 12, 24, 16, 41, 8), 'started_at': datetime.datetime(2015, 12, 24, 16, 41, 8), 'id': u'6dd8092a-1f61-4308-9086-8aea154aee9c', 'configurations': {u'in_distributed_mode': False, u'arp_responder_enabled': False, u'tunneling_ip': u'192.168.70.10', u'devices': 2, u'log_agent_heartbeats': False, u'l2_population': False, u'tunnel_types': [u'vxlan'], u'enable_distributed_routing': False, u'bridge_mappings': {}}}
2015-12-28 13:43:51.479 5798 ERROR neutron.plugins.ml2.managers [req-f46a9d2f-41c6-4227-abf1-d6cd2c635477 - - - - -] Failed to bind port afbd8713-9931-49f3-b847-4e6d4f6a2a52 on host manager.network.local
2015-12-28 13:43:51.479 5798 ERROR neutron.plugins.ml2.managers [req-f46a9d2f-41c6-4227-abf1-d6cd2c635477 - - - - -] Failed to bind port afbd8713-9931-49f3-b847-4e6d4f6a2a52 on host manager.network.local

END UPDATE

At this point, If I see in the "interfaces" section inside Project/Network/Routers in Horizon, in the "router_test" router, I'll see a "Down" status in the internal interface (which is the one we just created).

Any instance that uses this internal subnet (subnet_new_lan) will not get an IP and, of course, will not have connectivity to the router nor internet, nor nothing (because it doesn't have IP!).

Due I'm able to do everything with the router and networks from the "demo" project, I'm possitive there is no connectivity issues (packages from the Compute node server pass thru the Manager server and then goes to the internet).

I don't know where is my problem, but I ran out of ideas. Please help!

subnet interface status is down in router when create new routers

This is my scenario:

  • Liberty
  • RDO
  • Centos 7

Topology:

(Internet)----(1)Physical Router(2)-----(em1)Manager(em2)----(em1)Compute node

Physical Router:

  • Interface 1: xxx.yyy.zzz.www
  • Interface 2: 192.168.70.1/24

Manager:

  • em1: 192.168.70.10/24
  • em2: 192.168.80.1/24

Compute node:

  • em1: 192.168.80.13/24

This is what I do first:

In "Manager" I add this line to /etc/sysctl.conf:

net.ipv4.ip_forward = 1

Then, in "Manager":

# systemctl stop NetworkManager
# systemctl disable NetworkManager
# systemctl enable network
# systemctl disable firewalld
# systemctl stop firewalld
# yum update -y
# yum install -y https://rdoproject.org/repos/rdo-release.rpm
# yum update -y
# yum install -y openstack-packstack
# yum update -y

Reboot the box.

Then, in the "Compute Node" server I do the same than in the "Manager" server. All the traffic pass thru the "Manager" server, that has IP forwarding enabled.

Then, I generate the answer file:

packstack --gen-answer-file=respuestas.cfg

The only change I made on the response file:

CONFIG_COMPUTE_HOSTS=192.168.80.13

So, everything is installed on the Server called "Manager" and the only thing is installed on the other server is Nova (and Neutron Agent).

Once everything is installed, in the "Manager" server, I create the file /etc/sysconfig/network-scripts/ifcfg-br-ex and put this in there:

DEVICE=br-ex
DEVICETYPE=ovs
TYPE=OVSBridge
BOOTROTO=static
IPADD=192.168.80.1
NETMSK=255.255.255.0 
DNS1=8.8.8.8
ONBOOT=yes

Then, in "Manager" I edit the /etc/sysconfig/network-scripts/ifcfg-em2 file and add/change this:

TYPE=OVSPort
DEVICETYPE=ovs
OVS_BRIDGE=br-ex

And then, I edit /etc/neutron/plugin.ini and add this:

network_vlan_ranges = physnet1
bridge_mappings = physnet1:br-ex

Finally, I restart network service:

# systemctl restart network.service

In Horizon, I create the correct rules in "Access & Security"/"Security Groups" section.

Now, due the "demo" project is created, I will use that internal network and router to connect my first instance (that is launched on the "admin" project). In order to do that, I edit the "private" network, make it shared, and then I'm able to launch an instance (cirros), ping the router (default gateway) and everything. I Can use floating IPs and they work fine.

The problem is when I want to create new networks/routers. This is what I do, as "admin" user:

# . keystonerc_admin
# neutron router-create router_test 
# neutron net-create network_new_lan --provider:network_type vxlan
# neutron subnet-create --name subnet_new_lan --enable_dhcp --allocation-pool=start=172.16.90.2,end=172.16.90.254 --gateway=172.16.90.1 --dns-nameserver 8.8.8.8 network_new_lan 172.16.90.0/24
# neutron router-interface-add router_test subnet=subnet_new_lan

UPDATE:

When I add an interface to the router (like in the prior command), I see this error in /var/log/neutron/server.log:

2015-12-28 13:43:51.478 5798 WARNING neutron.plugins.ml2.drivers.mech_agent [req-f46a9d2f-41c6-4227-abf1-d6cd2c635477 - - - - -] Attempting to bind with dead agent: {'binary': u'neutron-openvswitch-agent', 'description': None, 'admin_state_up': True, 'heartbeat_timestamp': datetime.datetime(2015, 12, 24, 16, 54, 8), 'alive': False, 'topic': u'N/A', 'host': u'manager.network.local', 'agent_type': u'Open vSwitch agent', 'created_at': datetime.datetime(2015, 12, 24, 16, 41, 8), 'started_at': datetime.datetime(2015, 12, 24, 16, 41, 8), 'id': u'6dd8092a-1f61-4308-9086-8aea154aee9c', 'configurations': {u'in_distributed_mode': False, u'arp_responder_enabled': False, u'tunneling_ip': u'192.168.70.10', u'devices': 2, u'log_agent_heartbeats': False, u'l2_population': False, u'tunnel_types': [u'vxlan'], u'enable_distributed_routing': False, u'bridge_mappings': {}}}
2015-12-28 13:43:51.479 5798 ERROR neutron.plugins.ml2.managers [req-f46a9d2f-41c6-4227-abf1-d6cd2c635477 - - - - -] Failed to bind port afbd8713-9931-49f3-b847-4e6d4f6a2a52 on host manager.network.local
2015-12-28 13:43:51.479 5798 ERROR neutron.plugins.ml2.managers [req-f46a9d2f-41c6-4227-abf1-d6cd2c635477 - - - - -] Failed to bind port afbd8713-9931-49f3-b847-4e6d4f6a2a52 on host manager.network.local

END UPDATE

At this point, If I see in the "interfaces" section inside Project/Network/Routers in Horizon, in the "router_test" router, I'll see a "Down" status in the internal interface (which is the one we just created).

Any instance that uses this internal subnet (subnet_new_lan) will not get an IP and, of course, will not have connectivity to the router nor internet, nor nothing (because it doesn't have IP!).

Due I'm able to do everything with the router and networks from the "demo" project, I'm possitive there is no connectivity issues (packages from the Compute node server pass thru the Manager server and then goes to the internet).

I don't know where is my problem, but I ran out of ideas. Please help!