Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

"tox -e venv" failed on stage of "venv runtests: commands[0]"

Hi I'm very new to openstack. I'm following this page http://docs.openstack.org/developer/keystone/devref/development.environment.html to start keystone development.

But when I ran "tox -e venv", I got these error:

venv develop-inst-noop: /home/shoutm/work/keystone
venv installed: aioeventlet==0.4,alembic==0.8.4,amqp==1.4.8,anyjson==0.3.3,appdirs==1.4.0,Babel==2.1.1,bashate==0.3.2,beautifulsoup4==4.4.1,cachetools==1.1.5,cffi==1.4.2,contextlib2==0.4.0,coverage==4.0.3,cryptography==1.1.2,debtcollector==1.1.0,decorator==4.0.6,docutils==0.12,dogpile.cache==0.5.7,dogpile.core==0.4.1,ecdsa==0.13,enum34==1.1.2,eventlet==0.17.4,extras==0.0.3,fasteners==0.14.1,fixtures==1.4.0,flake8==2.2.4,flake8-docstrings==0.2.1.post1,funcsigs==0.4,functools32==3.2.3.post2,futures==3.0.3,futurist==0.9.0,greenlet==0.4.9,hacking==0.10.2,httplib2==0.9.2,idna==2.0,ipaddress==1.0.15,iso8601==0.1.11,Jinja2==2.8,jsonschema==2.5.1,-e git+https://git.openstack.org/openstack/keystone.git@6d7e9e40375c5d4a661b7c08692841a127681cac#egg=keystone-gerrit_master,keystoneauth1==2.1.0,keystonemiddleware==4.0.0,kombu==3.0.32,ldappool==1.0,linecache2==1.0.0,lxml==3.5.0,Mako==1.0.3,MarkupSafe==0.23,mccabe==0.2.1,mock==1.3.0,monotonic==0.4,mox3==0.13.0,msgpack-python==0.4.6,netaddr==0.7.18,netifaces==0.10.4,oauthlib==1.0.3,ordereddict==1.1,os-client-config==1.13.0,os-testr==0.5.0,oslo.cache==1.1.0,oslo.concurrency==3.2.0,oslo.config==3.2.0,oslo.context==1.0.0,oslo.db==4.2.0,oslo.i18n==3.1.0,oslo.log==2.2.0,oslo.messaging==4.0.0,oslo.middleware==3.4.0,oslo.policy==1.2.0,oslo.serialization==2.2.0,oslo.service==1.2.0,oslo.utils==3.3.0,oslosphinx==4.2.0,oslotest==2.0.0,paramiko==1.16.0,passlib==1.6.5,Paste==2.0.2,PasteDeploy==1.5.2,pbr==1.8.1,pep257==0.7.0,pep8==1.5.7,prettytable==0.7.2,pyasn1==0.1.9,pycadf==2.0.1,pycparser==2.14,pycrypto==2.6.1,pyflakes==0.8.1,Pygments==2.0.2,pyinotify==0.9.6,pymongo==3.2,pyOpenSSL==0.15.1,pysaml2==4.0.1,python-dateutil==2.4.2,python-editor==0.5,python-keystoneclient==2.0.0,python-ldap==2.4.22,python-memcached==1.57,python-mimeparse==0.1.4,python-subunit==1.2.0,pytz==2015.7,PyYAML==3.11,reno==1.2.0,repoze.lru==0.6,repoze.who==2.2,requests==2.9.1,requestsexceptions==1.1.1,retrying==1.3.3,Routes==2.2,six==1.10.0,Sphinx==1.2.3,SQLAlchemy==1.0.11,sqlalchemy-migrate==0.10.0,sqlparse==0.1.18,stevedore==1.10.0,tempest-lib==0.12.0,Tempita==0.5.2,testrepository==0.0.20,testscenarios==0.5.0,testtools==1.8.1,traceback2==1.4.0,trollius==2.0,unittest2==1.1.0,waitress==0.8.10,WebOb==1.5.1,WebTest==2.0.20,wheel==0.24.0,wrapt==1.10.6,zope.interface==4.1.3
venv runtests: PYTHONHASHSEED='1360502957'
venv runtests: commands[0] | 
Traceback (most recent call last):
  File "/usr/local/bin/tox", line 11, in <module>
    sys.exit(cmdline())
  File "/usr/local/lib/python2.7/dist-packages/tox/session.py", line 39, in main
    retcode = Session(config).runcommand()
  File "/usr/local/lib/python2.7/dist-packages/tox/session.py", line 375, in runcommand
    return self.subcommand_test()
  File "/usr/local/lib/python2.7/dist-packages/tox/session.py", line 548, in subcommand_test
    self.runtestenv(venv)
  File "/usr/local/lib/python2.7/dist-packages/tox/session.py", line 556, in runtestenv
    venv.test(redirect=redirect)
  File "/usr/local/lib/python2.7/dist-packages/tox/venv.py", line 321, in test
    if argv[0].startswith("-"):
IndexError: list index out of range

My environment is

shoutm@ubuntu % lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.04.1 LTS
Release:    14.04
Codename:   trusty
shoutm@ubuntu % python -V
Python 2.7.6

Anybody knows how to solve this issue ?