Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

How to configure the RDO Dashboard for SSL

I have RDO OpenStack (https://www.rdoproject.org/install/quickstart/) installed and running on CentOS 7. Access to the Horizon Dashboard is by HTTP; HTTPS is not enabled or configured. RDO's instructions on how to configure Horizon to use SSL are here: https://www.rdoproject.org/install/horizonssl/. I followed those instruction. I have mod_ssl installed, I have created a self-signed certificate, and I have modified the ssl.conf file as instructed. When I go to the Dashboard using https:// I get the expected "This connection is untrusted" and it allowed me to add it as an exception, however, once added, I get "Not Found. The requested URL /dashboard was not found on this server." HTTP to the Dashboard still works, but HTTPS produces the "Not Found" page.

Back to the instructions at https://www.rdoproject.org/install/horizonssl/. It says to add the following to /etc/httpd/conf.d/openstack-dashboard.conf:

RewriteEngine On

RewriteCond %{HTTPS} !on

RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

However, when I open that file it says: "This file has been cleaned by Puppet. OpenStack Horizon configuration has been moved to: 15-horizon_vhost.conf and 15-horizon_ssl_vhost.conf".

When I look for those two files, I see only one, 15-horizon_vhost.conf. I tried adding those three lines to both openstack-dashboard.conf and to 15-horizon_vhost.conf, followed by a stop and start of Apache, however, neither change worked. I still get the "Not Found" page.

Any help would be greatly appreciated.