Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

packstack fails to install openstack-keystone (pyOpenSSL-0.13.1-1.el6.x86_64 requires openssl 1.0.1)

Hello, running packstack --allinone on fresh install of CentOS 6.4, I get the following error:

ERROR : Error appeared during Puppet run: 10.21.1.4_keystone.pp
Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install openstack-keystone' returned 1: Error: Package: pyOpenSSL-0.13.1-1.el6.x86_64 (openstack-havana)
You will find full trace in log /var/tmp/packstack/20131211-182129-5I0avV/manifests/10.21.1.4_keystone.pp.log

Checking the trace file the problem is the package pyOpenSSL-0.13.1-1.el6.x86_64 (required by openstack-keystone) that depends on OpenSSL 1.0.1

Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install openstack-keystone' returned 1: Error: Package: pyOpenSSL-0.13.1-1.el6.x86_64 (openstack-havana)
           Requires: libcrypto.so.10(OPENSSL_1.0.1)(64bit)
Error: Package: pyOpenSSL-0.13.1-1.el6.x86_64 (openstack-havana)
           Requires: libcrypto.so.10(libcrypto.so.10)(64bit)
Error: Package: pyOpenSSL-0.13.1-1.el6.x86_64 (openstack-havana)
           Requires: libssl.so.10(libssl.so.10)(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Centos 6.4 is still using OpenSSL 1.0.0

[root@n04 ~]# rpm -q openssl
openssl-1.0.0-27.el6.x86_64

Does pyOpenSSL-0.13.1-1.el6.x86_64 have been updated in the havana repo since the last 2 weeks? Because about 2 weeks ago I successfully installed Openstack Havana with packstack --allinonce on a CentOS 6.4 server.

Thanks you

packstack fails to install openstack-keystone (pyOpenSSL-0.13.1-1.el6.x86_64 requires openssl 1.0.1)

Hello, running packstack --allinone on fresh install of CentOS 6.4, I get the following error:

ERROR : Error appeared during Puppet run: 10.21.1.4_keystone.pp
Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install openstack-keystone' returned 1: Error: Package: pyOpenSSL-0.13.1-1.el6.x86_64 (openstack-havana)
You will find full trace in log /var/tmp/packstack/20131211-182129-5I0avV/manifests/10.21.1.4_keystone.pp.log

Checking the trace file the problem is the package pyOpenSSL-0.13.1-1.el6.x86_64 (required by openstack-keystone) that depends on OpenSSL 1.0.1

Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install openstack-keystone' returned 1: Error: Package: pyOpenSSL-0.13.1-1.el6.x86_64 (openstack-havana)
           Requires: libcrypto.so.10(OPENSSL_1.0.1)(64bit)
Error: Package: pyOpenSSL-0.13.1-1.el6.x86_64 (openstack-havana)
           Requires: libcrypto.so.10(libcrypto.so.10)(64bit)
Error: Package: pyOpenSSL-0.13.1-1.el6.x86_64 (openstack-havana)
           Requires: libssl.so.10(libssl.so.10)(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Centos 6.4 is still using OpenSSL 1.0.0

[root@n04 ~]# rpm -q openssl
openssl-1.0.0-27.el6.x86_64

Does pyOpenSSL-0.13.1-1.el6.x86_64 have been updated in the havana repo since the last 2 weeks? Because about 2 weeks ago I successfully installed Openstack Havana with packstack --allinonce on a CentOS 6.4 server.

Thanks you