Revision history [back]

click to hide/show revision 1
initial version

packstack fails to detect ipaddress of interface eth1

I'm trying to add a node to my single-server installation using the instructions at https://www.rdoproject.org/install/adding-a-compute-node/. After editing the answer file I run packstack --answer-file=~/<answerfile> as per the instructions. However, it fails on the line

Adding Neutron API manifest entries

The error is

ERROR : "Couldn't detect ipaddress of interface eth1 on node 192.168.122.151"

I tried to find a solution but the only thing I came across is another answer here on the Q&A (https://ask.openstack.org/en/question/79980/packstack-complains-of-not-being-able-to-detect-ipaddress-of-interface/). I tried the solution that is suggested by sanderv but it didn't do anything. I got the same error.

One thing I've found with the instructions is that they mention CONFIG_NOVA_COMPUTE_HOSTS and CONFIG_NOVA_NETWORK_HOSTS stating that the IPs should be properly configured. Neither of those keys is in the answer file that packstack generated. I have CONFIG_COMPUTE_HOSTS and CONFIG_NETWORK_HOSTS, though. Each of these I've set to be what the instructions say the other keys should be.

In addition to this issue (or maybe as a result of it), the interface values I set are wiped out. For instance, I set CONFIG_NOVA_COMPUTE_PRIVIF and CONFIG_NOVA_NETWORK_PRIVIF to eth1 as instructed. But after running packstack --answer-file=<answerfile> those are blank.

What am I doing wrong?