Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

I am installing Havana and getting following error on neutron in l3-agent.log , dhcp_agent.log ERROR neutron.agent.l3_agent [-] Failed synchronizing routers

I am installing Havana and getting following error on neutron in l3-agent.log , dhcp_agent.log 2013-12-09 22:18:20.756 2510 ERROR neutron.agent.l3_agent [-] Failed synchronizing routers 2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent Traceback (most recent call last): 2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent File "/usr/lib/python2.7/dist-packages/neutron/agent/l3_agent.py", line 750, in _sync_routers_task 2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent context, router_ids) 2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent File "/usr/lib/python2.7/dist-packages/neutron/agent/l3_agent.py", line 75, in get_routers 2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent topic=self.topic) 2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent File "/usr/lib/python2.7/dist-packages/neutron/openstack/common/rpc/proxy.py", line 130, in call 2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent exc.info, real_topic, msg.get('method')) 2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent Timeout: Timeout while waiting on RPC response - topic: "q-l3-plugin", RPC method: "sync_routers" info: "<unknown>" 2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent 2013-12-09 22:18:20.756 2510 WARNING neutron.openstack.common.loopingcall [-] task run outlasted interval by 598.002945 sec 2013-12-09 22:18:20.756 2510 WARNING neutron.openstack.common.loopingcall [-] task run outlasted interval by 560.003462 sec

I am getting following output after running command "ip a" 1: lo: <loopback,up,lower_up> mtu 65536 qdisc noqueue state UNKNOWN link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 inet 127.0.0.1/8 scope host lo inet6 ::1/128 scope host valid_lft forever preferred_lft forever 2: eth0: <broadcast,multicast,up,lower_up> mtu 1500 qdisc pfifo_fast state UP qlen 1000 link/ether 00:50:56:91:56:56 brd ff:ff:ff:ff:ff:ff inet 172.16.17.18/16 brd 172.16.255.255 scope global eth0 inet6 fe80::250:56ff:fe91:5656/64 scope link valid_lft forever preferred_lft forever 3: eth1: <broadcast,multicast,up,lower_up> mtu 1500 qdisc pfifo_fast state UP qlen 1000 link/ether 00:50:56:91:6c:43 brd ff:ff:ff:ff:ff:ff inet 172.16.17.111/16 brd 172.16.255.255 scope global eth1 inet6 fe80::250:56ff:fe91:6c43/64 scope link valid_lft forever preferred_lft forever 4: eth2: <broadcast,multicast,promisc,up,lower_up> mtu 1500 qdisc pfifo_fast state UP qlen 1000 link/ether 00:50:56:91:32:e5 brd ff:ff:ff:ff:ff:ff inet6 fe80::250:56ff:fe91:32e5/64 scope link valid_lft forever preferred_lft forever 5: ovs-system: <broadcast,multicast> mtu 1500 qdisc noop state DOWN link/ether 5a:ef:48:02:d3:69 brd ff:ff:ff:ff:ff:ff 6: br-ex: <broadcast,up,lower_up> mtu 1500 qdisc noqueue state UNKNOWN link/ether 00:50:56:91:32:e5 brd ff:ff:ff:ff:ff:ff inet 172.16.17.113/16 brd 172.16.255.255 scope global br-ex inet6 fe80::5024:4aff:feba:5357/64 scope link valid_lft forever preferred_lft forever 7: br-int: <broadcast,up,lower_up> mtu 1500 qdisc noqueue state UNKNOWN link/ether ce:01:3d:b5:56:47 brd ff:ff:ff:ff:ff:ff inet6 fe80::fc35:5bff:fe36:5361/64 scope link valid_lft forever preferred_lft forever 11: br-tun: <broadcast,up,lower_up> mtu 1500 qdisc noqueue state UNKNOWN link/ether 5a:e7:2a:e5:e1:49 brd ff:ff:ff:ff:ff:ff inet6 fe80::84bd:d6ff:fef4:e7b2/64 scope link valid_lft forever preferred_lft forever

I have disabled firewall on both network node and controller node.

Also I am getting following output on controller node : root@openstackvm17:~# neutron agent-list +--------------------------------------+--------------------+---------------+-------+----------------+ | id | agent_type | host | alive | admin_state_up | +--------------------------------------+--------------------+---------------+-------+----------------+ | aaf278c5-b82e-4b13-bb5d-688a72048f38 | L3 agent | openstackvm18 | :-) | True | | b11374b4-a92a-4736-9c5c-ad82244b61c3 | DHCP agent | openstackvm18 | :-) | True | | bd26c9a9-7e89-4221-a497-f9f88521a31a | Open vSwitch agent | openstackvm18 | :-) | True | +--------------------------------------+--------------------+---------------+-------+----------------+

openstackvm17 is my Controller and openstackvm18 is my network node.

Please help me to resolve this issue.

Thanks in advanced.

click to hide/show revision 2
No.2 Revision

I am installing Havana and getting following error on neutron in l3-agent.log , dhcp_agent.log ERROR neutron.agent.l3_agent [-] Failed synchronizing routers

I am installing Havana and getting following error on neutron in l3-agent.log , dhcp_agent.log

2013-12-09 22:18:20.756 2510 ERROR neutron.agent.l3_agent [-] Failed synchronizing routers
2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent Traceback (most recent call last):
2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent   File "/usr/lib/python2.7/dist-packages/neutron/agent/l3_agent.py", line 750, in _sync_routers_task
2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent     context, router_ids)
2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent   File "/usr/lib/python2.7/dist-packages/neutron/agent/l3_agent.py", line 75, in get_routers
2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent     topic=self.topic)
2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent   File "/usr/lib/python2.7/dist-packages/neutron/openstack/common/rpc/proxy.py", line 130, in call
2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent     exc.info, real_topic, msg.get('method'))
2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent Timeout: Timeout while waiting on RPC response - topic: "q-l3-plugin", RPC method: "sync_routers" info: "<unknown>"
2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent
2013-12-09 22:18:20.756 2510 WARNING neutron.openstack.common.loopingcall [-] task run outlasted interval by 598.002945 sec
2013-12-09 22:18:20.756 2510 WARNING neutron.openstack.common.loopingcall [-] task run outlasted interval by 560.003462 sec

sec

I am getting following output after running command "ip a" a"

1: lo: <loopback,up,lower_up> <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <broadcast,multicast,up,lower_up> <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:50:56:91:56:56 brd ff:ff:ff:ff:ff:ff
    inet 172.16.17.18/16 brd 172.16.255.255 scope global eth0
    inet6 fe80::250:56ff:fe91:5656/64 scope link
       valid_lft forever preferred_lft forever
3: eth1: <broadcast,multicast,up,lower_up> <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:50:56:91:6c:43 brd ff:ff:ff:ff:ff:ff
    inet 172.16.17.111/16 brd 172.16.255.255 scope global eth1
    inet6 fe80::250:56ff:fe91:6c43/64 scope link
       valid_lft forever preferred_lft forever
4: eth2: <broadcast,multicast,promisc,up,lower_up> <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:50:56:91:32:e5 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::250:56ff:fe91:32e5/64 scope link
       valid_lft forever preferred_lft forever
5: ovs-system: <broadcast,multicast> <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN
    link/ether 5a:ef:48:02:d3:69 brd ff:ff:ff:ff:ff:ff
6: br-ex: <broadcast,up,lower_up> <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN
    link/ether 00:50:56:91:32:e5 brd ff:ff:ff:ff:ff:ff
    inet 172.16.17.113/16 brd 172.16.255.255 scope global br-ex
    inet6 fe80::5024:4aff:feba:5357/64 scope link
       valid_lft forever preferred_lft forever
7: br-int: <broadcast,up,lower_up> <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN
    link/ether ce:01:3d:b5:56:47 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::fc35:5bff:fe36:5361/64 scope link
       valid_lft forever preferred_lft forever
11: br-tun: <broadcast,up,lower_up> <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN
    link/ether 5a:e7:2a:e5:e1:49 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::84bd:d6ff:fef4:e7b2/64 scope link
       valid_lft forever preferred_lft forever

forever

I have disabled firewall on both network node and controller node.

Also I am getting following output on controller node : :

root@openstackvm17:~# neutron agent-list
+--------------------------------------+--------------------+---------------+-------+----------------+
| id                                   | agent_type         | host          | alive | admin_state_up |
+--------------------------------------+--------------------+---------------+-------+----------------+
| aaf278c5-b82e-4b13-bb5d-688a72048f38 | L3 agent           | openstackvm18 | :-)   | True           |
| b11374b4-a92a-4736-9c5c-ad82244b61c3 | DHCP agent         | openstackvm18 | :-)   | True           |
| bd26c9a9-7e89-4221-a497-f9f88521a31a | Open vSwitch agent | openstackvm18 | :-)   | True           |
+--------------------------------------+--------------------+---------------+-------+----------------+

+--------------------------------------+--------------------+---------------+-------+----------------+

openstackvm17 is my Controller and openstackvm18 is my network node.

Please help me to resolve this issue.

Thanks in advanced.

click to hide/show revision 3
No.3 Revision

I am installing Havana and getting following error on neutron in l3-agent.log , dhcp_agent.log ERROR neutron.agent.l3_agent [-] Failed failed synchronizing routersrouters ... rpc timeout

I am installing Havana and getting following error on neutron in l3-agent.log , dhcp_agent.log

2013-12-09 22:18:20.756 2510 ERROR neutron.agent.l3_agent [-] Failed synchronizing routers
2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent Traceback (most recent call last):
2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent   File "/usr/lib/python2.7/dist-packages/neutron/agent/l3_agent.py", line 750, in _sync_routers_task
2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent     context, router_ids)
2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent   File "/usr/lib/python2.7/dist-packages/neutron/agent/l3_agent.py", line 75, in get_routers
2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent     topic=self.topic)
2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent   File "/usr/lib/python2.7/dist-packages/neutron/openstack/common/rpc/proxy.py", line 130, in call
2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent     exc.info, real_topic, msg.get('method'))
2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent Timeout: Timeout while waiting on RPC response - topic: "q-l3-plugin", RPC method: "sync_routers" info: "<unknown>"
2013-12-09 22:18:20.756 2510 TRACE neutron.agent.l3_agent
2013-12-09 22:18:20.756 2510 WARNING neutron.openstack.common.loopingcall [-] task run outlasted interval by 598.002945 sec
2013-12-09 22:18:20.756 2510 WARNING neutron.openstack.common.loopingcall [-] task run outlasted interval by 560.003462 sec

I am getting following output after running command "ip a"

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:50:56:91:56:56 brd ff:ff:ff:ff:ff:ff
    inet 172.16.17.18/16 brd 172.16.255.255 scope global eth0
    inet6 fe80::250:56ff:fe91:5656/64 scope link
       valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:50:56:91:6c:43 brd ff:ff:ff:ff:ff:ff
    inet 172.16.17.111/16 brd 172.16.255.255 scope global eth1
    inet6 fe80::250:56ff:fe91:6c43/64 scope link
       valid_lft forever preferred_lft forever
4: eth2: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:50:56:91:32:e5 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::250:56ff:fe91:32e5/64 scope link
       valid_lft forever preferred_lft forever
5: ovs-system: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN
    link/ether 5a:ef:48:02:d3:69 brd ff:ff:ff:ff:ff:ff
6: br-ex: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN
    link/ether 00:50:56:91:32:e5 brd ff:ff:ff:ff:ff:ff
    inet 172.16.17.113/16 brd 172.16.255.255 scope global br-ex
    inet6 fe80::5024:4aff:feba:5357/64 scope link
       valid_lft forever preferred_lft forever
7: br-int: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN
    link/ether ce:01:3d:b5:56:47 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::fc35:5bff:fe36:5361/64 scope link
       valid_lft forever preferred_lft forever
11: br-tun: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN
    link/ether 5a:e7:2a:e5:e1:49 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::84bd:d6ff:fef4:e7b2/64 scope link
       valid_lft forever preferred_lft forever

I have disabled firewall on both network node and controller node.

Also I am getting following output on controller node :

root@openstackvm17:~# neutron agent-list
+--------------------------------------+--------------------+---------------+-------+----------------+
| id                                   | agent_type         | host          | alive | admin_state_up |
+--------------------------------------+--------------------+---------------+-------+----------------+
| aaf278c5-b82e-4b13-bb5d-688a72048f38 | L3 agent           | openstackvm18 | :-)   | True           |
| b11374b4-a92a-4736-9c5c-ad82244b61c3 | DHCP agent         | openstackvm18 | :-)   | True           |
| bd26c9a9-7e89-4221-a497-f9f88521a31a | Open vSwitch agent | openstackvm18 | :-)   | True           |
+--------------------------------------+--------------------+---------------+-------+----------------+

openstackvm17 is my Controller and openstackvm18 is my network node.

Please help me to resolve this issue.

Thanks in advanced.