Revision history [back]

click to hide/show revision 1
initial version

installing ceilometermiddleware via pip breaks openstack CLI

Hello and thanks for reading,

I'm trying to install OpenStack Kilo on Ubuntu 14.04 via the guide: http://docs.openstack.org/kilo/install-guide/install/apt/content/ch_preface.html

After trying to install Ceilometer I ran into this bug: https://bugs.launchpad.net/openstack-manuals/+bug/1462947

Seems like ceilometermiddleware isn't included in the ceilometer packages from ubuntu repositories. So I tried manually installing it with pip install ceilometermiddleware (pastebin output)

(I also manually installed an oslo.i18n package with pip to fix a similar issue with glance, but ceilometermiddleware seems to have installed the newer pbr, see pastebin^^)

This fixed my issue with ceilometer-client, however now any openstack command errors out...

ubuntu@stack-ctrl:~$ openstack user list
ERROR: openstackclient.shell Exception raised: (pbr 1.8.1 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('pbr>=0.6,!=0.7,<1.0'))

so I tried giving it the pbr package it wanted...

ubuntu@stack-ctrl:~$ sudo pip uninstall pbr
Uninstalling pbr:
...
  Successfully uninstalled pbr
ubuntu@stack-ctrl:~$ sudo pip install pbr==0.9
Downloading/unpacking pbr==0.9
  Downloading pbr-0.9.0-py2.py3-none-any.whl (63kB): 63kB downloaded
Requirement already satisfied (use --upgrade to upgrade): pip in /usr/lib/python2.7/dist-packages (from pbr==0.9)
Installing collected packages: pbr
  Found existing installation: pbr 0.10.0
    Not uninstalling pbr at /usr/lib/python2.7/dist-packages, owned by OS
Successfully installed pbr
Cleaning up...
ubuntu@stack-ctrl:~$ pip show pbr
---
Name: pbr
Version: 0.9.0
Location: /usr/local/lib/python2.7/dist-packages
Requires: pip

but I still get:

ubuntu@stack-ctrl:~$ openstack user list
ERROR: openstackclient.shell Exception raised: (pbr 0.9.0 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('pbr>=1.6'))

How can I satisfy openstack's dependency? Seems like the right version is installed and openstack is trying to use it (pbr 0.9.0)

installing ceilometermiddleware via pip breaks openstack CLI

Hello and thanks for reading,

I'm trying to install OpenStack Kilo on Ubuntu 14.04 via the guide: http://docs.openstack.org/kilo/install-guide/install/apt/content/ch_preface.html

After trying to install Ceilometer I ran into this bug: https://bugs.launchpad.net/openstack-manuals/+bug/1462947

Seems like ceilometermiddleware isn't included in the ceilometer packages from ubuntu repositories. So I tried manually installing it with pip install ceilometermiddleware (pastebin output)(output)

(I also manually installed an oslo.i18n package with pip to fix a similar issue with glance, but ceilometermiddleware seems to have installed the newer pbr, see pastebin^^)

This fixed my issue with ceilometer-client, however now any openstack command errors out...

ubuntu@stack-ctrl:~$ openstack user list
ERROR: openstackclient.shell Exception raised: (pbr 1.8.1 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('pbr>=0.6,!=0.7,<1.0'))

so I tried giving it the pbr package it wanted...

ubuntu@stack-ctrl:~$ sudo pip uninstall pbr
Uninstalling pbr:
...
  Successfully uninstalled pbr
ubuntu@stack-ctrl:~$ sudo pip install pbr==0.9
Downloading/unpacking pbr==0.9
  Downloading pbr-0.9.0-py2.py3-none-any.whl (63kB): 63kB downloaded
Requirement already satisfied (use --upgrade to upgrade): pip in /usr/lib/python2.7/dist-packages (from pbr==0.9)
Installing collected packages: pbr
  Found existing installation: pbr 0.10.0
    Not uninstalling pbr at /usr/lib/python2.7/dist-packages, owned by OS
Successfully installed pbr
Cleaning up...
ubuntu@stack-ctrl:~$ pip show pbr
---
Name: pbr
Version: 0.9.0
Location: /usr/local/lib/python2.7/dist-packages
Requires: pip

but I still get:

ubuntu@stack-ctrl:~$ openstack user list
ERROR: openstackclient.shell Exception raised: (pbr 0.9.0 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('pbr>=1.6'))

How can I satisfy openstack's dependency? Seems like the right version is installed and openstack is trying to use it (pbr 0.9.0)