Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Murano Install Complications

I have been tasked with installing murano in our openstack environment. Now from the looks of it based on its use in fuel murano should be able to be deployed outside of just dev stack.

We have an openstack instance that is running on KILO (soon to be upgraded to liberty) and most services are segregated onto seperate VM's. Which si where my problem comes in.

I am trying to install murano on a Ubuntu 14.04 vm to integrate it into our cloud to deploy applications. First off is this even supported/doable at this point? and second I need some help working through this error that I'm getting.

When running "tox -e venv -- murano-db-manage --config-file ./etc/murano/murano.conf upgrade" I am greeted with "sqlalchemy.exc.OperationalError: (sqlite3.OperationalError) near "DROP": syntax error [SQL: u'ALTER TABLE environment DROP COLUMN networking'] " then the upgrade command fails, then the venv commands fail.

I tried to ignore this, but a lot of other things fail afterwards, and it doesn't appear to work. I've tried building it up from scratch about 3 times now. so I'm not entirely sure what the problem is.