Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

nova-compute is down in nova service-list

We are installing Kilo over Ubuntu-14.04 over Virtual Box. Installed controller on one node and compute on another node. But "nova-compute is down in nova service-list".

root@controller:~# nova service-list

+----+------------------+------------+----------+---------+-------+----------------------------+-----------------+

| Id | Binary | Host | Zone | Status | State | Updated_at | Disabled Reason |

+----+------------------+------------+----------+---------+-------+----------------------------+-----------------+

| 1 | nova-cert | controller | internal | enabled | up | 2015-09-14T13:58:09.000000 | - |

| 2 | nova-consoleauth | controller | internal | enabled | up | 2015-09-14T13:58:07.000000 | - |

| 3 | nova-scheduler | controller | internal | enabled | up | 2015-09-14T13:58:01.000000 | - |

| 4 | nova-conductor | controller | internal | enabled | up | 2015-09-14T13:58:04.000000 | - |

| 5 | nova-compute | compute1 | nova | enabled | down | - | - |

+----+------------------+------------+----------+---------+-------+----------------------------+-----------------+ root@controller:~#

In the Compute, I observed the error message as shown below :- nova-compute.log

raise exception.ComputeHostNotFound(host=host) ComputeHostNotFound: Compute host compute1 could not be found.

Can anyone guide me how to debug the issue ?

nova-compute is down in nova service-list

We are installing Kilo over Ubuntu-14.04 over Virtual Box. Installed controller on one node and compute on another node. But "nova-compute is down in nova service-list".

root@controller:~# nova service-list

+----+------------------+------------+----------+---------+-------+----------------------------+-----------------+

service-list +----+------------------+------------+----------+---------+-------+----------------------------+-----------------+ | Id | Binary | Host | Zone | Status | State | Updated_at | Disabled Reason |

+----+------------------+------------+----------+---------+-------+----------------------------+-----------------+

| +----+------------------+------------+----------+---------+-------+----------------------------+-----------------+ | 1 | nova-cert | controller | internal | enabled | up | 2015-09-14T13:58:09.000000 | - |

| | 2 | nova-consoleauth | controller | internal | enabled | up | 2015-09-14T13:58:07.000000 | - |

| | 3 | nova-scheduler | controller | internal | enabled | up | 2015-09-14T13:58:01.000000 | - |

| | 4 | nova-conductor | controller | internal | enabled | up | 2015-09-14T13:58:04.000000 | - |

| | 5 | nova-compute | compute1 | nova | enabled | down | - | - |

| +----+------------------+------------+----------+---------+-------+----------------------------+-----------------+ root@controller:~#

root@controller:~#

In the Compute, I observed the error message as shown below :- nova-compute.log

raise exception.ComputeHostNotFound(host=host)
ComputeHostNotFound: Compute host compute1 could not be found.

found.

Can anyone guide me how to debug the issue ?