Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

not able to connect instance neutron networking enabled

Hi All,

I have enabled the neutron networking and able to boot the instance , also the instance is getting the ip address automatically. But i am not able to ping and ssh it . Below is the rules and configuration i have made for it. So please suggest what i have to do to allow the networking work for the instance.

Please let me know if more info required.

[root@controller ~(keystone)]# nova list +--------------------------------------+-------+--------+------------+-------------+------------------------------------+ | ID | Name | Status | Task State | Power State | Networks | +--------------------------------------+-------+--------+------------+-------------+------------------------------------+ | 848ecad0-da0b-474f-bf71-379e2797c8bf | cloud | ACTIVE | - | Running | int_net=192.168.100.3, 172.0.0.102 | +--------------------------------------+-------+--------+------------+-------------+------------------------------------+ [root@controller ~(keystone)]#

[root@controller ~(keystone)]# neutron net-list +--------------------------------------+---------+-------------------------------------------------------+ | id | name | subnets | +--------------------------------------+---------+-------------------------------------------------------+ | 101ac2f6-99c8-41c2-8788-044ae0dbe789 | ext_net | f99c7984-5d66-4c5f-b17e-c4c9aec5ea4f 172.0.0.0/24 | | 8a5b893e-7ea1-45cb-ae5f-aa0c8d7c33da | int_net | 24de6473-6984-471c-bdd7-477c9b02198b 192.168.100.0/24 | +--------------------------------------+---------+-------------------------------------------------------+ [root@controller ~(keystone)]#

configuration setting

/etc/neutron/plugins/ml2/ml2_conf.ini

near line 64: add

[ml2_type_vlan] network_vlan_ranges = physnet1:1000:2999

add to the end

[ovs] tenant_network_type = vlan bridge_mappings = physnet1:br-eth1

[root@controller ~(keystone)]# cat /etc/sysconfig/network-scripts/ifcfg-eth1 HWADDR=08:00:27:60:0a:72 DEVICE=eth1 TYPE=Ethernet ONBOOT=yes PROMISC=yes BRIDGE=br-eth1 [root@controller ~(keystone)]# cat /etc/sysconfig/network-scripts/ifcfg-eth2 HWADDR=08:00:27:03:20:36 DEVICE=eth2 TYPE=Ethernet ONBOOT=yes PROMISC=yes BRIDGE=br-ext [root@controller ~(keystone)]# cat /etc/sysconfig/network-scripts/ifcfg-br-ext DEVICE=br-ext TYPE=Bridge BOOTPROTO=dhcp

BOOTPROTO=static

IPADDR=10.0.0.65

NETMASK=255.255.255.0

ONBOOT=yes [root@controller ~(keystone)]# cat /etc/sysconfig/network-scripts/ifcfg-br-eth1 DEVICE=br-eth1 TYPE=Bridge BOOTPROTO=dhcp

BOOTPROTO=static

IPADDR=192.168.100.45

NETMASK=255.255.255.0

ONBOOT=yes [root@controller ~(keystone)]#

[root@controller ~(keystone)]# ip a 1: lo: <loopback,up,lower_up> mtu 65536 qdisc noqueue state UNKNOWN link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 inet 127.0.0.1/8 scope host lo valid_lft forever preferred_lft forever inet 169.254.169.254/32 scope link lo valid_lft forever preferred_lft forever inet6 ::1/128 scope host valid_lft forever preferred_lft forever 2: eth0: <broadcast,multicast,up,lower_up> mtu 1500 qdisc pfifo_fast state UP qlen 1000 link/ether 08:00:27:0d:97:ec brd ff:ff:ff:ff:ff:ff inet 10.11.138.75/24 brd 10.11.138.255 scope global dynamic eth0 valid_lft 863428sec preferred_lft 863428sec inet 10.0.0.249/32 scope global eth0 valid_lft forever preferred_lft forever inet 10.0.0.250/32 scope global eth0 valid_lft forever preferred_lft forever inet 10.0.0.251/32 scope global eth0 valid_lft forever preferred_lft forever inet 10.0.0.252/32 scope global eth0 valid_lft forever preferred_lft forever inet6 fe80::a00:27ff:fe0d:97ec/64 scope link valid_lft forever preferred_lft forever 3: eth1: <broadcast,multicast,up,lower_up> mtu 1500 qdisc pfifo_fast master ovs-system state UP qlen 1000 link/ether 08:00:27:60:0a:72 brd ff:ff:ff:ff:ff:ff 4: eth2: <broadcast,multicast,up,lower_up> mtu 1500 qdisc pfifo_fast master ovs-system state UP qlen 1000 link/ether 08:00:27:03:20:36 brd ff:ff:ff:ff:ff:ff 5: eth3: <broadcast,multicast,up,lower_up> mtu 1500 qdisc pfifo_fast state UP qlen 1000 link/ether 08:00:27:ee:52:29 brd ff:ff:ff:ff:ff:ff inet 10.0.0.30/24 brd 10.0.0.255 scope global eth3 valid_lft forever preferred_lft forever inet6 fe80::a00:27ff:feee:5229/64 scope link valid_lft forever preferred_lft forever 6: ovs-system: <broadcast,multicast> mtu 1500 qdisc noop state DOWN link/ether be:b3:01:44:37:71 brd ff:ff:ff:ff:ff:ff 7: br-ext: <broadcast,multicast,up,lower_up> mtu 1500 qdisc noqueue state UNKNOWN link/ether 08:00:27:03:20:36 brd ff:ff:ff:ff:ff:ff inet 10.11.138.66/24 brd 10.11.138.255 scope global dynamic br-ext valid_lft 863428sec preferred_lft 863428sec inet6 fe80::a00:27ff:fe03:2036/64 scope link valid_lft forever preferred_lft forever 9: br-eth1: <broadcast,multicast,up,lower_up> mtu 1500 qdisc noqueue state UNKNOWN link/ether 08:00:27:60:0a:72 brd ff:ff:ff:ff:ff:ff inet 10.11.138.62/24 brd 10.11.138.255 scope global dynamic br-eth1 valid_lft 863428sec preferred_lft 863428sec inet6 fe80::a00:27ff:fe60:a72/64 scope link valid_lft forever preferred_lft forever 10: gw-ea204113-20: <broadcast,multicast> mtu 1500 qdisc noop state DOWN link/ether 5a:41:4e:4e:f2:5e brd ff:ff:ff:ff:ff:ff inet 10.1.0.1/24 brd 10.1.0.255 scope global gw-ea204113-20 valid_lft forever preferred_lft forever 12: br-int: <broadcast,multicast> mtu 1500 qdisc noop state DOWN link/ether 66:fe:f9:47:ac:43 brd ff:ff:ff:ff:ff:ff 15: dummy0: <broadcast,noarp,up,lower_up> mtu 1500 qdisc noqueue state UNKNOWN link/ether 3e:25:89:1d:77:cd brd ff:ff:ff:ff:ff:ff inet6 fe80::3c25:89ff:fe1d:77cd/64 scope link valid_lft forever preferred_lft forever 16: virbr0: <no-carrier,broadcast,multicast,up> mtu 1500 qdisc noqueue state DOWN link/ether 52:54:00:25:8b:83 brd ff:ff:ff:ff:ff:ff inet 192.168.122.1/24 brd 192.168.122.255 scope global virbr0 valid_lft forever preferred_lft forever 17: virbr0-nic: <broadcast,multicast> mtu 1500 qdisc pfifo_fast master virbr0 state DOWN qlen 500 link/ether 52:54:00:25:8b:83 brd ff:ff:ff:ff:ff:ff 18: qbrb53d2059-c0: <broadcast,multicast,up,lower_up> mtu 1500 qdisc noqueue state UP link/ether ca:df:29:c1:6e:86 brd ff:ff:ff:ff:ff:ff inet6 fe80::c8df:29ff:fec1:6e86/64 scope link valid_lft forever preferred_lft forever 19: qvob53d2059-c0: <broadcast,multicast,promisc,up,lower_up> mtu 1500 qdisc pfifo_fast master ovs-system state UP qlen 1000 link/ether 96:76:4b:1c:66:8e brd ff:ff:ff:ff:ff:ff inet6 fe80::9476:4bff:fe1c:668e/64 scope link valid_lft forever preferred_lft forever 20: qvbb53d2059-c0: <broadcast,multicast,promisc,up,lower_up> mtu 1500 qdisc pfifo_fast master qbrb53d2059-c0 state UP qlen 1000 link/ether ca:df:29:c1:6e:86 brd ff:ff:ff:ff:ff:ff inet6 fe80::c8df:29ff:fec1:6e86/64 scope link valid_lft forever preferred_lft forever 21: tapb53d2059-c0: <broadcast,multicast,up,lower_up> mtu 1500 qdisc pfifo_fast master qbrb53d2059-c0 state UNKNOWN qlen 500 link/ether fe:16:3e:cc:68:d1 brd ff:ff:ff:ff:ff:ff inet6 fe80::fc16:3eff:fecc:68d1/64 scope link valid_lft forever preferred_lft forever [root@controller ~(keystone)]#

[root@controller ~(keystone)]# ovs-vsctl show 802024d2-a798-4a42-b883-9860f3aed133 Bridge "br-eth1" Port "br-eth1" Interface "br-eth1" type: internal Port "eth1" Interface "eth1" Port "phy-br-eth1" Interface "phy-br-eth1" type: patch options: {peer="int-br-eth1"} Bridge br-int fail_mode: secure Port "tap1ff00fe0-5c" tag: 2 Interface "tap1ff00fe0-5c" type: internal Port "tap5c6b33b0-e3" tag: 1 Interface "tap5c6b33b0-e3" type: internal Port "int-br-eth1" Interface "int-br-eth1" type: patch options: {peer="phy-br-eth1"} Port "qr-ff490e84-e6" tag: 1 Interface "qr-ff490e84-e6" type: internal Port "qvob53d2059-c0" tag: 1 Interface "qvob53d2059-c0" Port "gw-ea204113-20" tag: 4095 Interface "gw-ea204113-20" type: internal Port br-int Interface br-int type: internal Bridge br-ext Port "qg-11c4f78e-ee" Interface "qg-11c4f78e-ee" type: internal Port br-ext Interface br-ext type: internal Port "eth2" Interface "eth2" ovs_version: "2.3.1" [root@controller ~(keystone)]#

not able to connect instance neutron networking enabled

Hi All,

I have enabled the neutron networking and able to boot the instance , also the instance is getting the ip address automatically. But i am not able to ping and ssh it . Below is the rules and configuration i have made for it. So please suggest what i have to do to allow the networking work for the instance.

Please let me know if more info required.

[root@controller ~(keystone)]# nova list
+--------------------------------------+-------+--------+------------+-------------+------------------------------------+
| ID                                   | Name  | Status | Task State | Power State | Networks                           |
+--------------------------------------+-------+--------+------------+-------------+------------------------------------+
| 848ecad0-da0b-474f-bf71-379e2797c8bf | cloud | ACTIVE | -          | Running     | int_net=192.168.100.3, 172.0.0.102 |
+--------------------------------------+-------+--------+------------+-------------+------------------------------------+
[root@controller ~(keystone)]#

~(keystone)]# [root@controller ~(keystone)]# neutron net-list +--------------------------------------+---------+-------------------------------------------------------+ | id | name | subnets | +--------------------------------------+---------+-------------------------------------------------------+ | 101ac2f6-99c8-41c2-8788-044ae0dbe789 | ext_net | f99c7984-5d66-4c5f-b17e-c4c9aec5ea4f 172.0.0.0/24 | | 8a5b893e-7ea1-45cb-ae5f-aa0c8d7c33da | int_net | 24de6473-6984-471c-bdd7-477c9b02198b 192.168.100.0/24 | +--------------------------------------+---------+-------------------------------------------------------+ [root@controller ~(keystone)]#

~(keystone)]#

configuration setting

/etc/neutron/plugins/ml2/ml2_conf.ini

/etc/neutron/plugins/ml2/ml2_conf.ini
# near line 64: add

add [ml2_type_vlan] network_vlan_ranges = physnet1:1000:2999

physnet1:1000:2999 # add to the end

end [ovs] tenant_network_type = vlan bridge_mappings = physnet1:br-eth1

physnet1:br-eth1 [root@controller ~(keystone)]# cat /etc/sysconfig/network-scripts/ifcfg-eth1 HWADDR=08:00:27:60:0a:72 DEVICE=eth1 TYPE=Ethernet ONBOOT=yes PROMISC=yes BRIDGE=br-eth1 [root@controller ~(keystone)]# cat /etc/sysconfig/network-scripts/ifcfg-eth2 HWADDR=08:00:27:03:20:36 DEVICE=eth2 TYPE=Ethernet ONBOOT=yes PROMISC=yes BRIDGE=br-ext [root@controller ~(keystone)]# cat /etc/sysconfig/network-scripts/ifcfg-br-ext DEVICE=br-ext TYPE=Bridge BOOTPROTO=dhcp

BOOTPROTO=static

IPADDR=10.0.0.65

NETMASK=255.255.255.0

BOOTPROTO=dhcp #BOOTPROTO=static #IPADDR=10.0.0.65 #NETMASK=255.255.255.0 ONBOOT=yes [root@controller ~(keystone)]# cat /etc/sysconfig/network-scripts/ifcfg-br-eth1 DEVICE=br-eth1 TYPE=Bridge BOOTPROTO=dhcp

BOOTPROTO=static

IPADDR=192.168.100.45

NETMASK=255.255.255.0

BOOTPROTO=dhcp #BOOTPROTO=static #IPADDR=192.168.100.45 #NETMASK=255.255.255.0 ONBOOT=yes [root@controller ~(keystone)]#

~(keystone)]# [root@controller ~(keystone)]# ip a 1: lo: <loopback,up,lower_up> <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 inet 127.0.0.1/8 scope host lo valid_lft forever preferred_lft forever inet 169.254.169.254/32 scope link lo valid_lft forever preferred_lft forever inet6 ::1/128 scope host valid_lft forever preferred_lft forever 2: eth0: <broadcast,multicast,up,lower_up> <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000 link/ether 08:00:27:0d:97:ec brd ff:ff:ff:ff:ff:ff inet 10.11.138.75/24 brd 10.11.138.255 scope global dynamic eth0 valid_lft 863428sec preferred_lft 863428sec inet 10.0.0.249/32 scope global eth0 valid_lft forever preferred_lft forever inet 10.0.0.250/32 scope global eth0 valid_lft forever preferred_lft forever inet 10.0.0.251/32 scope global eth0 valid_lft forever preferred_lft forever inet 10.0.0.252/32 scope global eth0 valid_lft forever preferred_lft forever inet6 fe80::a00:27ff:fe0d:97ec/64 scope link valid_lft forever preferred_lft forever 3: eth1: <broadcast,multicast,up,lower_up> <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP qlen 1000 link/ether 08:00:27:60:0a:72 brd ff:ff:ff:ff:ff:ff 4: eth2: <broadcast,multicast,up,lower_up> <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP qlen 1000 link/ether 08:00:27:03:20:36 brd ff:ff:ff:ff:ff:ff 5: eth3: <broadcast,multicast,up,lower_up> <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000 link/ether 08:00:27:ee:52:29 brd ff:ff:ff:ff:ff:ff inet 10.0.0.30/24 brd 10.0.0.255 scope global eth3 valid_lft forever preferred_lft forever inet6 fe80::a00:27ff:feee:5229/64 scope link valid_lft forever preferred_lft forever 6: ovs-system: <broadcast,multicast> <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN link/ether be:b3:01:44:37:71 brd ff:ff:ff:ff:ff:ff 7: br-ext: <broadcast,multicast,up,lower_up> <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN link/ether 08:00:27:03:20:36 brd ff:ff:ff:ff:ff:ff inet 10.11.138.66/24 brd 10.11.138.255 scope global dynamic br-ext valid_lft 863428sec preferred_lft 863428sec inet6 fe80::a00:27ff:fe03:2036/64 scope link valid_lft forever preferred_lft forever 9: br-eth1: <broadcast,multicast,up,lower_up> <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN link/ether 08:00:27:60:0a:72 brd ff:ff:ff:ff:ff:ff inet 10.11.138.62/24 brd 10.11.138.255 scope global dynamic br-eth1 valid_lft 863428sec preferred_lft 863428sec inet6 fe80::a00:27ff:fe60:a72/64 scope link valid_lft forever preferred_lft forever 10: gw-ea204113-20: <broadcast,multicast> <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN link/ether 5a:41:4e:4e:f2:5e brd ff:ff:ff:ff:ff:ff inet 10.1.0.1/24 brd 10.1.0.255 scope global gw-ea204113-20 valid_lft forever preferred_lft forever 12: br-int: <broadcast,multicast> <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN link/ether 66:fe:f9:47:ac:43 brd ff:ff:ff:ff:ff:ff 15: dummy0: <broadcast,noarp,up,lower_up> <BROADCAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN link/ether 3e:25:89:1d:77:cd brd ff:ff:ff:ff:ff:ff inet6 fe80::3c25:89ff:fe1d:77cd/64 scope link valid_lft forever preferred_lft forever 16: virbr0: <no-carrier,broadcast,multicast,up> <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN link/ether 52:54:00:25:8b:83 brd ff:ff:ff:ff:ff:ff inet 192.168.122.1/24 brd 192.168.122.255 scope global virbr0 valid_lft forever preferred_lft forever 17: virbr0-nic: <broadcast,multicast> <BROADCAST,MULTICAST> mtu 1500 qdisc pfifo_fast master virbr0 state DOWN qlen 500 link/ether 52:54:00:25:8b:83 brd ff:ff:ff:ff:ff:ff 18: qbrb53d2059-c0: <broadcast,multicast,up,lower_up> <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP link/ether ca:df:29:c1:6e:86 brd ff:ff:ff:ff:ff:ff inet6 fe80::c8df:29ff:fec1:6e86/64 scope link valid_lft forever preferred_lft forever 19: qvob53d2059-c0: <broadcast,multicast,promisc,up,lower_up> <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP qlen 1000 link/ether 96:76:4b:1c:66:8e brd ff:ff:ff:ff:ff:ff inet6 fe80::9476:4bff:fe1c:668e/64 scope link valid_lft forever preferred_lft forever 20: qvbb53d2059-c0: <broadcast,multicast,promisc,up,lower_up> <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master qbrb53d2059-c0 state UP qlen 1000 link/ether ca:df:29:c1:6e:86 brd ff:ff:ff:ff:ff:ff inet6 fe80::c8df:29ff:fec1:6e86/64 scope link valid_lft forever preferred_lft forever 21: tapb53d2059-c0: <broadcast,multicast,up,lower_up> <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master qbrb53d2059-c0 state UNKNOWN qlen 500 link/ether fe:16:3e:cc:68:d1 brd ff:ff:ff:ff:ff:ff inet6 fe80::fc16:3eff:fecc:68d1/64 scope link valid_lft forever preferred_lft forever [root@controller ~(keystone)]#

~(keystone)]# [root@controller ~(keystone)]# ovs-vsctl show 802024d2-a798-4a42-b883-9860f3aed133 Bridge "br-eth1" Port "br-eth1" Interface "br-eth1" type: internal Port "eth1" Interface "eth1" Port "phy-br-eth1" Interface "phy-br-eth1" type: patch options: {peer="int-br-eth1"} Bridge br-int fail_mode: secure Port "tap1ff00fe0-5c" tag: 2 Interface "tap1ff00fe0-5c" type: internal Port "tap5c6b33b0-e3" tag: 1 Interface "tap5c6b33b0-e3" type: internal Port "int-br-eth1" Interface "int-br-eth1" type: patch options: {peer="phy-br-eth1"} Port "qr-ff490e84-e6" tag: 1 Interface "qr-ff490e84-e6" type: internal Port "qvob53d2059-c0" tag: 1 Interface "qvob53d2059-c0" Port "gw-ea204113-20" tag: 4095 Interface "gw-ea204113-20" type: internal Port br-int Interface br-int type: internal Bridge br-ext Port "qg-11c4f78e-ee" Interface "qg-11c4f78e-ee" type: internal Port br-ext Interface br-ext type: internal Port "eth2" Interface "eth2" ovs_version: "2.3.1" [root@controller ~(keystone)]#

~(keystone)]#