Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

vpnaas on kilo

I followed the manual to install kilo: http://docs.openstack.org/kilo/install-guide/install/apt/content/

This is all working fine, thanks for the good documentation. I am able to start a VM through openstack.

Now I am trying to add the vpnaas to the OpenStack implementation and this is where I am getting stuck.

On the network node I installed the 'neutron-vpn-agent'. I than edited the following files: /etc/neutron/vpn_agent.ini:

[DEFAULT]
interface_driver = neutron.agent.linux.interface.OVSInterfaceDriver
external_network_bridge =
router_delete_namespaces = True

[vpnagent]
vpn_device_driver=neutron_vpnaas.services.vpn.device_drivers.strongswan_ipsec.StrongSwanDriver

/etc/neutron/neutron.conf: Added vpnaas to the service_plugins

After that I restarted the neutron-vpn-agent and verified that there are no errors in the logfile at (/var/log/neutron/neutron-vpn-agent.log)

Then on the controller node I tried: neutron vpn-service-list

But that failed with: 404 Resource not found.

I obviously am missing something but I cannot find out what. Also the documentation on installing vpnaas is not available, searching with google didn't give me a suitable answer either...

So how do I need to proceed, what am I missing?

vpnaas on kilo

I followed the manual to install kilo: http://docs.openstack.org/kilo/install-guide/install/apt/content/

This is all working fine, thanks for the good documentation. I am able to start a VM through openstack.

Now I am trying to add the vpnaas to the OpenStack implementation and this is where I am getting stuck.

On the network node I installed the 'neutron-vpn-agent'. I than edited the following files: /etc/neutron/vpn_agent.ini:

[DEFAULT]
interface_driver = neutron.agent.linux.interface.OVSInterfaceDriver
external_network_bridge =
router_delete_namespaces = True

[vpnagent]
vpn_device_driver=neutron_vpnaas.services.vpn.device_drivers.strongswan_ipsec.StrongSwanDriver

/etc/neutron/neutron.conf: Added vpnaas to the service_plugins

After that I restarted the neutron-vpn-agent and verified that there are no errors in the logfile at (/var/log/neutron/neutron-vpn-agent.log)

Then on the controller node I tried: neutron vpn-service-list

But that failed with: 404 Resource not found.

I obviously am missing something but I cannot find out what. Also the documentation on installing vpnaas is not available, searching with google didn't give me a suitable answer either...

So how do I need to proceed, what am I missing?