Ask Your Question

Revision history [back]

Unable to launch instances in ARM

I am trying openstack on arm64. I Installed openstack using devstack and tried launching instances via dashboard as well as command line. The status of the instance is being shown as running(both on dashboard and virsh list) but nothing is getting logged in the console.log file.

I tried cirros-0.3.4-x86_64-uec, trusty-server-cloudimg-arm64-disk1.img and precise-server-cloudimg-i386-disk1.img images same result with all of them.

When I tried to execute the following command(The command generated by openstack for launching instances) from command line,

`qemu-system-aarch64 -name instance-00000006 -S -machine virt,accel=kvm,usb=off -cpu host -m 512 -realtime mlock=off -smp 1,sockets=1,cores=1,threads=1 -uuid 4a31ab6b-d65f-4dfb-8f1c-ed95f5553ec4 -nographic -no-user-config -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/instance-00000006.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc,driftfix=slew -no-shutdown -boot strict=on -usb -drive file=/opt/stack/data/nova/instances/4a31ab6b-d65f-4dfb-8f1c-ed95f5553ec4/disk,if=none,id=drive-virtio-disk0,format=qcow2,cache=none -device virtio-blk-device,scsi=off,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -drive file=/opt/stack/data/nova/instances/4a31ab6b-d65f-4dfb-8f1c-ed95f5553ec4/disk.eph0,if=none,id=drive-virtio-disk1,format=qcow2,cache=none -device virtio-blk-device,scsi=off,drive=drive-virtio-disk1,id=virtio-disk1 -drive file=/opt/stack/data/nova/instances/4a31ab6b-d65f-4dfb-8f1c-ed95f5553ec4/disk.config,if=none,media=cdrom,id=drive-virtio-disk25,readonly=on,format=raw,cache=none -device virtio-blk-device,scsi=off,drive=drive-virtio-disk25,id=virtio-disk25 -netdev tap,fd=23,id=hostnet0 -device virtio-net-device,netdev=hostnet0,id=net0,mac=fa:16:3e:27:92:27 -serial file:/opt/stack/data/nova/instances/4a31ab6b-d65f-4dfb-8f1c-ed95f5553ec4/console.log -serial pty -device virtio-balloon-device,id=balloon0`

the result is the same and I dont get any log. But, The images boots fine and I am able to get the boot log, if I supply a kernel using the additional parameter -kernel <path to kernel image> otherwise not (The kernel used is our own custom built one for arm64)

While googling I found a similar question HERE But don't have any conclusion.

Am I doing something wrong? Am I supposed to pass a kernel with these Images, if yes how do I do that in openstack?